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1.1 Introduction to Computer 

1.1.1 Definition 

 

 A computer is a device that accepts information (in the form of digitalized data) 

and manipulates it for some result based on a program, software, or sequence of 

instructions on how the data is to be processed. 

1.1.2 History & Generation of Computer 

First Generation 

● The period 1940 to 1956, roughly considered as the First Generation of 

Computer. 

● The first generation computers were developed by using vacuum tube or 

thermionic valve machine. 
 

 
 

● The input of this system was based on punched cards and paper tape; however, 

the output was displayed on printouts. 

● The first generation computers worked on binary-coded concept (i.e., language of 

0-1). Examples: ENIAC, EDVAC, etc. 

 

Second Generation 

● The period 1956 to 1963 is roughly considered as the period of Second 

Generation of Computers. 

● The second generation computers were developed by using transistor technology. 
 

 
 

● In comparison to the first generation, the size of second generation was smaller. 

● In comparison to computers of the first generation, the computing time taken by 

the computers of the second generation was lesser. 

 

Third Generation 

● The period 1963 to 1971 is roughly considered as the period of Third Generation 

of computers. 
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● The third generation computers were developed by using the Integrated Circuit (IC) 

technology 

● In comparison to the computers of the second generation, the size of the 

computers of the third generation was smaller. 

● In comparison to the computers of the second generation, the computing time 

taken by the computers of the third generation was lesser. 
 

 

● The third generation computer consumed less power and also generated less 

heat. 

● The maintenance cost of the computers in the third generation was also low. 

● The computer system of the computers of the third generation was easier for 

commercial use. 

 

Fourth Generation 

● The period 1972 to 2010 is roughly considered as the fourth generation of 

computers. 

● The fourth generation computers were developed by using microprocessor 

technology. 

 

● By coming to fourth generation, computer became very small in size, it became 

portable. 

● The machine of fourth generation started generating very low amount of heat. 

● It is much faster and accuracy became more reliable. 

● The production cost reduced to very low in comparison to the previous generation. 

● It became available for the common people as well. 

 

Fifth Generation 

● The period 2010 to till date and beyond, roughly considered as the period of fifth 

generation of computers. 

● By the time, the computer generation was being categorized on the basis of 

hardware only, but the fifth generation technology also included software. 
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● The computers of the fifth generation had high capability and large memory 

capacity. 

● Working with computers of this generation was fast and multiple tasks could be 

performed simultaneously. 

● Some of the popular advanced technologies of the fifth generation include 

Artificial intelligence, Quantum computation, Nanotechnology, Parallel processing, 

etc. 

 

1.1.3 Applications of Computer 

● Home  

● Medical Field 

● Entertainment 

● Industry 

● Education 

● Government 

● Banking 

● Business 

 

Home 

Computers are used at homes for several purposes like online bill payment, watching 

movies or shows at home, home tutoring, social media access, playing games, internet 

access, etc. They provide communication through electronic mail. They help to avail work 

from home facility for corporate employees. Computers help the student community to 

avail online educational support. 

Medical Field 

Computers are used in hospitals to maintain a database of patients‘ history, diagnosis, X-

rays, live monitoring of patients, etc. Surgeons nowadays use robotic surgical devices to 

perform delicate operations, and conduct surgeries remotely. Virtual reality technologies 

are also used for training purposes. It also helps to monitor the fetus inside the mother‘s 

womb. 

Entertainment 

Computers help to watch movies online, play games online; act as a virtual entertainer in 

playing games, listening to music, etc. MIDI instruments greatly help people in the 

entertainment industry in recording music with artificial instruments. Videos can be fed 



P a g e  | 13 

 

from computers to full screen televisions. Photo editors are available with fabulous 

features. 

Industry 

Computers are used to perform several tasks in industries like managing inventory, 

designing purpose, creating virtual sample products, interior designing, video 

conferencing, etc. Online marketing has seen a great revolution in its ability to sell 

various products to inaccessible corners like interior or rural areas. Stock markets have 

seen phenomenal participation from different levels of people through the use of 

computers. 

Education 

Computers are used in education sector through online classes, online examinations, 

referring e-books, online tutoring, etc. They help in increased use of audio-visual aids in 

the education field. 

Government 

In government sectors, computers are used in data processing, maintaining a database 

of citizens and supporting a paperless environment. The country‘s defense organizations 

have greatly benefitted from computers in their use for missile development, satellites, 

rocket launches, etc. 

Banking 

In the banking sector, computers are used to store details of customers and conduct 

transactions, such as withdrawal and deposit of money through ATMs. Banks have 

reduced manual errors and expenses to a great extent through extensive use of 

computers. 

Business 

Nowadays, computers are totally integrated into business. The main objective of 

business is transaction processing, which involves transactions with suppliers, 

employees or customers. Computers can make these transactions easy and accurate. 

People can analyze investments, sales, expenses, markets and other aspects of 

business using computers. 

Training 

Many organizations use computer-based training to train their employees, to save money 

and improve performance. Video conferencing through computers allows saving of time 

and travelling costs by being able to connect people in various locations. 

Arts 

Computers are extensively used in dance, photography, arts and culture. The fluid 

movement of dance can be shown live via animation. Photos can be digitized using 

computers. 

 



P a g e  | 14 

 

Science and Engineering 

Computers with high performance are used to stimulate dynamic process in Science and 

Engineering. Supercomputers have numerous applications in area of Research and 

Development (R&D). Topographic images can be created through computers. Scientists 

use computers to plot and analyze data to have a better understanding of earthquakes. 

1.1.4 Advantages of Computer 

● Stores huge amount of data 

● Accuracy 

● Increases your productivity.   

● Internet connection.   

● Organizes the information.   

● Keeps everyone connected.   

● Helps to automate.   

● Help physically challenged. 

 

1.1.5 Terms related to Computer 

1.1.5.1 Hardware 

These computer science terms connect to the physical components of a computer. 

Hardware represents the most tactile aspects of computer science and the materials 

computers are made of. 

1. CPU 

CPU stands for the Central Processing Unit. It is the processing chip that serves as the 

"brains" of a device that interprets (or processes) the digital instructions provided by 

applications. 

2. Bit 

Bit is an abbreviation for ―binary digit,‖ the smallest piece of information used by a 

computer. Each bit is either a 1 or a 0, which are the binary digits that make up computer 

language. Bits are literally the foundation upon which computer science is built. In 

modern computing, information is stored and processed at a scale that is orders of 

magnitude larger than individual bits. See the conversion rate below to better 

contextualize the size of a bit: 

● 1 Byte = 8 bits 

● 1 Kilobyte = 1,024 bytes 

● 1 Megabyte = 1,024 kilobytes 

● 1 Gigabyte = 1,024 megabytes 

 

3. RAM 

Random Access Memory (RAM) is the hardware component used to store data that is 

actively being used by a processor. When needed, information flows to RAM storage from 

long-term secondary storage—typically a hard drive. 
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4. Secondary storage 

Secondary storage refers to the long-term data storage options found in a device. This 

includes hard disk drives (HDD) and solid-state drives (SSD). When you save a file to your 

computer, it is sent to secondary storage. 

5. ROM 

ROM stands for Read-Only Memory. This is memory that can only be read from and is not 

electronically modifiable after being manufactured. Computers use ROM to store critical 

foundational information like start-up processes and software instructions. 

6. Input/Output Devices (I/O Devices) 

I/O devices refer to anything people use to input information to the computer or to take 

information out (output). For example, a keyboard and mouse are input devices. A printer 

is an output device. 

 

1.1.5.2 Software 

The physical components of devices are only the tip of the iceberg. Much of the computer 

science field focuses on software applications and their development. 

7. Algorithm 

At a basic level, algorithms are simply specific procedures used to solve computational 

problems. As computing power and data capabilities have grown more sophisticated, so 

have the algorithms and the problems they intend to solve. For example, a shipping 

company may turn to an algorithm to help determine the optimal route for delivery 

drivers. 

8. API (Application Programming Interface) 

An API is a software go-between that brings information from one application to another. 

It allows applications to communicate with one another while preserving some security 

measures for each end point. For example, an API can be used to securely transfer data 

stored by your web browser to a mobile app. 

9. Boolean 

A function in programming with binary choices, like ―Yes or No‖ and ―True or False.‖ This 

serves as a basic building block of programming logic. 

10. Bug 

A bug is a programming error that causes unexpected glitches or problems for a 

program‘s end user. Debugging is the process of identifying, documenting and fixing the 

issues caused by bugs. 

11. Camel Case 

Camel case refers to the practice of capitalizing the first letter of each compound word in 

a programming variable to improve readability. For example, ―StretchLength‖ and 

―FixedHeight.‖ 
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12. Code 

Code refers to the string of commands or directions used by different programming 

languages in order to create, edit or manage computer programs or applications. Code is 

used by computers to determine which action should be taken, define parameters and 

more. 

13. Compiling 

The process of taking code that‘s written in a high-level language (like C++) by human 

developers and translating it into machine-readable code. 

14. Conditional statements 

Conditional statements, another fundamental piece of programming instructions, set the 

terms for when a program moves forward. This is often expressed in an ―If, then‖ format. 

If all conditions expressed are met and true, only then will the computer move on to do 

the next step. 

15. Integrated Development Environment (IDE) 

An integrated development environment is a software tool where developers can write 

code and run their programs. Many provide useful features like syntax highlighting, 

debugging tools, version control and more. 

16. Latency 

Latency is the measure of time between entering an input and the returned output. The 

higher the latency, the longer it takes. This is an important factor for web applications 

and interfaces where a noticeable delay may impact user satisfaction. 

17. Scripts 

Similar in a way to the scripts used by Hollywood stars, a script in programming terms is 

a line by line set of instructions for a computer program to follow. These are often used 

for automation or for generating dynamic page content. 

18. Structured data 

This refers to data or information that‘s been organized and ―cleaned‖ in order to make it 

easier to search, manipulate and interface well with software applications. Structured 

data often is used for categories like names, addresses and credit card information but 

can be used for any quantifiable data category. 

19. Syntax 

Syntax refers to the rules that dictate the structure of a language. Programming 

languages, like all languages, need structure for the reader—whether a computer or a 

human—to make sense of the information. While some elements of syntax may carry over 

from language to language, most programming languages have unique and specific 

syntax rules that must be followed. 

1.1.5.3 Technical Industry 
Computer science today is about so much more than a computer and what it can do—it‘s 

a massive area of study that intersects the industry of technology in countless ways. Here  

https://www.rasmussen.edu/degrees/technology/blog/which-programming-language-should-i-learn/
https://www.rasmussen.edu/degrees/technology/blog/which-programming-language-should-i-learn/
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are some of the industry terms you‘ll want to ensure you know. 

20. Agile development 

Agile development is a project management process for producing and releasing 

software (or other projects) that calls for quick cycles that repeat, improving as they go. 

This typically breaks projects down into smaller increments. This can be helpful in 

software development where the individual components of a software application may 

need to be adjusted or revised in order to accommodate unexpected issues or changes 

downstream. 

21. Big data 

Big data is a quick way to refer to the massive amounts of data collected by 

organizations on a day-to-day basis. Data at this scale can be tapped into for a variety of 

purposes like trend analyses, forecasting, process automation and more. 

22. Cloud storage 

Cloud storage is an alternative to storing data on a computer‘s physical storage. 

Information stored ―on the cloud‖ is kept on remote servers that can be accessed 

anywhere via the Internet.  

23. Cyber security 

Cyber security is the process of protecting data from unauthorized users or hackers. It 

also represents a huge sector of the tech industry as more and more companies race to 

stay ahead of cyber criminals and security threats. 

 

1.1.6 Characteristics of Computer 

The characteristics of the computer system are as follows  

 
Speed 

A computer works with much higher speed and accuracy compared to humans while 

performing mathematical calculations. Computers can process millions (1,000,000) of 

https://www.atlassian.com/agile
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instructions per second. The time taken by computers for their operations is 

microseconds and nanoseconds. 

Storage 

A computer has built-in memory called primary memory where it stores data. 

Secondary storage are removable devices such as CDs, pen drives, etc., which are also 

used to store data. 

Diligence 

A computer can perform millions of tasks or calculations with the same consistency and 

accuracy. It doesn‘t feel any fatigue or lack of concentration. Its memory also makes it 

superior to that of human beings. 

Versatility 

Versatility refers to the capability of a computer to perform different kinds of works with 

same accuracy and efficiency. 

Hardware is further divided into four main 

categories:  

Input Devices 

Output Devices 

Secondary Storage Devices 

Internal Components 

Software is further divided into two main 

categories: 

Application Software 

System Software 

Developed using electronic and other 

materials 

Developed writing using instructions using a 

programming language 

When damaged, it can be replaced with a 

new component 

When damaged it can be installed once 

more using a backup copy 

Hardware is physical in nature and hence 

one can touch and see hardware 

The software cannot be physically touched 

but still can be used and seen 

Hardware cannot be infected by Viruses The software can be infected by Viruses 

Hardware will physically wear out over 

time 

Software does not wear out but it can be 

affected by bugs and glitches 

An example of Hardware is hard drives, 

monitors, CPU, scanners, printers etc. 

An example of software is Windows 10, 

Adobe Photoshop, Google Chrome etc. 
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1.1.7 Block diagram and Working Principle of Computer 

 

Input 

All the data received by the computer goes through the input unit. The input unit 

comprises different devices. Like a mouse, keyboard, scanner, etc. In other words, each 

of these devices acts as a mediator between the users and the computer.  The data that 

is to be processed is put through the input unit. The computer accepts the raw data in 

binary form. It then processes the data, and produces the desired output.  The 3 major 

functions of the input unit are 
 

● Take the data to be processed by the user. 

● Convert the given data into machine-readable form. 

● And then, transmit the converted data into the main memory of the computer. The 

sole purpose is to connect the user and the computer. In addition, this creates 

easy communication between them. 

CPU – Central Processing Unit 

Central Processing Unit or the CPU, is the brain of the computer. It works the same way a 

human brain works. As the brain controls all human activities, the CPU too controls all 

tasks.  Moreover, the CPU conducts all the arithmetical and logical operations in the 

computer.  Now the CPU comprises of two units, namely – ALU (Arithmetic Logic Unit) and 

CU (Control Unit). Both of these units work in sync. The CPU processes the data as a 

whole. 

ALU – Arithmetic Logic Unit 

The Arithmetic Logic Unit is made of two terms, arithmetic and logic. There are two major 

functions that this unit performs. 

1. Data inserted through the input unit into the primary memory. Performs the basic 

arithmetical operation on it. Like addition, subtraction, multiplication, and 

division. It performs all sorts of calculations required on the data. Then sends 

back data to the storage. 

2. The unit is also responsible for performing logical operations like, AND, OR, Equal 

to, Less than, etc.  In addition to this it conducts merging, sorting, and selection of 

the given data. 

https://artoftesting.com/input-devices-of-computer
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CU – Control Unit 

The control unit as the name suggests is the controller of all the activities/tasks and 

operations. All this is performed inside the computer.  The memory unit sends a set of 

instructions to the control unit. Then the control unit in turn converts those instructions. 

After that these instructions are converted to control signals.  These control signals help 

in prioritizing and scheduling the activities. Thus, the control unit coordinates the tasks 

inside the computer in sync with the input and output units. 

Memory Unit 

All the data that has to be processed or has been processed is stored in the memory 

unit. The memory unit acts as a hub of all the data. It transmits it to the required part of 

the computer whenever necessary.  The memory unit works in sync with the CPU. This 

helps in faster accessing and processing of the data. Thus, making tasks easier and 

faster.       

There are two types of computer memory 

1. Primary memory – This type of memory cannot store a vast amount of data. 

Therefore, it is only used to store recent data. The data stored in this is temporary. 

It can get erased once the power is switched off. Therefore, is also called 

temporary memory or the main memory.   

RAM stands for Random Access Memory. It is an example of primary memory. This 

memory is directly accessible by the CPU. It is used for reading and writing 

purposes. For data to be processed, it has to be first transferred to the RAM and 

then to the CPU. 

2. Secondary memory – As explained above, the primary memory stores temporary 

data. Thus it cannot be accessed in the future. For permanent storage 

purposes, secondary memory is used. It is also called the permanent memory or 

the auxiliary memory. The hard disk is an example of secondary memory. Even in 

a power failure data does not get erased easily. 

Output 

There is nothing to be amazed by what the output unit is used for. All the information 

sent to the computer once processed is received by the user through the output unit. 

Devices like printers, monitors, projector, etc. all come under the output unit. 
 

The output unit displays the data either in the form of a soft copy or hard copy. The 

printer is for the hard copy. The monitor is for the display. The output unit accepts the 

data in binary form from the computer. It then converts it into a readable form for the 

user. 

https://en.wikipedia.org/wiki/Computer_data_storage#Secondary_storage
https://artoftesting.com/computer-output-devices-example


P a g e  | 21 

 

1.1.8 Types of computer 

1.1.8.1 Classification of Computers on the basis of working 
 

Analog computers 

Analog computers are used to process analog data. Analog data is of continuous nature 

and which is not discrete or separate. Such type of data includes temperature. pressure, 

speed weight, voltage, depth etc. These quantities are continuous and having an infinite 

variety of values. 

It measures continuous changes in some physical quantity e.g. The Speedometer of a car 

measures speed, the change of temperature is measured by a Thermometer, the weight 

is measured by Weights machine. These computers are ideal in situations where data 

can be accepted directly from measuring instrument without having to convert it into 

numbers or codes. 

 

Analog computers are the first computers being developed and provided the basis for the 

development of the modern digital computers. Analog computers are widely used for 

certain specialized engineering and scientific applications, for calculation and 

measurement of analog quantities. They are frequently used to control process such as 

those found in oil refinery where flow and temperature measurements are important. 

They are used for example in paper making and in the chemical industry. Analog 

computers do not require any storage capability because they measure and compare 

quantities in a single operation. Output froth an analog computer is generally in the form 

of readings on a series of the dial (Speedometer of a car) or a graph on strip chart. 

Digital Computers 

 

A Digital Computer, as its name implies, works with digits to represent numerals, letters 

or other special symbols. Digital Computers operate on inputs which are ON-OFF type and 

its output is also in the form of ON-OFF signal. Normally, an ON is represented by a 1 and 

an OFF is represented by a 0. So we can say that digital computers process information 

https://qsstudy.com/definition/what-is-computer
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which is based on the presence or absence of an electrical charge or we prefer to say a 

binary 1 or 0. 

A digital computer can be used to process numeric as well as non-numeric data. It can 

perform arithmetic operations like addition, subtraction, multiplication and division and 

also logical operations. Most of the computers available today are digital computers. The 

most common examples of digital computers are accounting machines and calculators. 

Hybrid Computers 

 

A hybrid is a combination of digital and analog computers. It combines the best features 

of both types of computers, i.e. It has the speed of analog computer and the memory and 

accuracy of digital computer. Hybrid computers are used mainly in specialized 

applications where both kinds of data need to be processed. Therefore. they help the 

user, to process both continuous and discrete data. For example a petrol pump contains 

a processor that converts fuel flow measurements into quantity and price values. In 

hospital Intensive Care Unit (ICU), an analog device is used which measures patient‘s 

blood pressure and temperature etc. which are then converted and displayed in the form 

of digits. Hybrid computers for example are used for scientific calculations, in defense 

and radar systems. 

1.1.8.2 Classification of Computers on the basis of Size 

● Supercomputers 

● Mainframe computers 

● Minicomputers 

● Personal computers (PCs) or microcomputers 
 

Supercomputers 

Supercomputer – a powerful computer that can process large amounts of data and do a 

great amount of computation very quickly. 

Supercomputers are used for areas related to: 

● Science 

● Engineering 

● Education 

● Defence 

● Aerospace 
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Supercomputers are useful for applications involving very large databases or that require 

a great amount of computation. A supercomputer is a computer that performs at or near 

the highest operational rate for computers. 

 

Traditionally, supercomputers have been used for scientific and engineering applications 

that must handle massive databases, do a great amount of computation or both. 

Advances like multicore processors and general-purpose graphics processing units have 

enabled powerful machines that could be called desktop supercomputers or GPU 

supercomputers. 

By definition, a supercomputer is exceptional in terms of performance. At any time, there 

are a few well-publicized supercomputers that operate at extremely high speeds relative 

to all other computers. The term supercomputer is sometimes applied to far slower -- but 

still impressively fast -- computers. 

Supercomputers are used for complex tasks, such as: 

● Weather forecasting 

● Climate research 

● Scientific simulation 

● Oil and gas exploration 

● Quantum mechanics 

● Cryptanalysis 

 

Mainframe computers 

Mainframe computer – a high-performance computer used for large information 

processing jobs. 

Mainframe computers are primarily used in : 

● Institutions 

● Research 

● Academics 

● Health care 

● Libraries 
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● Large businesses 

● Financial institutions 

● Stock brokerage firms 

● Insurance agencies 

 

Mainframe computers are useful for tasks related to: 

● Census taking 

● Industry and consumer statistics 

● Enterprise resource planning 

● Transaction processing 

● e-business and e-commerce 
 

Minicomputers 

 

Minicomputer – a mid-range computer that is intermediate in size, power, speed, storage 

capacity, etc., between a mainframe and a microcomputer. 

Minicomputers are used by small organizations. 

―Minicomputer‖ is a term that is no longer used much. In recent years, minicomputers 

are often referred to as small or midsize servers (a server is a central computer that 

provides information to other computers). 
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Workstation 

A high-performance computer system that is basically designed for a single user and has 

advanced graphics capabilities, large storage capacity, and a powerful central processing 

unit. A workstation is more capable than a personal computer (PC) but is less advanced 

than a server (which can manage a large network of peripheral PCs or workstations and 

handle immense data-processing and reporting tasks) 

A desktop computer is a personal computing device designed to fit on top of a typical 

office desk. 

It houses the physical hardware that makes a computer run and connects to input 

devices such as the monitor, keyboard and mouse users interact with. Desktop 

computers are commonly used in the enterprise, as well as in consumer use cases such 

as gaming. In the enterprise, they are important because they are the main means for 

many users to do their jobs. 

Microcomputer 

Microcomputer an electronic device with a microprocessor as its central processing 

unit (CPU). Microcomputer was formerly a commonly used term for personal computers, 

particularly any of a class of small digital computers whose CPU is contained on a 

single integrated semiconductor chip. Thus, a microcomputer uses a 

single microprocessor for its CPU, which performs all logic and arithmetic operations. The 

system also contains a number of associated semiconductor chips that serve as the 

main memory for storing program instructions and data and as interfaces for exchanging 

data of this sort with peripheral devices (e.g., keyboard, video display, and printer) 

and auxiliary storage units. The earliest microcomputers marketed in the mid-1970s 

contained a single chip on which all CPU, memory, and interface circuits were integrated. 

As large-scale integration and then very-large-scale integration progressively increased 

the number of transistors that could be placed on one semiconductor chip, so the 

processing capacity of microcomputers using such single chips grew commensurately. 

During the 1980s microcomputers came to be used widely in other applications 

besides electronic game systems and other relatively simple computer-based 

recreations. Increasingly powerful microcomputers began to be used in personal 

computer systems and workstations, for instance. High-performance microcomputer 

systems began to be used widely in business, in engineering, in ―smart‖ or intelligent 

machines employed in the factory and office, and in military electronics systems. 

Desktop computer 

A desktop computer is a personal computer designed for regular use at a single location 

on or near a desk due to its size and power requirements. The most common 

configuration has a case that houses the power supply, motherboard (a printed circuit 

https://www.britannica.com/topic/computer-graphics
https://www.britannica.com/dictionary/capabilities
https://www.britannica.com/technology/central-processing-unit
https://www.britannica.com/technology/central-processing-unit
https://www.britannica.com/technology/personal-computer
https://www.britannica.com/technology/server
https://www.britannica.com/technology/input-output-device
https://www.techtarget.com/whatis/definition/keyboard
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board with a microprocessor as the central processing unit, memory, bus, 

certain peripherals and other electronic components), disk storage (usually one or 

more hard disk drives, solid state drives, optical disc drives, and in early models a floppy 

disk drive); a keyboard and mouse for input; and a computer monitor, speakers, and, 

often, a printer for output. The case may be oriented horizontally or vertically and placed 

either underneath, beside, or on top of a desk. 

 

Laptop Computer 

A laptop, laptop computer, or notebook computer is a small, portable personal 

computer (PC) with a screen and alphanumeric keyboard. Laptops typically have a clam 

shell form factor with the screen mounted on the inside of the upper lid and the keyboard 

on the inside of the lower lid, although 2-in-1 PCs with a detachable keyboard are often 

marketed as laptops or as having a laptop mode.  

Laptops are folded shut for transportation, and thus are suitable for mobile use.  They 

are so named because they can be practically placed on a person's lap when being used. 

Today, laptops are used in a variety of settings, such as at work, in education, for playing 

games, web browsing, for personal multimedia, and for general home computer use. 

Palmtop Computer 

A Palmtop PC was an approximately pocket calculator-sized, battery-powered computer 

compatible with the IBM Personal Computer in a horizontal clamshell design with 

integrated keyboard and display. It could be used like a subnotebook, but was light 

enough to be comfortably used handheld as well. Most Palmtop PCs were small enough 

to be stored in a user's shirt or jacket pocket. 

Palmtop PCs distinguish from other palmtop computers by using a mostly IBM-

compatible PC architecture and BIOS as well as an Intel-compatible x86 processor. All 

such devices were DOS-based, with DOS stored in ROM. While many Palmtop PCs came 

with a number of PDA and office applications pre-installed in ROM, most of them could 

also run generic, off-the-shelf PC software with no or little modifications. Some could also 

run other operating systems such as GEOS, Windows 1.0-3.0 (in Real mode only), 

or MINIX 2.0. 

 

https://en.wikipedia.org/wiki/Personal_computer
https://en.wikipedia.org/wiki/Personal_computer
https://en.wikipedia.org/wiki/Alphanumeric_keyboard
https://en.wikipedia.org/wiki/Flip_(form)
https://en.wikipedia.org/wiki/Flip_(form)
https://en.wikipedia.org/wiki/Form_factor_(design)
https://en.wikipedia.org/wiki/Computer_screen
https://en.wikipedia.org/wiki/2-in-1_PC
https://en.wikipedia.org/wiki/Computer_keyboard
https://en.wikipedia.org/wiki/Mobile_computing
https://en.wikipedia.org/wiki/Lap
https://en.wikipedia.org/wiki/PC_game
https://en.wikipedia.org/wiki/PC_game
https://en.wikipedia.org/wiki/Web_browser
https://en.wikipedia.org/wiki/Multimedia
https://en.wikipedia.org/wiki/Pocket_calculator
https://en.wikipedia.org/wiki/Personal_Computer
https://en.wikipedia.org/wiki/Subnotebook
https://en.wikipedia.org/wiki/Palmtop_computer
https://en.wikipedia.org/wiki/IBM-compatible
https://en.wikipedia.org/wiki/IBM-compatible
https://en.wikipedia.org/wiki/PC_architecture
https://en.wikipedia.org/wiki/Basic_Input/Output_System
https://en.wikipedia.org/wiki/X86
https://en.wikipedia.org/wiki/DOS
https://en.wikipedia.org/wiki/Read-only_Memory
https://en.wikipedia.org/wiki/Personal_digital_assistant
https://en.wikipedia.org/wiki/Office_application
https://en.wikipedia.org/wiki/GEOS_(16-bit_operating_system)
https://en.wikipedia.org/wiki/Windows_1.0
https://en.wikipedia.org/wiki/Windows_3.0
https://en.wikipedia.org/wiki/Real_mode
https://en.wikipedia.org/wiki/MINIX_2.0
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1.1.8.3 Classification of Computers on the basis of Processor 

XT, AT  

The older 8-bit systems are very different, however. This gives us two basic system types, 

or classes, of hardware: 

● 8-bit (PC/XT-class) systems 

● 16/32/64-bit (AT-class) systems 

In this verbiage, PC stands for personal computer; XT stands for an extended PC; and AT 

stands for an advanced-technology PC. The terms PC, XT, and AT, as they are used here, 

are taken from the original IBM systems of those names. The XT was a PC system that 

included a hard disk for storage in addition to the floppy drives found in the basic PC 

system. These systems had an 8-bit 8088 processor and an 8-bit Industry Standard 

Architecture (ISA) bus for system expansion. The bus is the name given to expansion 

slots in which additional plug-in circuit boards can be installed. The 8-bit designation 

comes from the fact that the ISA bus found in the PC/XT class systems can send and 

receive only 8 bits of data in a single cycle. The data in an 8-bit bus is sent along eight 

wires simultaneously, in parallel. 

16-bit and greater systems are said to be AT-class, which indicates that they follow 

certain standards and that they follow the basic design first set forth in the original IBM 

AT system. AT is the designation IBM applied to systems that first included more 

advanced 16-bit (and later, 32- and 64-bit) processors and expansion slots. AT-class 

systems must have a processor that is compatible with Intel 286 or higher processors 

(including the 386, 486, Pentium, Pentium Pro, Pentium II, and Pentium III processors), 

and they must have a 16-bit or greater system bus. The system bus architecture is 

central to the AT system design, along with the basic memory architecture, interrupt 

request (IRQ), direct memory access (DMA), and I/O port address design. All AT-class 

systems are similar in the way these resources are allocated and how they function. 

The first AT-class systems had a 16-bit version of the ISA bus, which is an extension of 

the original 8-bit ISA bus found in the PC/XT-class systems. Eventually, several expansion 

slot or bus designs were developed for AT-class systems, including the following: 

● 16-bit ISA bus 

● 16/32-bit Extended ISA bus 

● 16/32-bit PS/2 Micro Channel Architecture (MCA) bus 

● 16-bit PC-Card (PCMCIA) bus 

● 32-bit Cardbus (PCMCIA) bus 

● 32-bit VESA Local (VL) bus 

● 32/64-bit Peripheral Component Interconnect bus 

● 32-bit Accelerated Graphics Port 

A system with any of these types of expansion slots is by definition an AT-class system, 

regardless of the actual Intel or Intel-compatible processor that is used. AT-type systems 

with 386 or higher processors have special capabilities not found in the first generation 
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of 286-based ATs. These distinct capabilities are in the areas of memory addressing, 

memory management, and possible 32- or 64-bit wide access to data. Most systems 

with 386DX or higher chips also have 32-bit bus architectures to take full advantage of 

the 32-bit data transfer capabilities of the processor. 

Differences between PC/XT and AT Systems 

System Attributes (8-Bit) PC/XT Type (16/32/64-Bit) AT Type 

Supported processors All x86 or x88 286 or higher 

Processor modes Real Real/Protected/Virtual Real 

Software supported 16-bit only 16- or 32-bit 

Bus slot width 8-bit 16/32/64-bit 

Slot type ISA only ISA, EISA, MCA, PC-Card, Cardbus, VL-Bus, 

PCI, and AGP 

Hardware interrupts 8 (6 usable) 16 (11 usable) 

DMA channels 4 (3 usable) 8 (7 usable) 

Maximum RAM 1MB 16MB/4GB or more 

Floppy controller speed 250Kbps 250/300/500/1,000 Kbps 

Standard boot drive 360KB or 720KB 1.2MB/1.44MB/2.88MB 

Keyboard interface Unidirectional Bidirectional 

CMOS memory/clock None standard MC146818-compatible 

Serial-port UART 8250B 16450/16550A or greater 

 

Pentium: 

Core i3 processors offer a great mix of price and performance. They aren't the best for 

heavy multi-tasking or more challenging tasks such as editing videos, but they offer a 

noticeable step up from Pentium processors without you having to spend too much more; 

you'll find them in laptops from about £350 and up. 
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Core i5 processors are a great choice if you want a computer that can perform lots of 

tasks at once, and perhaps even delve into photo and video editing work. They don't cost 

as much as i7 processors but they offer performance that isn't too far off. It's the 

specification we recommend to most people, and you can grab one in a laptop for about 

£500.  

Core i7 is a step up from i5, with a bit of extra performance to make those tough tasks 

that bit quicker. You often pay a premium for this, and if you have no specific need for 

speed then you may well not need or want to pay the extra. Core i9 chips are reserved for 

specialist computers working on extremely challenging tasks, usually editing large videos. 

These would be overkill for most people, although if you do get the chance to use one 

you'll surely notice the scintillating speed. 

1.2 Memory 

1.2.1 Units, Representation 

Memory unit is the amount of data that can be stored in the storage unit. This storage 

capacity is expressed in terms of Bytes. 

The following table explains the main memory storage units  

S.No. Unit & Description 

1 
Bit (Binary Digit)  -A binary digit is logical 0 and 1 representing a passive or an 

active state of a component in an electric circuit. 

2 Nibble - A group of 4 bits is called nibble. 

3 
Byte - A group of 8 bits is called byte. A byte is the smallest unit, which can 

represent a data item or a character. 
 

S.No. Unit   Description 

1 Kilobyte (kB) 1 KB = 1024 Bytes 

2 Megabyte (MB) 1 MB = 1024 kB 

3 GigaByte (GB) 1 GB = 1024 MB 

 

1.2.2 Types 

Primary memory 

Primary memory is computer memory that a processor or computer accesses first or 

directly. It allows a processor to access running execution applications and services that 

are temporarily stored in a specific memory location. 

Primary storage (also known as main memory) is the component of the computer that 

holds data, programs and instructions that are currently in use. 
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RAM > Random Access Memory 

 

RAM (Random Access Memory), contains one or multiple memory modules that store 

data temporarily.  It is also called volatile memory because data get erased when the 

computer is turned off. It holds data and instruction frequently during processing. When 

we are launching the software, then it is loaded into RAM. 

ROM > Read Only Memory 

ROM is a primary memory. It stores some standard processing programs to operate the 

PC. Processers only read the content of ROM but cannot change the content. 

 

PROM 

It stands for programmable read-only memory. In this memory, data can be written only 

once and will remain there forever. 

It can retain its content when the computer is turned off. PROM is manufactured in an 

empty state and then programmed later using PROM Programmer or burner.  

EPROM 

It stands for Erasable programmable read-only memory, In this memory can be erased by 

exposing it to ultraviolet light. Ultraviolet light clears its contents, marking it possible to 

reprogrammed memory. 

https://www.computerhope.com/jargon/p/progrrom.htm
https://www.computerhope.com/jargon/p/progrrom.htm
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EEPROM 

It stands for Electrically erasable programmable read-only memory, Same as EPROM but 

it erases content by exposing it to electrical charge and then can be reprogrammed. 

It retains its content when the power is turned off. It is like flash memory. However, It 

requires data to be written and erased one byte at a time. This makes it faster than flash 

memory.  

Primary storage is located on the motherboard. As a result, data can be read from and 

written to primary storage extremely quickly. This gives the processor fast access to the 

data and instructions that the primary storage holds. 

There are four types of primary storage: 

● Read Only Memory (ROM) 

● Random Access Memory (RAM) 

● Flash memory 

● Cache memory 

The two main types of primary storage are ROM, which is non-volatile, and RAM, which 

is volatile. Non-volatile memory keeps its contents even when the computer is switched 

off. Volatile memory loses its contents when power is lost. 

Primary storage is comparatively limited in size, especially when compared 

with secondary storage. In a modern personal computer, primary storage is often around 

4 GB in size. 

DDR 

In computing, a computer bus operating with double data rate (DDR) transfers data on 

both the rising and falling edges of the clock signal.[1] This is also known as double 

pumped, dual-pumped, and double transition. The term toggle mode is used in the 

context of NAND flash memory. 

 

The Secondary storage media can be fixed or removable. Fixed Storage media is an 

internal storage medium like a hard disk that is fixed inside the computer. A storage 

medium that is portable and can be taken outside the computer is termed removable 

storage media. 

https://en.wikipedia.org/wiki/Computing
https://en.wikipedia.org/wiki/Computer_bus
https://en.wikipedia.org/wiki/Clock_signal
https://en.wikipedia.org/wiki/Double_data_rate#cite_note-1
https://en.wikipedia.org/wiki/Flash_memory#NAND_flash
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Fixed storage is an internal media device used by a computer system to store data. 

Usually, these are referred to as the fixed disk drives or Hard Drives. 

Fixed storage devices are not fixed. These can be removed from the system for repairing 

work, maintenance purposes, and also for an upgrade, etc. But in general, this can not 

be done without a proper toolkit to open up the computer system to provide physical 

access, which needs to be done by an engineer. 

Technically, almost all data, i.e. being processed on a computer system, is stored on 

some built-in fixed storage device. We have the following types of fixed storage: 

o Internal flash memory (rare) 

o SSD (solid-state disk) units 

o Hard disk drives (HDD) 

Hard disk (HDD) 

A hard disk is also known as a hard drive or fixed disk. It is said to be rigid magnetic disc 

that stores data. It is located within a drive unit. Hard disk is a non-volatile storage device 

that contains platters and magnetic disks rotating at high speeds. Non-volatile means 

the data retains when the computer shuts down. 

It is installed internally in our computer systems. Hard disk is located within a drive unit 

on the computer's motherboard and comprises one or more platters packed in an air-

sealed casing. 

Its main components include a read/write actuator arm, head actuator, read/write head, 

spindle, and platter. A circuit board (also called as the interface board or disk controller) 

is present on the back of a hard drive. It lets the hard drive to communicate with the 

computer. 
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SSD 

Solid-state drives (SSD) are a new generation of storage devices aimed at replacing 

traditional mechanical hard-disk drives (HDD). SSDs use flash-based memory rather than 

spinning disks, making them faster, more reliable and more energy-efficient. 

This storage technology was previously reserved for enterprise organizations and the 

most high-end PCs. Technology improvements have made them more affordable so they 

are now more common in mainstream devices. They are on average more expensive than 

HDDs but they provide more value. SSDs are available with storage capacities ranging 

from 32 gigabytes up to 8 terabytes. 

CD 

A compact disc (CD) is a circular disc introduced by James Russell. It is 4.75 in diameter, 

which is a flat, round, portable storage medium used to record, store and playback audio, 

video, and other data. On 17 August 1982, in Germany, the first CD was created at a 

Philips factory. Sony and Philips proposed the CD standard, and in 1993, the technology 

was introduced to the U.S. It can store data up to 700 MB or 80 minutes of audio. It 

stores data as small notches and read with the help of laser from an optical drive, and 

the notches are converted into usable data by drives. 

The first CDs were able to store only audio, which was replaced by audiotapes. Audio CDs 

have the ability to enable users to skip to different places on the disc. CDs can be used 

unlimited time without losing quality, while audio tapes can lose the quality if you use it 

around ten times. Because in the CDs, the laser that reads data does not put the 

pressure on the disc, while in a tape, the play heads drape slowly wear away the 

magnetic strip on the tape. 

What is the use of a CD on the computer? 

CDs are used to store data, which can be executed in the future. Thus, you can load 

software programs in the compact disc that can be moved onto the computer. 

Even, Windows files are also stored in the CD, which can be installed onto the computer. 

Furthermore, the stored files on the compact disc can be transferred to other computers, 

through which you can make a backup of all files. 

History of CD (Compact Disc) 

The two companies Sony and Philips announced to developed the CD (Compact Disc) 

with developing prototypes separately in the late 1970s. 

DVD 

DVD is short for digital versatile disc or digital video disc. It is a type of optical media 

used for storing optical data. Although it has the same size as a CD, its storage capacity 

is much more than a CD. So, it is widely used for storing and viewing movies and to 
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distribute software programs as they are too large to fit on a CD. DVD was co-developed 

by Sony, Panasonic, Philips, and Toshiba in 1995. 

 

Types of DVDs: 

DVDs can be divided into three main categories which are as follows: 

DVD-ROM (Read-Only): These types of DVDs come with media already recorded on them, 

such as movie dvds. As the name suggests, data on these discs cannot be erased or 

added, so these discs are known as a read-only or non-writable DVD. 

DVD-R (Writable): It allows you to record or write information to the DVD. However, you 

can write information only once as it becomes a read-only DVD once it is full. 

DVD-RW (Rewritable or Erasable): This type of discs can be erased, written, or recorded 

multiple times. 

 

Blu-Ray DVD 

A Blu-ray disk is a type of high capacity optical disk medium, which is used to store a 

huge amount of data and to record and playback high definition video. Blu-ray was 

designed to supersede the DVD. While a CD is able to store 700 MB of data and a DVD is 

able to store 4.7 GB of data, a single Blu-ray disk is able to store up to 25 GB of data. 

The dual-layer Blu-ray disks can hold 50 GB of data. That amount of storage is equivalent 

to 4 hours of HDTV. There is also a double-sided dual-layer DVD, which is commonly used 

and able to store 17 GB of data. 

Blu-ray disk uses the blue lasers, which help them to hold more information as compared 

to other optical media. The laser is actually known as 'blue-violet', but the developer rolls 

off the tongue to make 'Blue-violet-ray' a little earlier as 'Blu-ray'. The CDs and DVDs use 

the red laser, and their wavelength (650 nm) is greater than the blue-violet laser 

(405nm). With the help of a small wavelength, the laser can focus on a small area. In 

Blu-ray disks, we can use the same size, which is used by CD or DVD and store a large 

amount of data on a disk. Blu-ray is able to provide very high resolution as compared to 

the DVD. On the basis of standard definition, a DVD can provide a definition of 720x480 

pixels. In contrast, the Blu-ray high definition contains 1920X1080 pixel resolution. 

Pen drive 

Pen drive is a compact secondary storage device. It is also known as a USB flash drive, 

thumb drive or a jump drive. It connects to a computer via a USB port. It is commonly 

used to store and transfer data between computers. For example, you can write a report 

using a computer and then copy or transfer it in the pen drive. Later, you can connect 

this pen drive to a computer to see or edit your report. You can also store your important 

documents and pictures, music, videos in the pen drive and keep it at a safe place. 
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Pen drive does not have movable parts; it comprises an integrated circuit memory chip 

that stores the data. This chip is housed inside a plastic or aluminium casing. The data 

storage capacity of the pen drive generally ranges from 2 GB to 128 GB. Furthermore, it 

is a plug and play device as you don't need additional drives, software, or hardware to 

use it. 

Magnetic Tape 

Reading and writing techniques in the tape system is the same as the disk system. In 

this, the medium is flexible polyester tape coated with a magnetizable material. The tape's 

data can be structured as a number of parallel tracks that will be run lengthwise. In this 

form, the recording of data can be called a parallel recording. Instead of the parallel 

recording, most of the modern system uses serial recording. The serial recording uses the 

sequence of bits along with each track to lay of the data. It is done with the help of a 

magnetic disk. In the serial recoding, the disk contains the physical record on the tape, 

which can be described as the data which are read and write in the contiguous blocks. 

The gaps are used to separate the blocks on the tape, which can also be known as inter-

record gaps. With the disk, we format the tape so that we can assist in locating physical 

records. When the data are being recorded in the techniques of serial tape, we record 

the first set of bits along with the whole tape's length. When we reach the end of a tape, 

the head will be repositioned so that they can record a new track. This time, the tape will 

follow the opposite direction to again record its whole length. This process will be 

continued until the tape is full. 
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A tape drive can be accessed as a sequential access device. If the current position of the 

head is beyond the desired result, we have to rewind the tape at a certain distance and 

starting reading forward. During the operation of reading and writing only, the tape is in 

motion. The difference between tape and disk drive is that the disk drive can be referred 

to as a direct access device. A disk drive is able to get the desired result without 

sequentially reading all sectors on a disk. It has to only wait until the intervening sectors 

have arrived within one track. After that, it is able to successive access to any track. 

The magnetic tape can also be known as a type of second memory. It can also be used 

as the slowest speed and lowest cost member of the memory hierarchy. There is also a 

linear tape technology, which is a type of cartridge system. It was developed in late the 

1990s. In the market, the LTO can be described as an alternative to various properties 

systems. 

 

Zip disk 

Zip disk is a hardware data storage device developed by Iomega that functions like a 

standard 1.44" floppy drive and diskette. The Iomega Zip drive unique is having 

capability to hold up to 100 MB of data or 250 MB of data on the later models. Iomega 

Zip drives became very popular in late 1990s but quickly became less popular as users 

needed larger storage capabilities. The drive was eventually replaced by CD-R and CD-

RW drives and discs as they became cheaper since they offered much more storage and 

compatibility. 

 

 

 

In the picture is an Iomega Zip disk that is bigger than a floppy diskette and made of a 

much harder plastic. Much like a floppy diskette, the Zip disk contains a magnetic 

circular disk that holds information. To read and write information on a Zip diskette, it is 

placed into a Zip drive that moves the metal cover exposing the magnetic disk. 
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1.3 CPU 

Components of CPU 

 

Motherboard 

The motherboard is the computer's main circuit board. It's a thin plate that holds the 

CPU, memory, connectors for the hard drive and optical drives, expansion cards to 

control the video and audio, and connections to your computer's ports (such as USB 

ports). The motherboard connects directly or indirectly to every part of the computer. 

 
 

Hard disk  

The hard drive is where your software, documents, and other files are stored. The hard 

drive is long-term storage, which means the data is still saved even if you turn the 

computer off or unplug it. 
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When you run a program or open a file, the computer copies some of the data from 

the hard drive onto the RAM. When you save a file, the data is copied back to the hard 

drive. The faster the hard drive, the faster your computer can start up and load programs. 

SSD 

SSD Stands for ―Solid State Drive.‖ An SSD is a type of mass storage device similar to a 

hard disk drive (HDD). It supports reading and writing data and maintains stored data in 

a permanent state even without power. Internal SSDs connect to a computer like a hard 

drive, using standard IDE or SATA connections. 

 

RAM (Random Access Memory) 

 

RAM is your system's short-term memory. Whenever your computer performs 

calculations, it temporarily stores the data in the RAM until it is needed. 

This short-term memory disappears when the computer is turned off. If you're working on 

a document, spreadsheet, or other type of file, you'll need to save it to avoid losing it. 

When you save a file, the data is written to the hard drive, which acts as long-term 

storage. 

RAM is measured in megabytes (MB) or gigabytes (GB). The more RAM you have, the 

more things your computer can do at the same time. If you don't have enough RAM, you 

may notice that your computer is sluggish when you have several programs open. 

Because of this, many people add extra RAM to their computers to improve performance. 

ROM 

ROM (read only memory) is a flash memory chip that contains a small amount of non-

volatile memory. Non-volatile means that its contents cannot be changed and it retains 

its memory after the computer is turned off. 
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Processor / CPU 

The central processing unit (CPU), also called a processor, is located inside the computer 

case on the motherboard. It is sometimes called the brain of the computer, and its job is 

to carry out commands. Whenever you press a key, click the mouse, or start an 

application, you're sending instructions to the CPU. 

The CPU is usually a two-inch ceramic square with a silicon chip located inside. The chip 

is usually about the size of a thumbnail. The CPU fits into the motherboard's CPU socket, 

which is covered by the heat sink, an object that absorbs heat from the CPU. 

 

A processor's speed is measured in megahertz (MHz), or millions of instructions per 

second; and gigahertz (GHz), or billions of instructions per second. A faster processor can 

execute instructions more quickly. However, the actual speed of the computer depends 

on the speed of many different components—not just the processor. 

 

SMPS & Connecting wire 

SMPS / Power Supply Unit 

 

The SMPS (Switched Mode Power Supply) / Power Supply Unit in a computer converts 

the power from the wall outlet to the type of power needed by the computer. It sends 

power through cables to the motherboard and other components. 
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Connecting wires 

 

20 + 4 Pin ATX / Motherboard Connector 

This is the main ATX connector that supplies power to motherboard and other 

components like RAM, Low-end graphics card, PCI cards that are connected to 

motherboard. Earlier motherboards have 20 pin sockets only but now modern-day 

motherboards require 24-pin power connectors.  

CPU 4 + 4 Pin Connector 

This is the 12 Volt connector that supplies power to CPU or Processor. Some 

motherboards have 4 pins 12V CPU socket and some have 8 pins 12V socket, therefore 

most of the good power supplies come with 8-pin (4 + 4) detachable connectors which 

can be split into two 4 pin connectors. 

SATA Power Connector 

This power connector is used to power up SATA devices that mostly include Hard Disks, 

DVD Writers / Drives. 

Floppy 4 Pin Connector 

This 4 pin power connector is used to power floppy drives. Floppy Drives are not being 

used commonly, but in some cases they can prove very useful. 

Peripheral 4 Pin Molex Connector 

Peripheral 4 Pin Molex Connector is used to provide power to IDE devices and other 

peripherals like Fans, case lights etc.  
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PCI-e 6 Pin / PCI-e 8 Pin Connector 

PCI-e 6 Pin or PCI-e 6+2 Pin are 12 Volt Connectors that are used to provide power to 

mid to high range graphics cards that require extra amount of power for their working.  

Graphics Card 

A graphics card is a type of display adapter or video card installed within most computing 

devices to display graphical data with high clarity, color, definition and overall 

appearance. A graphics card provides high-quality visual display by processing and 

executing graphical data using advanced graphical techniques, features and functions. 

Sound Card   

A sound card (also known as an audio card) is an internal expansion card that 

provides input and output of audio signals to and from a computer under control 

of computer programs. The term sound card is also applied to external audio 

interfaces used for professional audio applications. 

Network Interface Card 

A network interface controller (NIC, also known as a network interface card, network 

adapter, LAN adapter or physical network interface and by similar terms) is a computer 

hardware component that connects a computer to a computer network.  Early NIC‘s were 

commonly implemented on expansion cards that plugged into a computer bus. The low 

cost and ubiquity of the Ethernet standard means that most newer computers have a 

network interface built into the motherboard, or is contained into a USB-

connected dongle. 

Modem 

A modem converts data to a signal so it can be easily sent and received over a phone 

line, cable, or satellite connection. For transmission over an analog telephone line—which 

was once the most popular way to access the internet—the modem converts data 

between analog and digital formats in real time for two-way network communication. In 

the case of the high-speed digital modems popular today, the signal is much simpler and 

doesn't require the analog-to-digital conversion. 

1.4 Input, Output Devices 

 

Input and output devices allow the computer system to interact with the outside world by 

moving data into and out of the system.  
 

An input device is used to bring data into the system. Some input devices are: 

● Keyboard 

● Mouse 

● Microphone 

● Bar code reader 

● Graphics tablet 

https://en.wikipedia.org/wiki/Expansion_card
https://en.wikipedia.org/wiki/Input_and_output
https://en.wikipedia.org/wiki/Audio_signal
https://en.wikipedia.org/wiki/Computer
https://en.wikipedia.org/wiki/Computer_program
https://en.wikipedia.org/wiki/Audio_interface
https://en.wikipedia.org/wiki/Audio_interface
https://en.wikipedia.org/wiki/Professional_audio
https://en.wikipedia.org/wiki/Computer_hardware
https://en.wikipedia.org/wiki/Computer_hardware
https://en.wikipedia.org/wiki/Computer
https://en.wikipedia.org/wiki/Computer_network
https://en.wikipedia.org/wiki/Expansion_card
https://en.wikipedia.org/wiki/Computer_bus
https://en.wikipedia.org/wiki/Ethernet
https://en.wikipedia.org/wiki/Motherboard
https://en.wikipedia.org/wiki/USB
https://en.wikipedia.org/wiki/Dongle
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An output device is used to send data out of the system. Some output devices are: 

● Monitor 

● Printer 

● Speaker 

 

Input/output devices are usually called I/O devices. They are directly connected to an 

electronic module inside the systems unit called a device controller. For example, the 

speakers of a multimedia computer system are directly connected to a device controller 

called an audio card (such as a Soundblaster), which in turn is connected to the rest of 

the system.  Sometimes secondary memory devices like the hard disk are called I/O 

devices (because they move data in and out of main memory.) What counts as an I/O 

device depends on context. To a user, an I/O device is something outside of the system 

box. To a programmer, everything outside of the processor and main memory looks like 

an I/O devices. To an engineer working on the design of a processor, everything outside 

of the processor is an I/O device. 

 

Input, Output devices 

A computer is an electronic device used for performing calculations and controlling 

operations. It is a collection of hardware and software components that help you 

complete many different tasks. 

 

1.4.1 Input Device 

● An input device is used to feed data into computer. 

● Input devices are capable of converting data into a form which can be recognized 

by computer. 

● A computer has several input device namely, Keyboard, Mouse, Trackball, 

Joystick, Scanner, Light pen, Bar Code Reader, OCR, OMR, MICR etc. 

Note: The device used to accept the data and instructions from the user is called 

input device. 

 

Keyboard 
 

● The most common input device is the keyboard. 

● It is used to enter both numerical and character type data. 

● It is like a mechanical type writer with alpha numeric and special keys, punctuation 

keys, functional keys to perform specific. The keyboards contain 101 keys or 104 

keys. 

● The keyboard detects the key pressed and generates the corresponding ASCII 

codes which can be recognized by the computer. 

 

Types of keyboard: 

1. Standard keyboard: The standard keyboards have their basic layout. The 

average number of keys on a regular keyboard is 105/108; QWERTY keyboards 
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are the most common and have the six alphabets Q, W, E, R, T, and Y in the first 

row. 

2. Ergonomics: It refers to study of method that can reduce stress on muscles to 

avoid repetitive strain injury. It mostly deals with optimizing posture and 

technique while working, so the work can be carried out in the easiest manner. 

3. Wireless keyboard: It is a keyboard that does not need to connect to the 

computer via a wire. This makes very convenient for the use the keyboard 

comfortably. Wireless keyboard use Bluetooth, Infrared (IR) to connect to the 

computer. 

4. Virtual keyboard: It is a software device that led to use input data just like 

hardware keyboard. They open up as an application and can be controlled by a 

mouse or wire touch screen. 

5. Compact keyboard: These keyboards are slim and usually do not have the 

numerical keypad that is present on the right side of the keyboard these are 

typically used in laptops. 

 

Mouse 

● Mouse is an input device that controls the movement of the cursor on the display 

screen. 

● Mouse stands for ―Mechanically Operated User Serial Engine‖. 

● The Mouse is used as a pointing device. 

● Mouse is a small device; you can roll/navigate along a flat surface. 

● In a mouse, a small ball/IR rays is kept inside and touches the pad through a 

hole at the bottom of the mouse. 
 

There are two types of mouse. 

o Mechanical 

o Optical 

● Mechanical: This mouse has a small rubber ball underneath that moves against 

two rollers as it passes across a flat surface. 

● Optical: This mouse more accurate and has no moving parts. Ts use a laser to 

detect movement. 

 

Scanner 

● The scanner is an input device which works more like a photocopy machine. 

● It is used when some information is available on a paper and it is to be 

transferred to the computer for further manipulation. 

● The scanner captures images from the source which are then converted into the 

digital form. 

 

1.4.2 Output Device 

● When the data and instruction are fed into the computer and processed the next 

step is get the desired output. 
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● This output may be displayed on the monitor or printed on the computer. 

● The output displayed on the monitor is called soft copy output. 

● The output produced on a computer is called hard copy output. 

Note: The device that displays output to the user is called output device. 

Monitor 

● It is commonly used output device sometimes called as display screen/VDU. 

● Monitors are connected with the computer are similar in appears to a television 

set. 

● Monitor display image and text. 

● The smallest dot that can be displayed is called a pixel. 

● The resolution of the monitor determines the quality of the display. Some popular 

resolutions are 640X480 pixels, 800X600 pixels and 1024X768 pixels. 

● The different size of the monitor is measured diagonally may be 12‖, 14‖, 17‖, 19‖, 

21‖. 

The different types of monitors: 

o CRT (Cathode Ray Tube) 

o LCD (Liquid Crystal Display) 

o TFT ( Thin Film Transistors) 

o LED (Light Emitting Diode) 

 

Printer 

● Printer is an output device that prints text or images on paper. 

● By printing you create a ‗hard copy‘ of data. 

● There are different kinds of printers, which vary in their speed and print quality. 

The two main types of printer namely; 

⮚ Impact Printers 

⮚ Non Impact Printers. 

 

Joystick 

● A joystick is an input device consisting of a stick that pivots on a base and 

reports its angle or direction to the device it is controlling. 

● The joystick can be moved in all four directions. The function of the joystick is 

similar to that of a mouse. 

● It is mainly used in playing computer games. 

● Joysticks are also used for controlling machines such as cranes, trucks, 

underwater unmanned vehicles, surveillance cameras and zero turning radius 

lawn mowers. 

 

Plotter 

● Plotter is an output device that draws shapes on paper based on commands from a 

computer. 

● Plotter differs from printers in that they draw lines using a pen.  As a result, they 
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can produce continuous lines, whereas printers can only stimulate lines printing 

a closely spaced series of dots. 

● Multicolor plotters use different colored pens to draw different colors. 

● Plotters are more expensive than printers. 

● They used in engineering applications. 

 

Digital Camera  

A digital camera is a camera that captures photographs in digital memory. Most cameras 

produced today are digital, largely replacing those that capture images on photographic 

film. Digital cameras are now widely incorporated into mobile devices like smart 

phones with the same or more capabilities and features of dedicated cameras. While 

there are still dedicated digital cameras, many more cameras are now incorporated into 

mobile devices like smart phones. High-end, high-definition dedicated cameras are still 

commonly used by professionals and those who desire to take higher-quality 

photographs.  

 

 

Graphics tablet  

A graphics tablet (also known as a digitizer, digital graphic tablet, pen tablet, drawing 

tablet, or digital art board) is a computer input device that enables a user to hand-draw 

images, animations and graphics, with a special pen-like stylus, similar to the way a 

person draws images with a pencil and paper. These tablets may also be used to capture 

data or handwritten signatures. It can also be used to trace an image from a piece of 

paper that is taped or otherwise secured to the tablet surface. Capturing data in this way, 

by tracing or entering the corners of linear polylines or shapes, is called digitizing. 

 

https://en.wikipedia.org/wiki/Camera
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https://en.wikipedia.org/wiki/Stylus_(computing)
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https://en.wikipedia.org/wiki/Digitizing


P a g e  | 46 

 

1.4.3 Connecting Port 
 

In the computer world, a port is a means to connect the external devices to the central 

processing unit (CPU). Effectively they are the sockets found on the back of the PCs and 

are used to communicate with printers, keyboards, modems, and monitors, or just about 

any peripheral or component. The ports either connect directly onto the motherboard or 

onto an expansion card. We are here to talk about two of the commonly used ports – 

serial ports and parallel ports. 

 

1.4.3.1 Serial Port 
 

A serial port is yet another type of port and a great alternative to the parallel ports where 

the bits of data is sent one at a time in a single stream of 1s and 0s. Unlike the parallel 

port, it is a serial communication interface through which data is transferred on a single 

wire or a pair of wires, or in case of wireless communication, a single transmission path. 

Also known as COM (communication) ports, there are many different types of serial 

interfaces available for computers, such as the ubiquitous RS-232 port, the RS-485 port, 

IEEE-394, and the USB. The serial port uses a standard 9-pin D-shaped connector and is 

used to connect devices such as mouse, modems, gaming controllers, older printers, etc. 

It is one of the oldest interfaces used to connect mainly modem and printers to the 

computer. But the modern serial ports are used for specialist devices such as security 

cameras, flat-screen monitors, GPS receivers, and so on. 

1.4.3.2 Parallel Port  
 

A parallel port is an external interface found on the back of the personal computers and 

is used to connect to just about anything you‘d want to hook to a computer. It acts as an 

interface for connecting computer peripherals such as printers, or any other device that 

requires relatively high bandwidth. The parallel port is one of the most versatile I/O ports 

in the system because it can be used for a variety of devices, including optical drives, 

scanners, external CD-ROM, and so on. The name parallel describes the way how the 

data is sent; it implies parallel communication meaning multiple bits of data is sent all 

together at the same time without any hold-up. The parallel port uses DB25 female pin 

connector and the end of the cable that connects to devices uses a centronics connector 

– after the name of the company that designed the standard interface for connecting a 

printer to a computer. 
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1.4.3.3 USB Port  
 

USB port is a standard cable connection interface for personal computers and consumer 

electronics devices. USB stands for Universal Serial Bus, an industry standard for short-

distance digital data communications. USB ports allow USB devices to be connected to 

each other with and transfer digital data over USB cables. They can also supply electric 

power across the cable to devices that need it. 

Both wired and wireless versions of the USB standard exist, although only the wired 

version involves USB ports and cables. 

1.4.4 Installation of Scanner and Printer 

Connect your printer by a wire, plug it into your device. It'll connect automatically, your PC 

will download the right drivers, and you can use it right away. To connect a wireless 

printer, follow these steps: 

1. Select the Start  button, then select Settings  > Devices > Printers & scanners > Add a 

printer or scanner. 

 

2. Wait for it to find nearby printers, then choose the one you want to use, and 

select Add device. If you want to remove the printer later, just highlight it and 

select Remove. 

 

3. If you don't see your printer, try to fix the problem by using the steps in   

1.4.5 Connecting Monitor, Mouse, Keyboard to System Unit 

You might need to connect the monitor, keyboard, and mouse to the system.  To connect 

a monitor, mouse and keyboard perform the following steps: 

1. Locate the graphics adapter at the rear of the server. 

https://www.lifewire.com/universal-serial-bus-usb-2626039
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2. Connect a keyboard and mouse to the USB ports. 

3. Connect a standard monitor to the adapter to use the console. 

4. Power on the console. 

5. Connect the power cables for the server and wait for the green light on the 

operator panel to start flashing.  

6. Install an operating system and update the operating system, if required. 

***** 
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UNIT – 2 

OPERATING SYSTEM 

 

 

 

 

 

 

 

 

 

 

 



P a g e  | 50 

 

2.1 Windows 

2.1.1 Definition of Operating System 

An operating system is a program that acts as an interface between the user and the 

computer hardware and controls the execution of all kinds of programs. 

 

 

 

2.1.1.1 Functions of OS 

Following are some of important functions of an operating System. 

● Memory Management 

● Processor Management 

● Device Management 

● File Management 

● Security 

● Control over system performance 

● Job accounting 

● Error detecting aids 

● Coordination between other software and users 

Memory Management 

Memory management refers to management of Primary Memory or Main Memory. Main 

memory is a large array of words or bytes where each word or byte has its own address. 
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Main memory provides a fast storage that can be accessed directly by the CPU. For a 

program to be executed, it must in the main memory. An Operating System does the 

following activities for memory management 

● Keeps tracks of primary memory, i.e., what part of it are in use by whom, what part 

are not in use. 

● In multiprogramming, the OS decides which process will get memory when and 

how much. 

● Allocates the memory when a process requests it to do so. 

● De-allocates the memory when a process no longer needs it or has been 

terminated. 

Processor Management 

In multiprogramming environment, the OS decides which process gets the processor 

when and for how much time. This function is called process scheduling. An Operating 

System does the following activities for processor management − 

● Keeps tracks of processor and status of process. The program responsible for this 

task is known as traffic controller. 

● Allocates the processor (CPU) to a process. 

● De-allocates processor when a process is no longer required. 

Device Management 

An Operating System manages device communication via their respective drivers. It does 

the following activities for device management − 

● Keeps tracks of all devices. Program responsible for this task is known as the I/O 

controller. 

● Decides which process gets the device when and for how much time. 

● Allocates the device in the efficient way. 

● De-allocates devices. 

File Management 

A file system is normally organized into directories for easy navigation and usage. These 

directories may contain files and other directions. 

An Operating System does the following activities for file management − 

● Keeps track of information, location, uses, status etc. The collective facilities are 

often known as file system. 

● Decides who gets the resources. 

● Allocates the resources. 

● De-allocates the resources. 
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Other Important Activities 

Following are some of the important activities that an Operating System performs − 

● Security − By means of password and similar other techniques, it prevents 

unauthorized access to programs and data. 

● Control over system performance − Recording delays between request for a 

service and response from the system. 

● Job accounting − Keeping track of time and resources used by various jobs and 

users. 

● Error detecting aids − Production of dumps, traces, error messages, and other 

debugging and error detecting aids. 

● Coordination between other softwares and users − Coordination and assignment 

of compilers, interpreters, assemblers and other software to the various users of 

the computer systems. 

 

2.1.1.1 Types of OS 
 

An operating system is a well-organized collection of programs that manages the 

computer hardware. It is a type of system software that is responsible for the smooth 

functioning of the computer system. 

 

 

Single User Operating System 

A single-user operating system is a type of operating system developed and intended for 

use on a computer or similar machine that will only have a single user at any given time. 

This type of OS is typically used on devices like wireless phones and two-way messaging 

devices. 

The operating system is responsible for handling many different tasks and is typically one 

of the most important programs used on a computer. It manages memory usage and 

other resources, hardware connectivity and the proper execution of other applications. A 

single task operating system can only run one program or application at a time. So it is 

not as useful for a computer or other device intended to run multiple programs at once. 
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Single User Single Task Operating System 

As the name indicates, Single User Single Task OS is a system in which only one program 

is executed at one time. It manages the computer in a way that one user can successfully 

perform one thing at a time.  There is a problem with these types of Operating System 

that the program has to be arranged in a queue. 

Advantages 

● This operating system occupies less space in memory. 

 

Disadvantages 

● It can perform only a single task at a time.  

 

Single User Multi Tasking Operating System 
 

Most people use this Operating-System on their computers, laptop and desktops. Best 

examples of these types of Operating System are Apple‘s Mac OS platform and 

Microsoft‘s Windows. 

 

This Operating System will allow a single user to operate several programs at the same 

time. For example, a Windows user may be writing an e-mail while printing a word 

document while downloading a file from Internet. 

 

Advantages 

● It is time saving as it performs multiple tasks at a time yielding high productivity. 

 

Disadvantages 

● This operating system is highly complex and occupies more space. 

 

Real-Time Operating System 

A real-time operating system (RTOS) is a special-purpose operating system used in 

computers that has strict time constraints for any job to be performed. It is employed 

mostly in those systems in which the results of the computations are used to influence a 

process while it is executing. Whenever an event external to the computer occurs, it is 

communicated to the computer with the help of some sensor used to monitor the event. 

The sensor produces the signal that is interpreted by the operating system as an 

interrupt. On receiving an interrupt, the operating system invokes a specific process or a 

set of processes to serve the interrupt. 

This process is completely uninterrupted unless a higher priority interrupt occurs during 

its execution. Therefore, there must be a strict hierarchy of priority among the interrupts. 

The interrupt with the highest priority must be allowed to initiate the process, while lower 

priority interrupts should be kept in a buffer that will be handled later. Interrupt 

management is important in such an operating system. 
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1. Hard Real-Time: 

This type handles deadlines very strictly. Thus, the given task must start and finish 

execution within the assigned time duration. Example: Medical critical care system and 

aircraft systems. 

2. Firm Real-Time: 

This type needs to follow deadlines though one or two missing deadlines would not have 

a big impact they could still cause undesired effects. These effects include a huge 

reduction in the quality of a product. Example: Multimedia applications. 

3. Soft Real-Time: 

This type handles delays by the OS softly. Though there is a deadline assigned for a 

specific job, a little delay is acceptable. Example: Livestock price quotation system. 

 

Examples of the real-time operating systems: Airline traffic control systems, Command 

Control Systems, Airlines reservation system, Heart Pacemaker, Network Multimedia 

Systems, Robot etc. 

Multi User Operating System 

Multi User Operating System allows various different users on different desktop or 

computer to access a single System. A user at the terminal or desktop, through a 

network takes access of the system and other system attached machines such as 

printers. 

The Operating System takes care of all the requirements of the various users in a 

balanced manner. Also, it ensures that each of the programs being used has a separate 

and sufficient resource so that problem of one user doesn‘t affect the entire community 

of users. 
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Multiuser / Multitasking Operating System 

It is an operating system that permits several users to utilize the programs that are 

concurrently running on a single network server. The single network server is termed as 

"Terminal server". "Terminal client" is software that supports user sessions. Examples 

include UNIX, MVS, etc. 

 

Advantages 

● It is highly productive as it performs multiple tasks at a time. 

● It is time saving as we don‘t have to make changes in many desktops, instead can 

make changes only to the server. 
 

Disadvantages 

● If the connection to the server is broken, user cannot perform any task on the client 

as it is connected to that server. 

 

2.1.2 System Administration 

2.1.2.1 Installing Windows 
 

How to install Windows 10: Full installation 

Before we get into the installation walkthrough, it‘s worth noting that installing Windows 

10 can be a lengthy process. Make sure you have enough time to wait it out.  

1. Check your device meets the Windows 10 system requirements. Below you‘ll find the 

minimum specs needed to run Windows 10, so check your device is capable:  

CPU: 1GHz or faster processor 

RAM: 1GB for Windows 10 32-bit or 2GB for Windows 10 64-bit 

Storage: 32GB of space or more 

GPU: DirectX 9 compatible or later with WDDM 1.0 driver 

Display: 800x600 resolution or higher 
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2. Create USB installation media. Visit Microsoft's Windows 10 download page(opens in 

new tab) and select ―Download tool now‖ under the ―create Windows 10 installation 

media‖ section. Transfer the downloaded installer tool to a USB drive. 

3. Run the installer tool. Open the installer tool by clicking on it. Accept Microsoft‘s terms, 

and then select ―Create installation media for another PC‖ on the ―What do you want to 

do?‖ page. After selecting which language you want Windows 10 to run in, and which 

edition you want as well (32-bit or 62-bit), you‘ll be asked what type of media you want to 

use. 

  

Installing from a USB drive is definitely the preferred option but you can also install from 

a CD or ISO file. Once you choose your device, the installer tool will download the 

required files and put them onto your drive.  

4. Use your installation media. Insert your installation media into your device and 

then access the computer‘s BIOS or UEFI. These are the systems that allow you to control 

your computer‘s core hardware.  

  

The process of accessing these systems is unique to each device, but the manufacturer‘s 

website should be able to give you a helping hand here. Generally, you'll need to press 

the F2, F12 or Delete keys as your computer boots up. 

 

5. Change your computer's boot order. Once you have access to your computer‘s 

BIOS/UEFI you‘ll need to locate the settings for boot order. You need the Windows 10 

installation tool to be higher up on the list than the device‘s current current boot drive: 

this is the SSD or HDD that your existing OS is stored on. You should move the drive with 

the installer files to the very top of the boot order menu. Now, when you restart your 

device the Windows 10 installer should load up first.  

 

6. Restart your device. Save your settings in the BIOS/UEFI and reboot your device. 

 

7. Complete the installation. Your device should now load up the Windows 10 installation 

tool on restart. This will guide you through the rest of the installation process.  

 

How to install Windows 10: Upgrading from an older version of Windows 

If you‘re upgrading to Windows 10 from Windows 7 or Windows 8, the process is much 

easier. Here's how to upgrade from an older version of the Windows operating system. 

 

1. Download the installer tool. Visit Microsoft's Windows 10 download page(opens in new 

tab) and select ―Download tool now‖ under the ―create Windows 10 installation media‖ 

section. 

2. Run installer tool. You can just upgrade your version of Windows directly from the 

installer tool, without creating separate installation media. When you reach the ―what do 

you want to do?‖ section, select ―Upgrade this PC now.‖ 
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3. Complete Windows 10 installation. Now the installer tool will guide you through the 

rest of the process. Just follow the steps to complete the installation process and you'll 

have Windows 10 installed on your device at the end of it.  

2.1.2.2 Booting the System 
 

Booting is the process of starting a computer. It can be initiated by hardware such as a 

button press or by a software command. After it is switched on, a CPU has no software in 

its main memory, so some processes must load software into memory before execution. 

This may be done by hardware or firmware in the CPU or by a separate processor in the 

computer system. 

Restarting a computer also is called rebooting, which can be "hard", e.g., after electrical 

power to the CPU is switched from off to on, or "soft", where the power is not cut. On 

some systems, a soft boot may optionally clear RAM to zero. Hard and soft booting can 

be initiated by hardware such as a button press or a software command. Booting is 

complete when the operative runtime system, typically the operating system and some 

applications, is attained. 

The process of returning a computer from a state of sleep does not involve booting; 

however, restoring it from a state of hibernation does. Minimally, some embedded 

systems do not require a noticeable boot sequence to begin functioning and, when 

turned on, may run operational programs that are stored in ROM. All computer systems 

are state machines and a reboot may be the only method to return to a designated zero-

state from an unintended, locked state. 

In addition to loading an operating system or stand-alone utility, the boot process can 

also load a storage dump program for diagnosing problems in an operating system. 

Sequencing of Booting 

Booting is a start-up sequence that starts the operating system of a computer when it is 

turned on. A boot sequence is the initial set of operations that the computer performs 

when it is switched on. Every computer has a boot sequence. 

 

1. Boot Loader: Computers powered by the central processing unit can only execute code 

found in the system's memory. Modern operating systems and application program code 

and data are stored on nonvolatile memories. When a computer is first powered on, it 

must initially rely only on the code and data stored in nonvolatile portions of the system's 

https://www.javatpoint.com/cpu-full-form
https://www.javatpoint.com/central-processing-unit
https://www.javatpoint.com/os-tutorial
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memory. The operating system is not really loaded at boot time, and the computer's 

hardware cannot perform many complex systems actions. 

The program that starts the chain reaction that ends with the entire operating system 

being loaded is the boot loader or bootstrap loader. The boot loader's only job is to load 

other software for the operating system to start. 

2. Boot Devices: The boot device is the device from which the operating system is loaded. 

A modern PC BIOS (Basic Input/Output System) supports booting from various devices. 

These include the local hard disk drive, optical drive, floppy drive, a network interface 

card, and a USB device. The BIOS will allow the user to configure a boot order. If the boot 

order is set to: 

o CD Drive 

o Hard Disk Drive 

o Network 
 

The BIOS will try to boot from the CD drive first, and if that fails, then it will try to boot 

from the hard disk drive, and if that fails, then it will try to boot from the network, and if 

that fails, then it won't boot at all. 

3. Boot Sequence: There is a standard boot sequence that all personal computers use. 

First, the CPU runs an instruction in memory for the BIOS. That instruction contains a 

jump instruction that transfers to the BIOS start-up program. This program runs a power-

on self-test (POST) to check that devices the computer will rely on are functioning 

properly. Then, the BIOS goes through the configured boot sequence until it finds a 

bootable device. Once BIOS has found a bootable device, BIOS loads the bootsector and 

transfers execution to the boot sector. If the boot device is a hard drive, it will be a 

master boot record (MBR). 

The MBR code checks the partition table for an active partition. If one is found, the MBR 

code loads that partition's boot sector and executes it. The boot sector is often operating 

system specific, and however, in most operating systems, its main function is to load and 

execute the operating system kernel, which continues start-up. Suppose there is no 

active partition, or the active partition's boot sector is invalid. In that case, the MBR may 

load a secondary boot loader which will select a partition and load its boot sector, which 

usually loads the corresponding operating system kernel. 

Types of Booting 

There are two types of booting in an operating system. 
 

 

https://www.javatpoint.com/cd
https://www.javatpoint.com/hdd
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1. Cold Booting: When the computer starts for the first time or is in a shut-down state 

and switch on the power button to start the system, this type of process to start the 

computer is called cold booting. During cold booting, the system will read all the 

instructions from the ROM (BIOS) and the Operating System will be automatically 

get loaded into the system. This booting takes more time than Hot or Warm 

Booting. 

2. Warm Booting: Warm or Hot Booting process is when computer systems come to no 

response or hang state, and then the system is allowed to restart during on 

condition. It is also referred to as rebooting. There are many reasons for this state, 

and the only solution is to reboot the computer. Rebooting may be required when 

we install new software or hardware. The system requires a reboot to set software 

or hardware configuration changes, or sometimes systems may behave abnormally 

or may not respond properly. In such a case, the system has to be a force restart. 

Most commonly Ctrl+Alt+Del button is used to reboot the system. Else, in some 

systems, the external reset button may be available to reboot the system. 

Booting Process in Operating System 

When our computer is switched on, it can be started by hardware such as a button press, 

or by software command, a computer's central processing unit (CPU) has no software in 

its main memory, there is some process which must load software into main memory 

before it can be executed. Below are the six steps to describe the boot process in the 

operating system, such as: 

 

Step 1: Once the computer system is turned on, BIOS (Basic Input /Output System) 

performs a series of activities or functionality tests on programs stored in ROM, called 

on POST (Power-on Self Test) that checks to see whether peripherals in the system are in 

perfect order or not. 

Step 2: After the BIOS is done with pre-boot activities or functionality test, it read 

bootable sequence from CMOS (Common Metal Oxide Semiconductor) and looks for 

master boot record in the first physical sector of the bootable disk as per boot device 

sequence specified in CMOS. For example, if the boot device sequence is: 

o Floppy Disk 

o Hard Disk 

o CDROM 
 

Step 3: After this, the master boot record will search first in a floppy disk drive. If not 

found, then the hard disk drive will search for the master boot record. But if the master 

boot record is not even present on the hard disk, then the CDROM drive will search. If the 

https://en.wikipedia.org/wiki/Control-Alt-Delete
https://www.javatpoint.com/what-is-a-floppy-disk
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system cannot read the master boot record from any of these sources, ROM displays "No 

Boot device found" and halted the system. On finding the master boot record from a 

particular bootable disk drive, the operating system loader, also called Bootstrap loader, 

is loaded from the boot sector of that bootable drive· into memory. A bootstrap loader is a 

special program that is present in the boot sector of a bootable drive. 

Step 4: The bootstrap loader first loads the IO.SYS file. After this, MSDOS.SYS file is 

loaded, which is the core file of the DOS operating system. 

Step 5: After this, MSDOS.SYS file searches to find Command Interpreter 

in CONFIG.SYS file, and when it finds, it loads into memory. If no Command Interpreter is 

specified in the CONFIG.SYS file, the COMMAND.COM file is loaded as the default 

Command Interpreter of the DOS operating system. 

Step 6: The last file is to be loaded and executed is the AUTOEXEC.BAT file that contains 

a sequence of DOS commands. After this, the prompt is displayed. We can see the drive 

letter of bootable drive displayed on the computer system, which indicates that the 

operating system has been successfully on the system from that drive. 

 

2.1.2.3 Maintaining user accounts 

Windows 10 allows you to log in to different user accounts when using your computer. 

Like we discussed earlier, you can choose which account you want to log in to after 

turning on the computer. 

But you can also configure or manage your user account after you‘re logged in. To do 

this, follow these steps − 

Step 1 − Open the Start Menu. 

Step 2 − Click on Settings. 

Step 3 − From the SETTINGS window, choose Accounts option. 

Step 4 − In the ACCOUNTS window, choose the account setting you want to configure. 
 

2.1.2.4 File systems and special files 

A file system is a process of managing how and where data on a storage disk, which is 

also referred to as file management or FS. It is a logical disk component that compresses 

files separated into groups, which is known as directories. It is abstract to a human user 

and related to a computer; hence, it manages a disk's internal operations. Files and 

additional directories can be in the directories. Although there are various file systems 

with Windows, NTFS is the most common in modern times. It would be impossible for a 

file with the same name to exist and also impossible to remove installed programs and 

recover specific files without file management, as well as files would have no 

organization without a file structure. The file system enables you to view a file in the 

current directory as files are often managed in a hierarchy. 
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A disk (e.g., Hard disk drive) has a file system, despite type and usage. Also, it contains 

information about file size, file name, file location fragment information, and where disk 

data is stored and also describes how a user or application may access the data. The 

operations like metadata, file naming, storage management, and directories/folders are 

all managed by the file system. 

On a storage device, files are stored in sectors in which data is stored in groups of 

sectors called blocks. The size and location of the files are identified by the file system, 

and it also helps to recognize which sectors are ready to be used. Other than Windows, 

there are some other operating systems that contain FAT and NTFS file system. But Apple 

product (like iOS and macOS) uses HFS+ as operating system is horizon by many 

different kinds of file systems. 

Sometimes the term "file system" is used in the reference of partitions. For instance, 

saying, "on the hard drive, two files systems are available," that does not have to mean 

the drive is divided between two file systems, NTFS and FAT. But it means two separate 

partitions are there that use the same physical disk. 

 

Types of file systems 

There are various kinds of file systems, which are as follows: 

1. Disk file systems 

On the disk storage medium, a disk file system has the ability to randomly address data 

within a few amounts of time. Also, it includes the anticipation that led to the speed of 
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accessing data. Without regard to the sequential location of the data, multiple users can 

access several data on the disk with the help of a disk file system. 

2. Flash file systems 

A flash file system is responsible for restrictions, performance, and special abilities of 

flash memory. It is superior to utilize a file system that is designed for a flash device; 

however, a disk file system is the basic storage media, which can use a flash memory 

device. 

3. Tape file systems 

A tape file system is used to hold files on the tape as it is a tape format and file system. 

As compared to disks, magnetic tapes are more powerful to access data for a long time, 

which are the challenges for a general-purpose file system in terms of creation and 

efficient management. 

4. Database file systems 

A database-based file system is another method for file management. Files are 

recognized by their characteristics (like a type of file, author, topic, etc.) rather than 

hierarchical structured management. 

5. Transactional file systems 

Some programs require one or more changes to fail for any reason or need several file 

systems changes but do not make any changes. For instance, a program may write 

configuration files or libraries mand executables at the time of installing or updating the 

software. The software may be unusable or broken if the software is stopped while 

updating or installing. Also, the entire system may leave in an unusable state if the 

process of installing or updating the software is incomplete. 

6. Network file systems 

A network file system offers access to files on a server. In remote network-connected 

computers, with the help of local interfaces, programs are able to transparently create, 

manage and access hierarchical files and directories. The file-system-like clients for FTP 

and WebDAV, and AFS, SMB protocols, NFS are all examples of the network file systems. 

7. Shared disk file systems 

A shared-disk file system allows the same external disk subsystem to be accessed by 

multiple machines, but when the number of machines accesses the same external disk 

subsystem, there may be occurred collisions in this condition; so, to prevent the collision, 

the file system decides which subsystem to be accessed. 

 

2.1.2.5 Backups and restoration 

Windows 10 features several tools to help you perform backups of your documents. Here 

are some of these tools. 
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File History 

File History will perform a back-up of the files located in your libraries (Documents, 

Pictures, Music, etc.) It allows you to choose a drive, where you can back-up your files 

and then asks you when to do it. 

To configure the File History backup, follow these steps − 

Step 1 − Go to SETTINGS and select Update & security. 

 

Step 2 − In the UPDATE & SECURITY window, select Backup. 

 

Step 3 − Click ―Add a drive‖ to choose where to store your backup. 
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2.1.3 Windows Desktop  

2.1.3.1 GUI 
 

GUI stands for graphical user interface. A GUI, which some folks pronounce as 'gooey', is 

exactly what it sounds like... a graphical way to do stuff. Simply put, a graphical user 

interface is a way to communicate what you want to a computer application (or computer 

operating system) using graphical symbols rather than typing the instructions in. GUIs let 

you work with picture-like items (icons and arrows for example) to tell the computer what 

you want from it. And, rather than a keyboard (which can leave you guessing what to type 

next), you get to scoot around a blocky thing on your desk called a mouse, which makes 

the arrows and icons scoot around on the screen. Much easier! 

You may not have even heard of the opposite of a GUI, which is a command-line 

interface or CLI. Yep, years ago we used to hunch over keyboards and laboriously type in 

cryptic, difficult-to-memorize phrases just to do stuff. We also hoped the computer 

wouldn't reply with something obtuse like 'SYNTAX ERROR', 'INVALID PIP FORMAT' or 

some other unhelpful reply. Command-line interfaces still exist today. In fact, without 

them, many important computer tasks would be downright difficult. However, for most 

daily needs and casual users, the GUI is a nice thing to have. 

Cursor 

Mouse cursor is a symbol or graphical image on the computer monitor or other display 

device that echoes movements of the pointing device, commonly a mouse, touchpad, 

or stylus pen. It signals the point where actions of the user take place. It can be used 

in text-based or graphical user interfaces to select and move other elements. It is distinct 

from the cursor, which responds to keyboard input. 

GUI Pointer 

A pointing device, or sometimes called a pointing tool, is a hardware input device that 

allows the user to move the mouse cursor in a computer program or GUI operating 

system. Using a pointing device, you can point at or manipulate any object or text on the 

screen. 

GUI Icons 

In computing and digital design, icons are pictograms or ideograms used in the web or 

mobile interface to support its usability and provide the successful flow of human-

computer interaction. Diving into the benefits of icons, one of the most important among 

them is the ability to replace the text. 

GUI Menus 

A menu is a set of options presented to the user of a computer application to help the 

user find information or execute a program function. Menus are common in graphical 

user interfaces (GUI s) such as Windows or the Mac OS . Menus are also employed in 

some speech recognition programs. 

https://en.wikipedia.org/wiki/Computer_monitor
https://en.wikipedia.org/wiki/Display_device
https://en.wikipedia.org/wiki/Display_device
https://en.wikipedia.org/wiki/Pointing_device
https://en.wikipedia.org/wiki/Mouse_(computing)
https://en.wikipedia.org/wiki/Touchpad
https://en.wikipedia.org/wiki/Digital_pen
https://en.wikipedia.org/wiki/Text-based_user_interface
https://en.wikipedia.org/wiki/Graphical_user_interface
https://en.wikipedia.org/wiki/Computer_keyboard
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GUI Shares Data 

You can share data between callbacks by storing the data in the MATLAB handles 

structure. All components in a GUI share the same handles structure. It is passed as an 

input argument to all callbacks generated by GUIDE. 

 

2.1.3.2 Desktop Icons and their Functions 
 

An icon is a small graphical representation of a program, feature, or file. When you click 

or double-click an icon, the associated file or program opens or an action is performed. 

For example, if you were to double-click My Computer icon, it would open Windows 

 

Functions of My Computer 

My Computer allows the user to access the local drives, such as the local disk, also 

known as the C: Drive. The user can also access external drives. Examples of an external 

drive are a floppy disk drive (A: Drive) and the CD Drive (D:). My computer also lets the 

user access My Documents and other files. 

 

Functions of My Document 

The My Documents folder is a component of the user profile that is used as a unified 

location for storing personal data. By default, the My Documents folder is a folder in the 

user's profile that is used as a default storage location for saved documents. 

 

Network Neighbourhood 

My Network Places replaces Network Neighborhood in Windows for browsing available 

network connections, computer, and devices. In a home network setting, My Network 

Places can display the other computers, network printers, and other network resources 

 

Functions of Recycle bin 

The Recycle Bin acts a 'holding bay' for deleted items, such as files and folders (and even 

shortcuts!). When you delete a file or folder, it is not deleted from your computer 

permanently. Instead, Windows 7 places the deleted items into the Recycle Bin 

 

Quick Launch Bar 

Quick Launch is a section of the Microsoft Windows taskbar that enables a user the 

launch programs without having to locate them using the Start menu. The Quick Launch 

area is located next to the Start button. This feature was first introduced with the release 

of Microsoft Windows 98. 
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System Tray 

The system tray is a notification area on the operating system taskbar. It contains icons 

that provide users with easy access to system functions such as email, printer, network 

connections and volume control. The icons also indicate the statuses of the processes 

running on the computer. 

 

Start Menu 

The Start menu is a graphical user interface element used in Microsoft Windows since 

Windows 95 and in other operating systems. It provides a central launching point for 

computer programs and performing other tasks in the Windows shell. 

 

Taskbar 

The taskbar is the access point for programs displayed on the desktop. With the new 

Windows 7 taskbar features, users can give commands, access resources, and view 

program status directly from the taskbar. The taskbar is the access point for programs 

displayed on the desktop, even if the program is minimized. 

 

2.1.3.3 Dialog Boxes 
 

Dialog box 

A dialog box is a temporary window an application creates to retrieve user input. An 

application typically uses dialog boxes to prompt the user for additional information for 

menu items 

List box  

A list box is a graphical control element that allows the user to select one or more items 

from a list contained within a static, multiple line text box. 

Spin box 

A spin box sometimes called a spinner control is a collective term for the combination of 

a text box with an up-down control. Users can click arrow buttons (the up-down control) or 

press the UP ARROW or DOWN ARROW key to change the value in the text box. The value 

ascends or descends incrementally 

 

Slide 

A sliding window is often described as a double hung window placed on its side. They can 

open from either the left or the right side to provide a wide view of your surroundings. 

Slider windows can also come with a variety of customization, from grids to personalized 

interior and exterior colors. 
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Drop-down list 

A drop-down list box saves space (it can drop down to cover other dialog box controls 

temporarily). A combo box allows the user either to select an item from the list or type in 

a new item. The items displayed in a list box, drop-down list box, or combo box are stored 

in an array that is defined before the instructions that define the dialog box 

 

Radio Buttons in Dialog Boxes 

A radio button control groups options in such a way that they are all displayed, but only 

one may be selected at a time.  Place an r inside the braces of the display area to 

indicate the list of options in the input area of the menu are to be used as a radio button 

control. 
 

Check box 

Check box is either checked or unchecked. Check box is either checked, unchecked or 

grayed, and it switches between checked and unchecked when clicked. Check box is 

either checked, unchecked or grayed, and it cycles through all three states as the button 

is clicked. 

Textbox   

 

This widget displays the contents of a file in a scroll window.  The format for this widget is 

--textbox      <file> <height> <width> 

The command which we  wrote in the script file is dialog –textbox /etc/hosts 10 60 

 
Textbox widget 

After running the script, we get the window as shown below 
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2.1.3.4 Task Bar 

 

System Tray 

The System Tray is another name given to the Notification Area, which we can find in the 

right-side of the Windows Taskbar. The System Tray features different types of 

notifications and alerts from your computer like your Internet connection, or the volume 

level. 

Quick Launch 

Quick Launch is a section of the Microsoft Windows taskbar that enables a user the 

launch programs without having to locate them using the Start menu. The Quick Launch 

area is located next to the Start button. 

This feature was first introduced with the release of Microsoft Windows 98. The image 

below shows an example with three Quick Launch icons in-between the Start button and 

currently-running programs. On the far right of the taskbar is the Windows Notification 

Area. 

Start Menu 

The Start Menu is the main point of access to your applications. There are two main ways 

to open it − 

Step 1 − Use your mouse to click Windows icon in the lower-left corner of the taskbar. 

Step 2 − Press the Windows key on your keyboard. 

The Windows 10 Start Menu features two panes. 

The left pane resembles the traditional Start Menu from Windows 7 and earlier, while the 

right pane features live tiles that were used in Windows 8. 

 

Left Pane 

Among the things you can do in the left pane are − 

● Click the username at the top of the menu to change account settings or log in 

with another user. 

● Access the applications you use more frequently. 

● A small arrow next to an application will open a sub-menu with a list of recent 

documents opened with that application. 

● Open the ―File Explorer‖ to navigate your folders and files. 

● Change the settings of your computer like your Internet connection or changing 

your background. 

● See different options to shut down your computer. 

● See a list of all the applications installed in your computer. 
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Right Pane 

The right pane features a varied array of tiles, similar to the ones that were seen on the 

Start Screen of Windows 8. 

These tiles can be moved and dragged to different places by holding the mouse button. 

 

2.1.3.5 Parts of Windows 
 

Title Bar 

It is a horizontal Bar at the top of the window. The title of the running application or file is 

displayed in this bar. It is also the means for moving the window-when you point the 

mouse cursor to this bar and drag the mouse, you move the window on the screen. 

Menu Bar 

It contains the titles of pull down menus. The titles in the bar may very from application 

to application. Clicking title of a menu in the menu bar opens the particular menu of 

commands. 

Scroll Bar 

Generally, there are two scroll bars to a window. A vertical scroll bar at the right hand 

edge of the window and a horizontal scroll bar at the button of the window. These scroll 

bars enables scrolling the contents in the workspace horizontally and vertically. 

There are a number of button on the window as briefed below. 

Status Bar 

A status bar is an area at the bottom of a primary window that displays information about 

the current window's state (such as what is being viewed and how), background tasks 

(such as printing, scanning, and formatting), or other contextual information (such as 

selection and keyboard state). 

Status bars typically indicate status through text and icons, but they can also have 

progress indicators, as well as menus for commands and options related to status. 

Minimize and Maximize  

The size of a window can be minimised or maximised by clicking the minimize or 

maximize buttons respectively. These are located at the right hand top corner of the 

window. 
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Restore Button 

The window size can be restored to previous size by clicking restore button. 

Close and Resize  

● Close button is located at the right hand top corner of the window, near restore 

button. Clicking the close button will close the window. 

● Resize a window by dragging the edges or corner of the window. Hold down Shift 

while resizing to snap the window to the edges of the screen and other windows. 

Move or resize a window using only the keyboard. Press Alt+F7 to move a window or 

Alt+F8 to resize. Use the arrow keys to move or resize, then press Enter to finish, or press 

Esc to return to the original position and size. 

Moving a Window 

Before a window can be moved, make sure it is not maximized. A maximized window 

cannot be resized. If the window is maximized, click the maximize or resize button. 

Move a window using the mouse 

Once a window has is resized so it is not full screen, it can be moved anywhere on your 

screen. Click and hold the left mouse button on the title bar of the window. Then, drag it 

to any location. 

2.1.3.6 Windows 
 

Windows is a group of several proprietary graphical operating system families developed 

and marketed by Microsoft. Each family caters to a certain sector of the computing 

industry. Active Windows families include Windows NT and Windows IoT; these may 

encompass subfamilies, (e.g. Windows Server or Windows Embedded Compact) 

(Windows CE). Defunct Windows families include Windows 9x, Windows 

Mobile and Windows Phone 

 

Start Menu 

To open the Start menu—which contains all your apps, settings, and files—do either of the 

following: 

● On the left end of the taskbar, select the Start icon. 

● Press the Windows logo key on your keyboard 
 

Help Menu 

Open the Help window. The Help system must be install for this to be enabled. View pop-

up help for the current field. Press Ctrl+H as a shortcut, or click the Help on Field icon on 

the toolbar. 

https://en.wikipedia.org/wiki/Proprietary_software
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https://en.wikipedia.org/wiki/Windows_IoT
https://en.wikipedia.org/wiki/Windows_Server
https://en.wikipedia.org/wiki/Windows_Embedded_Compact
https://en.wikipedia.org/wiki/Windows_9x
https://en.wikipedia.org/wiki/Windows_Mobile
https://en.wikipedia.org/wiki/Windows_Mobile
https://en.wikipedia.org/wiki/Windows_Phone


P a g e  | 71 

 

 

Preview Menu 
 

This plugin lets you preview your menu on any registered location. 

 

2.1.3.7 Logoff & Shutdown – Keyboard Accelerators 

 

Shutdown and logout is when you shut down everything stops running and the PC is 

powered off. Logout will logout your session but the computer will remain running. 

 

Accelerator keys (or keyboard accelerators) are keyboard shortcuts that improve the 

usability and accessibility of your Windows applications by providing an intuitive way for 

users to invoke common actions or commands without navigating the app UI. 

 

Keyboard Short Keys 

● Copy: Ctrl + C 

● Cut: Ctrl + X 

● Paste: Ctrl + V 

● Maximize Window: F11 or Windows logo key  + Up arrow  

● Open Task View: Windows logo key  + Tab 

● Display and hide the desktop: Windows logo key  + D 

● Switch between open apps: Alt + Tab 

● Open the Quick Link menu: Windows logo key  + X 

● Lock your PC: Windows logo key  + L 

Depending on your hardware, you can use Windows logo key  + PrtScn to take a 

screenshot, or use Fn + Windows logo key  + Spacebar.  

2.1.3.8 Working with Notepad & WordPad  
 

1. NotePad: It is a basic text editor or editing program of the Microsoft Windows which 

enables the computer users to create documents into it. 

2. WordPad: It is also a basic editing type of program which helps in creating documents 

like letters, reports, notes, etc. with some additional formatting features into it. 

 

Notepad 

Notepad is a very basic text-editing program that comes as an included application on 

Windows operating systems. Notepad is great for writing short documents that you want 

to save in plain text. Notepad has some additional features to take advantage of as well. 

However, Notepad is just a text editor, so images are not compatible. Because Notepad 

is basically the same on both Windows 7 and Windows 8.1, the only difference is how 

you open the program. Learning the basics of Notepad is quick and easy! 



P a g e  | 72 

 

Creating a File 

1. Open Notepad - On Windows 7, open your Start Menu and type "Notepad" in the 

search box. Select Notepad to open the application. You can also navigate to the 

"Accessories" folder in the Start Menu and select Notepad from the list of applications.  

On Windows 8.1, type "Notepad" into the Start screen search box. 

2. Explore the Notepad user interface - Once Notepad is open, you will see a simple 

screen with a limited set of text editing options. Notice menu options for File, Edit, 

Format, View, and Help. 

3. Open an existing file in Notepad - Choose Open from the File menu.  The Open a File 

dialog box lists files and folders in your current folder. You can browse the documents 

listed, or change to a new folder to locate other files on your system.  Select the name 

of the document you want to open, or type the document name in the Enter file name 

field.  Press Return or click OK. 

4. Open the File Menu - You will see a drop down list with New, Open, Save, Save As, 

Page Setup, and Print. These are the basic options for word editing. Select "New" to 

create a document. 

● Whenever you save a file with either Save or Save As, Windows will automatically 

save the file in .txt format, which will launch it in Notepad. 

● You can choose to save Notepad documents in HTML by choosing Save As and 

selecting All Files from the list of choices, then saving the file with .htm or .html as 

its extension. Type your HTML code directly into your document as if you would 

plain text. 

● In order to properly save a document in HTML, you will need to have Word Wrap 

enabled. You will find instructions on how to enable this feature a little later. 

 

5. Format your page Setup - Navigate to Page Setup from the File menu. You will see 

just a few simple formatting options. Choose your desired paper size, orientation, and 

header and footer options from this menu. 

6. Add a header and footer - Notepad includes a header by default, which is the name of 

the document and the date it was printed. The default footer text is the page number. 

You can remove these defaults by selecting the Header and Footer option from the 

File menu on the menu bar and deleting the codes inside. All header and footer 

setting must be entered manually each time you want to print a document. These 

settings cannot be saved. To change headers and footers, choose Page Setup from 

the File menu and enter the desired command(s) in the Header and Footer text 

boxes. The following is a short list of header and footer commands: 

● &l Left-align the characters that follow 

● &c Center the characters that follow 

● &r Right-align the characters that follow 

● &d Print the current date 

https://www.wikihow.com/Use-Notepad#/Image:Use-Notepad-Step-2.jpg
https://www.wikihow.com/Use-Notepad#/Image:Use-Notepad-Step-2.jpg
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● &t Print the current time 

● &f Print the name of the document 

● &p Print the page number 

● Leaving the Header or Footer text box empty will result in no header footer on your 

printed document. 

● You can insert words into the Header and Footer text box and they will print in 

their appropriate position. Letters after the "&" sign do not need to be capitalized. 

● In Notepad, your header is centered, regardless of the formatting codes you use, if 

the formatting code is not the first item in the Header text box. For example, to 

align a title to the left side of the page, use &lTitle text. 

 

Editing and Formatting  

1. Become familiar with the "Edit" tab on the menu bar. Undo is the first item you will 

find under the Edit pull down on the menu bar. You can use the keyboard shortcut 

Ctrl-Z for this function also. Once you use Undo you will find Redo as an option in its 

place. 

● The rest of the menu, Cut, Copy, Paste, Delete, Find, Find Next, Replace, Go To, 

Select All, and Time/Date, are standard in nearly all Windows programs that deal 

with word documents. 

● The "Go To" option is only available if Word Wrap is disabled and if your document 

contains numbered lines. Notepad defaults with Word Wrap turned off. 
 

2. Enable Word Wrap. Unless Word Wrap is enabled, all text you type will be on the 

same line until you press the "Return" key and the line will scroll indefinitely. In order 

to fix this, open the next pull down on the menu bar. Word Wrap is the first option you 

will see. Simply select Word Wrap and your document will be adjusted accordingly.  

3. Adjust your font. Select Font from the Format option on the menu bar. Now, you have 

the ability to select from a series of preloaded fonts, choose options for Bold, 

Italics/Oblique, or Bold/Italics. You can also select your font size from this window. 

● A change in font affects the entire document. You cannot use one type of font on 

one part of the document and another type on another part. 

● From the dropdown menu item listed as "Script" in the Font window, you can find 

characters that are not available in the standard "Western" style fonts. 

 

4. Use the "View" pull down from the menu bar. The only option you will find is called 

"Status Bar." This option is also only available when Word Wrap is disabled. When 

word Wrap is disabled, a notification will display on the lower border of your 

document window showing you where your cursor is located in the document. 

5. Start typing. It is recommended that you enable Word Wrap. Adjust the font as you 

desire and remember that it will be consistent with the entire document text. 
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● Note that the "Tab" key will move your cursor ten spaces across your text line, 

unlike Microsoft Word, which moves five spaces. 

 

6. Save your document. Once you have finished, navigate to the "Save As" option from 

the File pull down on the menu bar. Notepad uses the default folder "My Documents" 

on Windows 7, and the "OneDrive" folder on Windows 8.1. 

● If you would like to save your document in a different place, simply browse your 

preferred folder from the "Save As" window and select it. Notepad will switch to this 

choice for future documents. 

● Remember that all of your files will be saved with the .txt extension. 

 

7. Print your finished document. Click on the File menu and then select the Print option 

from the dropdown. This will bring you to a separate window where you can select the 

printer and options you would like, and click print. To change the settings that 

determine how your printed document will look, click the File menu, and then click 

Page Setup: 

● To change the paper size, tap or click a size in the Size list. 

● To change the paper source, tap or click a tray name or a feeder in the Source list. 

● To print the file vertically, click Portrait; to print the file horizontally, click 

Landscape. 

● To change the margins, enter a width in any of the Margins boxes 

 

Learning Shortcuts  

1. Use the "Escape" key. You can use the escape key as a quick and easy way to get out 

of any dialogs. The escape key is essentially a "cancel" button. Pressing the escape 

key will also hide outputs. The escape key is generally located toward the right-hand 

side of your keyboard and is sometimes indicated by a small arrow pointing to the 

left.  

2. Navigate to another window. To go to the next window, you can use either Ctrl-Tab or 

Ctrl-F6. Press and hold these buttons together to activate the shortcut. Depending on 

your options, this will navigate through documents in Windows' own recent window 

order, or will use a Visual-Studio window stack system. 

● You can hold down the Shift key with either of these combinations to scroll through 

windows in the opposite direction. 

 

3. Toggle your output window. Press the F8 key located along the top of your keyboard 

and the shift key located on the left-hand side to scroll through dockable output 

windows and individual output windows. 

4. Learn more shortcuts. Using shortcuts reduces the time you spend on minor 

adjustments while working on your document. Notepad has a ton of shortcuts ranging 
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from simple actions to complex ones. Here are some of the popular shortcuts for 

Notepad: 

F2 Next Bookmark Alt+Enter Show Document Properties 

F3 Find Next Alt+G Jump To (tags) 

F8 Toggle Output Window Ctrl+F2 Set Bookmark 

Ctrl+W Close Window Ctrl+F4 Close Window 

Alt+F6 Toggle Project Window Ctrl+F6 Next Window 

Alt+F7 Toggle Text Clips Window Ctrl+Space Autocomplete 

Alt+F8 Toggle Find Results Window Ctrl+Tab Next Window 

Ctrl+Alt+C Copy as RTF Ctrl+Insert Copy 

Alt+F9 Toggle CTags Window Shift+F3 Find Previous 

Ctrl+Shift+T Copy Line Ctrl+/ Quick Find 

Alt+F10 Toggle Scripts Window Ctrl+A Select All 

Ctrl+H Replace Dialog Ctrl+C Copy 

Ctrl+F6 Next Window Ctrl+D Duplicate Line 

Ctrl+L Cut Line Ctrl+F Find Dialog 

Ctrl+N New File Ctrl+N New File 

Ctrl+O Open File Ctrl+R Replace Dialog 

Ctrl+V Paste Ctrl+S Save 

Ctrl+P Print Ctrl+Y Redo 

Ctrl+Shift+S Save All Ctrl+Z Undo 

 

Saving Files 

1. Choose Save As from the File menu. The Save As dialog box lists files and folders 

located in your current folder.  

2. Optional.  

3. Type a new file name in the Enter file name field. 

4. Press Return or click OK. 

Formatting 

Formatting text in Microsoft Word refers to controlling how text appears in your 

document. This includes the size, color, and font of the text. It also covers text alignment, 

spacing, and letter case. Microsoft Word styles make it easy to change and apply styles 

throughout a document. 

 

Printing 

1. Select File > Print. 
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2. To preview each page, select the forward and backward arrows at the bottom of the 

page. If the text is too small to read, use the zoom slider at the bottom of the page 

to enlarge it. 

3. Choose the number of copies, and any other options you want, and select the Print 

button. 

Inserting Objects 
 

In the Insert Object dialog box,  

● Click the Create New option and then select an option from the Object type list. The 

default program for that file type opens, where you can enter any text or data you 

want. 

(or) 

● Click the Create from file option and browse the file you want to insert. 

 
 

Finding and replacing 

1. Go to Home > Replace. 

2. Enter the word or phrase you want to replace in Find what. 

3. Enter your new text in Replace with. 

4. Choose Replace All to change all occurrences of the word or phrase. ... 

5. To specify only upper or lowercase in your search, select More > Match case 

 

Creating and Editing Images with Microsoft Paint 

How to Edit a Photo in Paint 

1. Click "File" then "Open" on the Paint main menu. ... 

2. Select the "Line" tool to add straight or curved lines to your photo. ... 
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3. Create a draw shape within your photo using the "Shape" tool from the toolbar. ... 

4. Click the "Text" tool if you want to add a message to your photo, such as a name or 

caption. 

 

Using the Calculator 
 

Windows Calculator is a software calculator developed by Microsoft and included 

in Windows. In Windows 10, it has four modes: standard, scientific, programmer, and a 

graphing mode. The standard mode includes a number pad and buttons for performing 

arithmetic operations. The scientific mode takes this a step further and adds exponents 

and trigonometric function, and programmer mode allows the user to perform operations 

related to computer programming.  Graphing mode was added to the Calculator, allowing 

users to graph equations on a coordinate plane. 

 

To use the Calculator, follow these steps 

● Select the Start menu button. 

● Select All apps. 

● Select Calculator. 

● Click the menu icon. 

● Select a mode. 

 
Personalising windows 
 

Desktop personalization is the process of adjusting the look, feel and organization of a 

Windows end-user experience. In general, any adjustment to the user interface that 

deviates from the default installation settings may be considered to be a personalization, 

but users typically personalize a desktop to improve the personal comfort of the user 

interface, enhance its visual behaviours or reflect personal interests. 

 

To access the Personalization settings, right-click anywhere on the desktop, then select 

Personalize from the drop-down menu. The Personalization settings will appear. 

 

https://en.wikipedia.org/wiki/Calculator
https://en.wikipedia.org/wiki/Microsoft
https://en.wikipedia.org/wiki/Microsoft_Windows
https://en.wikipedia.org/wiki/Windows_10
https://en.wikipedia.org/wiki/Computer_programming
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2.2 Linux 

2.2.1 Linux Programming and Administration 
 

2.2.1.1Introduction to Linux 

Linux is the best-known and most-used open source operating system. As an operating 

system, Linux is software that sits underneath all of the other software on a computer, 

receiving requests from those programs and relaying these requests to the computer's 

hardware. 

2.2.1.2 Features of Linux 

Following are some of the important features of Linux Operating System. 

● Portable − Portability means software can works on different types of hardware in 

same way. Linux kernel and application programs supports their installation on 

any kind of hardware platform. 

● Open Source − Linux source code is freely available and it is community based 

development project. Multiple teams work in collaboration to enhance the 

capability of Linux operating system and it is continuously evolving. 

● Multi-User − Linux is a multiuser system means multiple users can access system 

resources like memory/ ram/ application programs at same time. 

● Multiprogramming − Linux is a multiprogramming system means multiple 

applications can run at same time. 

● Hierarchical File System − Linux provides a standard file structure in which system 

files/ user files are arranged. 
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● Shell − Linux provides a special interpreter program which can be used to execute 

commands of the operating system. It can be used to do various types of 

operations, call application programs. etc. 

● Security − Linux provides user security using authentication features like 

password protection/ controlled access to specific files/ encryption of data 
 

2.2.1.3 Components of Linux  

Linux Operating System has primarily three components 

● Kernel − Kernel is the core part of Linux. It is responsible for all major activities of 

this operating system. It consists of various modules and it interacts directly with 

the underlying hardware. Kernel provides the required abstraction to hide low level 

hardware details to system or application programs. 

● System Library − System libraries are special functions or programs using which 

application programs or system utilities accesses Kernel's features. These 

libraries implement most of the functionalities of the operating system and do not 

requires kernel module's code access rights. 

● System Utility − System Utility programs are responsible to do specialized, 

individual level tasks. 

 

2.2.1.4 Linux Process and Thread Management 
 

Processes in Linux 

A program/command when executed, a special instance is provided by the system to the 

process. This instance consists of all the services/resources that may be utilized by the 

process under execution.  
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● Whenever a command is issued in Unix/Linux, it creates/starts a new process. For 

example, pwd when issued which is used to list the current directory location the user 

is in, a process starts. 

● Through a 5 digit ID number Unix/Linux keeps an account of the processes, this 

number is call process ID or PID. Each process in the system has a unique PID. 

● Used up pid‘s can be used in again for a newer process since all the possible 

combinations are used. 

● At any point of time, no two processes with the same pid exist in the system because 

it is the pid that Unix uses to track each process. 

  

Thread management 
 

Thread management is done in user space by the thread library. When thread makes a 

blocking system call, the entire process will be blocked. Only one thread can access the 

Kernel at a time, so multiple threads are unable to run in parallel on multiprocessors. 

 

 

 

File Management in Linux 

In Linux, most of the operations are performed on files. And to handle these files Linux 

has directories also known as folders which are maintained in a tree-like structure. 

Though, these directories are also a type of file themselves.  

Linux has 3 types of files: 

1. Regular Files: It is the common file type in Linux. it includes files like – text files, 

images, binary files, etc. Such files can be created using the touch command. They 

consist of the majority of files in the Linux/UNIX system. The regular file contains 

ASCII or Human Readable text, executable program binaries, program data and much 

more. 
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2. Directories: Windows call these directories as folders. These are the files that store 

the list of file names and the related information. The root directory(/) is the base of 

the system, /home/ is the default location for user‘s home directories, /bin for 

Essential User Binaries, /boot – Static Boot Files, etc. We could create new 

directories with mkdir command. 

3. Special Files: Represents a real physical device such as a printer which is used for IO 

operations. Device or special files are used for device Input/Output(I/O) on UNIX and 

Linux systems. You can see them in a file system like an ordinary directory or file 

 

Linux File System 

A Linux file system is a structured collection of files on a disk drive or a partition. A 

partition is a segment of memory and contains some specific data. In our machine, there 

can be various partitions of the memory. Generally, every partition contains a file system. 

The general-purpose computer system needs to store data systematically so that we can 

easily access the files in less time. It stores the data on hard disks (HDD) or some 

equivalent storage type. There may be below reasons for maintaining the file system: 

o Primarily the computer saves data to the RAM storage; it may lose the data if it 

gets turned off. However, there is non-volatile RAM (Flash RAM and SSD) that is 

available to maintain the data after the power interruption. 

o Data storage is preferred on hard drives as compared to standard RAM as RAM 

costs more than disk space. The hard disks costs are dropping gradually 

comparatively the RAM. 

The Linux file system contains the following sections: 

o The root directory (/) 

o A specific data storage format (EXT3, EXT4, BTRFS, XFS and so on) 

o A partition or logical volume having a particular file system. 

Linux file system is generally a built-in layer of a Linux operating system used to handle 

the data management of the storage. It helps to arrange the file on the disk storage. It 

manages the file name, file size, creation date, and much more information about a file. 

If we have an unsupported file format in our file system, we can download software to 

deal with it. 

Linux File System Structure 

Linux file system has a hierarchal file structure as it contains a root directory and its 

subdirectories. All other directories can be accessed from the root directory. A partition 

usually has only one file system, but it may have more than one file system. 

https://www.geeksforgeeks.org/mkdir-command-in-linux-with-examples/
https://www.javatpoint.com/linux-tutorial
https://www.javatpoint.com/what-is-linux
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A file system is designed in a way so that it can manage and provide space for non-

volatile storage data. All file systems required a namespace that is a naming and 

organizational methodology. The namespace defines the naming process, length of the 

file name, or a subset of characters that can be used for the file name. It also defines the 

logical structure of files on a memory segment, such as the use of directories for 

organizing the specific files. Once a namespace is described, a Metadata description 

must be defined for that particular file. 

The data structure needs to support a hierarchical directory structure; this structure is 

used to describe the available and used disk space for a particular block. It also has the 

other details about the files such as file size, date & time of creation, update, and last 

modified.  Also, it stores advanced information about the section of the disk, such as 

partitions and volumes. 

The advanced data and the structures that it represents contain the information about 

the file system stored on the drive; it is distinct and independent of the file system 

metadata. 

Linux file system contains two-part file system software implementation architecture. 

Consider the below image: 

 

The file system requires an API (Application programming interface) to access the 

function calls to interact with file system components like files and 

directories. API facilitates tasks such as creating, deleting, and copying the files. It 

facilitates an algorithm that defines the arrangement of files on a file system. 

The first two parts of the given file system together called a Linux virtual file system. It 

provides a single set of commands for the kernel and developers to access the file 

system. This virtual file system requires the specific system driver to give an interface to 

the file system. 

https://www.javatpoint.com/api-full-form
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Linux File System Features 

In Linux, the file system creates a tree structure. All the files are arranged as a tree and 

its branches. The topmost directory called the root (/) directory. All other directories in 

Linux can be accessed from the root directory. 

Some key features of Linux file system are as following: 

o Specifying paths: Linux does not use the backslash (\) to separate the 

components; it uses forward slash (/) as an alternative. For example, as in 

Windows, the data may be stored in C:\ My Documents\ Work, whereas, in Linux, 

it would be stored in /home/ My Document/ Work. 

o Partition, Directories, and Drives: Linux does not use drive letters to organize the 

drive as Windows does. In Linux, we cannot tell whether we are addressing a 

partition, a network device, or an "ordinary" directory and a Drive. 

o Case Sensitivity: Linux file system is case sensitive. It distinguishes between 

lowercase and uppercase file names. Such as, there is a difference between 

test.txt and Test.txt in Linux. This rule is also applied for directories and Linux 

commands. 

o File Extensions: In Linux, a file may have the extension '.txt,' but it is not necessary 

that a file should have a file extension. While working with Shell, it creates some 

problems for the beginners to differentiate between files and directories. If we use 

the graphical file manager, it symbolizes the files and folders. 

o Hidden files: Linux distinguishes between standard files and hidden files, mostly 

the configuration files are hidden in Linux OS. Usually, we don't need to access or 

read the hidden files. The hidden files in Linux are represented by a dot (.) before 

the file name (e.g., .ignore). To access the files, we need to change the view in the 

file manager or need to use a specific command in the shell. 

Types of Linux File System 

When we install the Linux operating system, Linux offers many file systems such as Ext, 

Ext2, Ext3, Ext4, JFS, ReiserFS, XFS, btrfs, and swap. 

 

https://www.javatpoint.com/linux-features
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Let's understand each of these file systems in detail: 

 

1. Ext, Ext2, Ext3 and Ext4 file system 

The file system Ext stands for Extended File System. It was primarily developed for MINIX 

OS. The Ext file system is an older version, and is no longer used due to some limitations. 

Ext2 is the first Linux file system that allows managing two terabytes of data. Ext3 is 

developed through Ext2; it is an upgraded version of Ext2 and contains backward 

compatibility. The major drawback of Ext3 is that it does not support servers because this 

file system does not support file recovery and disk snapshot. 

Ext4 file system is the faster file system among all the Ext file systems. It is a very 

compatible option for the SSD (solid-state drive) disks, and it is the default file system in 

Linux distribution. 

2. JFS File System 

JFS stands for Journaled File System, and it is developed by IBM for AIX Unix. It is an 

alternative to the Ext file system. It can also be used in place of Ext4, where stability is 

needed with few resources. It is a handy file system when CPU power is limited. 

 

3. ReiserFS File System 

ReiserFS is an alternative to the Ext3 file system. It has improved performance and 

advanced features. In the earlier time, the ReiserFS was used as the default file system 

in SUSE Linux, but later it has changed some policies, so SUSE returned to Ext3. This file 

system dynamically supports the file extension, but it has some drawbacks in 

performance. 

 

4. XFS File System 

XFS file system was considered as high-speed JFS, which is developed for parallel I/O 

processing. NASA still using this file system with its high storage server (300+ Terabyte 

server). 

 

5. Btrfs File System 

Btrfs stands for the B tree file system. It is used for fault tolerance, repair system, fun 

administration, extensive storage configuration, and more. It is not a good suit for the 

production system. 

 

6. Swap File System 

The swap file system is used for memory paging in Linux operating system during the 

system hibernation. A system that never goes in hibernate state is required to have swap 

space equal to its RAM size. 

 

https://www.javatpoint.com/cpu-full-form
https://www.javatpoint.com/ram-full-form
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Backup and Recovery 

Before exploring methods particular to CentOS for deploying a standard backup plan, 

let's first discuss typical considerations for a standard level backup policy. The first thing 

we want to get accustomed to is the 3-2-1 backup rule. 

Backup Strategy 

Throughout the industry, you'll often hear the term 3-2-1 backup model. This is a very 

good approach to live by when implementing a backup plan. 3-2-1 is defined as 

follows: 3 copies of data; for example, we may have the working copy; a copy put onto the 

CentOS server designed for redundancy using rsync; and rotated, offsite USB backups 

are made from data on the backup server. 2 different backup mediums. We would 

actually have three different backup mediums in this case: the working copy on an SSD 

of a laptop or workstation, the CentOS server data on a RADI6 Array, and the offsite 

backups put on USB drives. 1 copy of data offsite; we are rotating the USB drives offsite 

on a nightly basis. Another modern approach may be a cloud backup provider. 

System Recovery 

A bare metal restore plan is simply a plan laid out by a CentOS administrator to get vital 

systems online with all data intact. Assuming 100% systems failure and loss of all past 

system hardware, an administrator must have a plan to achieve uptime with intact user-

data costing minimal downtime. The monolithic kernel used in Linux actually makes bare 

metal restores using system images much easier than Windows. Where Windows uses a 

micro-kernel architecture. 

A full data restore and bare metal recovery are usually accomplished through a 

combination of methods including working, configured production disk-images of key 

operational servers, redundant backups of user data abiding by the 3-2-1 rule. Even 

some sensitive files that may be stored in a secure, fireproof safe with limited access to 

the trusted company personnel. 

A multiphase bare metal restore and data recovery plan using native CentOS tools may 

consist of − 

● dd to make and restore production disk-images of configured servers 

● rsync to make incremental backups of all user data 

● tar & gzip to store encrypted backups of files with passwords and notes from 

administrators. Commonly, this can be put on a USB drive, encrypted and locked 

in a safe that a Senior Manager access. Also, this ensures someone else will know 

vital security credentials if the current administrator wins the lottery and 

disappears to a sunny island somewhere. 

If a system crashes due to a hardware failure or disaster, following will be the different 

phases of restoring operations − 

● Build a working server with a configured bare metal image 

● Restore data to the working server from backups 
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● Have physical access to credentials needed to perform the first two operations 
 

Use rsync for File Level Backups 

rsync is a great utility for syncing directories of files either locally or to another 

server. rsync has been used for years by System Administrators, hence it is very refined 

for the purpose of backing up data. In the author's opinion, one of the best features 

of sync is its ability to be scripted from the command line.  In this, we will discuss rsync in 

various ways − 

● Explore and talk about some common options 

● Create local backups 

● Create remote backups over SSH 

● Restore local backups 

 

rsync is named for its purpose: Remote Sync and is both powerful and flexible in use. 

Following is a basic rsync remote backup over ssh − 

MiNi:~ rdc$ rsync -aAvz --progress ./Desktop/ImportantStuff/ 

rdc@192.168.1.143:home/rdc/ Documents/RemoteStuff/ 

rdc@192.168.1.143's password: 

sending incremental file list 

6,148 100% 0.00kB/s 0:00:00 (xfr#1, to-chk=23/25) 

2017-02-14 16_26_47-002 - Veeam_Architecture001.png 

33,144 100% 31.61MB/s 0:00:00 (xfr#2, to-chk=22/25) 

A Guide to the WordPress REST API | Toptal.pdf 

892,406 100% 25.03MB/s 0:00:00 (xfr#3, to-chk=21/25) 

Rick Cardon Technologies, LLC..webloc 

77 100% 2.21kB/s 0:00:00 (xfr#4, to-chk=20/25) 

backbox-4.5.1-i386.iso 

43,188,224 1% 4.26MB/s 0:08:29 

sent 2,318,683,608 bytes received 446 bytes 7,302,941.90 bytes/sec 

total size is 2,327,091,863 speedup is 1.00 

MiNi:~ rdc$ 

The following sync sent nearly 2.3GB of data across our LAN. The beauty of rsync is it 

works incrementally at the block level on a file-by-file basis. This means, if we change just 

two characters in a 1MB text file, only one or two blocks will be transferred across the lan 

on the next sync! 

Furthermore, the incremental function can be disabled in favor of more network 

bandwidth used for less CPU utilization. This might prove advisable if constantly copying 

several 10MB database files every 10 minutes on a 1Gb dedicated Backup-Lan. The 

reasoning is: these will always be changing and will be transmitting incrementally every 

10 minutes and may tax load of the remote CPU. Since the total transfer load will not 

exceed 5 minutes, we may just wish to sync the database files in their entirety. 
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Following are the most common switches with rsync − 

rsync syntax: 

rsync [options] [local path] [[remote host:remote path] or [target path 

 

2.2.2 Linux Commands and Utilities 
 

1. Cat Command 

The cat command is a multi-purpose utility in the Linux system. It can be used to create a 

file, display content of the file, copy the content of one file to another file, and more. 
 

Syntax: 

 cat [OPTION]... [FILE]..   

To create a file, execute it as follows: 

cat > <file name>   

// Enter file content   

Press "CTRL+ D" keys to save the file. To display the content of the file, execute it as 

follows:  

cat <file name>   

 

2. Tail Command 

The tail command is similar to the head command. The difference between both 

commands is that it displays the last ten lines of the file content. It is useful for reading 

the error message. 
 

Syntax:   tail <file name> 

 

3. Wc Command 

The wc command is used to count the lines, words, and characters in a file. 
 

Syntax:    wc <file name>   

 

4. Sort Command 

The sort command is used to sort files in alphabetical order. 
 

Syntax: sort <file name>   

 

5. Mkdir Command 

The mkdir command is used to create a new directory under any directory. 
 

Syntax: mkdir <directory name>  

 

6. cd Command 

The cd command is used to change the current directory. 
 

Syntax: cd <directory name>  

 

7. rmdir Command 

The rmdir command is used to delete a directory. 
 

Syntax: rmdir <directory name>  

https://www.javatpoint.com/linux-cat
https://www.javatpoint.com/linux-tail
https://www.javatpoint.com/linux-wc
https://www.javatpoint.com/linux-sort
https://www.javatpoint.com/linux-mkdir
https://www.javatpoint.com/linux-cd
https://www.javatpoint.com/linux-rmdir
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8. pwd Command 

The pwd command is used to display the location of the current working directory. 
 

Syntax: pwd   

  
9. cp Command 

The cp command is used to copy a file or directory. 
 

Syntax: 

 To copy in the same directory: 

 cp <existing file name> <new file name> 

 

10. more command 

The more command is quite similar to the cat command, as it is used to display the file 

content in the same way that the cat command does. The only difference between both 

commands is that, in case of larger files, the more command displays screenful output at 

a time. 
 

In more command, the following keys are used to scroll the page: 

ENTER key : To scroll down page by line. 

Space bar : To move to the next page. 

b key  : To move to the previous page. 

/ key  : To search the string. 
 

Syntax: more <file name>   

 

11. passwd Command 

The passwd command is used to create and change the password for a user. 
 

Syntax: passwd <username>   

 

12. mv Command 

The mv command is used to move a file or a directory form one location to another 

location. 
 

Syntax: mv <file name> <directory path>   

 

13. mail Command 

The mail command is used to send emails from the command line. 
 

Syntax: mail -s "Subject" <recipient address>  

 

14. who Command 

The who command is used to identify the users currently logged in. 

Syntax: who [ -a |  -b -d -i -l -m -p -q -r -s -t -u  -w -A -H -T -X ] [ File  ] 

 

15. whoami command yntax: $who [options] [filename]  

The whoami command allows Linux users to see the currently logged-in user. The output 

displays the username of the effective user in the current shell. 
 

Syntax: Whoami[option] 

https://www.javatpoint.com/linux-pwd
https://www.javatpoint.com/linux-cp
https://www.javatpoint.com/linux-more
https://www.javatpoint.com/linux-user-password
https://www.javatpoint.com/linux-mv
https://www.javatpoint.com/linux-mail-command
https://www.javatpoint.com/linux-mail-command
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/who.html#who__row-d3e19679
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/who.html#who__row-d3e19692
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/who.html#who__row-d3e19698
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/who.html#who__row-d3e19770
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/who.html#who__row-d3e19704
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/who.html#who__row-d3e19710
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/who.html#who__row-d3e19725
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/who.html#who__row-d3e19731
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/who.html#who__row-d3e19737
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/who.html#who__row-d3e19743
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/who.html#who__row-d3e19755
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/who.html#who__row-d3e19770
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/who.html#who__row-d3e19799
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/who.html#who__row-d3e19780
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/who.html#who__row-d3e19793
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/who.html#who__row-d3e19799
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/who.html#who__row-d3e19827
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/who.html#who__row-d3e19827
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16. chmod Command 

The chmod command is used to change the access permissions of files and directories. 

It stands for change mode. It cannot change the permission of symbolic links. 

Syntax:  chmod <options> <permissions> <file name>  

 

17. kill command 

Syntax: $ type -a kill   

 

18. Write command 

Opens a line of communication to send messages to other users on the system in real 

time. 
 

Syntax: 

To query all messages awaiting replies from users on a host and display them with their 

handles, type the following: 

 write -q [ -n Host ] 

 

19. wall Command 

Writes a message to all users that are logged in. 
 

Syntax: wall [ -a ] [ -g Group ][ Message ] 

 

20. news Command 

Writes system news items to standard output. 
 

Syntax: news [  -a |  -n |  -s | Item ... ] 

 

21. diff Command 

Compares text files. 
 

Syntax: 

To Compare the Contents of Two Files 

 diff [ -c| -C Lines | -D [ String ] | -e | -f | -n | -u | -U Lines ] [ -b ] [ -i ] [ -t ] [ -

w ] File1  File2 

 diff [ -h ] [ -b ] File1 File2 

 

22. cmp Command 

Compares the contents of two files and reports the first character that differs. 
 

Syntax: cmp [  -l |  -s ] File1 File2 

 

23. merge command 

merge command is used for Three-way file merge. This post describes ―merge‖ command 

used in Linux along with usage examples and/or output. 
 

Syntax: merge [ options ] file1 file2 file3 

 

***** 

 

https://www.ibm.com/docs/en/ssw_aix_72/w_commands/write.html#write__row-d3e26394
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/write.html#write__row-d3e26383
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/wall.html#wall__row-d3e16255
https://www.ibm.com/docs/en/ssw_aix_72/w_commands/wall.html#wall__row-d3e16261
https://www.ibm.com/docs/en/aix/7.2?topic=n-news-command#news__row-d3e13700
https://www.ibm.com/docs/en/aix/7.2?topic=n-news-command#news__row-d3e13706
https://www.ibm.com/docs/en/aix/7.2?topic=n-news-command#news__row-d3e13712
https://www.ibm.com/docs/en/aix/7.2?topic=d-diff-command#diff__row-d3e29474
https://www.ibm.com/docs/en/aix/7.2?topic=d-diff-command#diff__row-d3e29432
https://www.ibm.com/docs/en/aix/7.2?topic=d-diff-command#diff__row-d3e29511
https://www.ibm.com/docs/en/aix/7.2?topic=d-diff-command#diff__row-d3e29511
https://www.ibm.com/docs/en/aix/7.2?topic=d-diff-command#diff__row-d3e29543
https://www.ibm.com/docs/en/aix/7.2?topic=d-diff-command#diff__row-d3e29597
https://www.ibm.com/docs/en/aix/7.2?topic=d-diff-command#diff__row-d3e29676
https://www.ibm.com/docs/en/aix/7.2?topic=d-diff-command#diff__row-d3e29749
https://www.ibm.com/docs/en/aix/7.2?topic=d-diff-command#diff__row-d3e29764
https://www.ibm.com/docs/en/aix/7.2?topic=d-diff-command#diff__row-d3e29426
https://www.ibm.com/docs/en/aix/7.2?topic=d-diff-command#diff__row-d3e29652
https://www.ibm.com/docs/en/aix/7.2?topic=d-diff-command#diff__row-d3e29740
https://www.ibm.com/docs/en/aix/7.2?topic=d-diff-command#diff__row-d3e29782
https://www.ibm.com/docs/en/aix/7.2?topic=d-diff-command#diff__row-d3e29782
https://www.ibm.com/docs/en/aix/7.2?topic=d-diff-command#diff__row-d3e29615
https://www.ibm.com/docs/en/aix/7.2?topic=d-diff-command#diff__row-d3e29426
https://www.ibm.com/docs/en/aix/7.2?topic=c-cmp-command#cmp__row-d3e122353
https://www.ibm.com/docs/en/aix/7.2?topic=c-cmp-command#cmp__row-d3e122359
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Introduction to MS Office – MS Word and Open Office - Writer 

3.1 MS Word 

 

Introduction to MS Office 

MS Office helps simplify basic office tasks and improve work productivity. Each 

application is designed to address specific tasks, such as word processing, data 

management, making presentations and organizing emails. 

Microsoft has developed multiple versions of Office that can be supported by different 

operating systems, including Windows, Linux, and mac OS.  

Microsoft Office Common Applications 

The most common Office applications are Word, Excel, PowerPoint, and Outlook. Other 

apps include Publisher, Access and OneNote. 

● Microsoft Word: is a word processor that lets users make and edit text 

documents, such as reports, letters, and résumés and run spell-checks on writing 

● Microsoft Excel: is an electronic spreadsheet program that helps you store, 

organize and manipulate data by creating simple to complex spreadsheets 

● Microsoft PowerPoint: allows you to visually display information, using anything 

from basic slideshows to professional multimedia presentations 

● Microsoft Outlook: is a personal information manager mainly used for emails but 

that can also be used to store calendars and contact information, manage tasks 

as well as organize meetings 

● Microsoft Publisher: is a graphic design app that gives users creating material for 

marketing or publications more options in the layout and design of their 

documents 

● Microsoft Access: is a database management system that allows you to link and 

use data from other sources, manipulate the data you‘ve gathered in different 

ways, as well as create simple business applications 

● Microsoft OneNote: is a digital alternative to a paper notebook that allows you to 

create, organize and share your notes easily 

Microsoft Office is either available as a package or you can buy stand-alone Microsoft 

Office applications, such as Word or Excel separately. 

MS Word and Open Office Writer 

Microsoft word is word processor software developed by Microsoft in 1983. It is the most 

commonly used word processor software. It is used to create professional quality 

documents, letters, reports, resumes, etc and also allows you to edit or modify your new 

or existing document. The file saved in Ms Word has .docx extension. It is a component of 

the Microsoft Office suite, but you can buy it separately and is available for both Windows 

and macOS. The latest version of Ms Word is 2019. 
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OpenOffice Writer is the free word processor in the OpenOffice suite, which also includes 

a spreadsheet program, presentation program, and database program. Writer holds up 

well when compared to professional and expensive word processors such as Microsoft 

Word.  

While it supports many basic functions such as spell check and custom font styles, Writer 

also includes advanced tools like macros, bookmarks, math functions, a built-in image 

gallery, and keyboard shortcuts.  

 

MS Word 

Microsoft Office Word allows you to create and edit personal and business documents, 

such as letters, reports, invoices, emails and books. By default, documents saved in 

Word are saved with the .docx extension. Microsoft Word can be used for the following 

purposes − 

● To create business documents having various graphics including pictures, charts, 

and diagrams. 

● To store and reuse readymade content and formatted elements such as cover pages 

and sidebars. 

● To create letters and letterheads for personal and business purpose. 

● To design different documents such as resumes or invitation cards etc. 

● To create a range of correspondence from a simple office memo to legal copies and 

reference documents. 

3.1.1 Working with Documents 
 

Following is the basic window, the various important parts of this window. 
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Working with Documents - Opening & Saving files 

Steps to start the Word application 

Step 1 − Click the Start button.  

Step 2 − Click the All Programs option from the menu.    

Step 3 - Search for Microsoft Office from the submenu and click it. 

Step 4 – Search for Microsoft Word 2010 from the submenu and click it. 

 

Opening New Document 

A new, blank document always opens when you start Microsoft Word. Suppose you want 

to start another new document while you are working on another document, or you 

closed an already opened document and want to start a new document.  

Here are the steps to open a new document:- 

Step 1 − Click the File tab and select the New option. 

 

Step 2 − When you select the New option from the first column, it will display a list of 

templates in the second column. Double-click on the Blank document; this is the first 

option in the template list. The blank document as shown below. The document is now 

ready  to start typing the text. 
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Shortcut to open a blank document anytime by pressing Ctrl + N keys, a new blank 

document will appear similar to the one in the above screenshot. 

 

Opening Existing Document 

To open an existing document to edit it partially or completely. Follow the steps given 

below to open an existing document − 

Step 1 − Click the File tab and select the Open option. 

 

Step 2 − This will display the following file Open dialog box, navigate through different 

folders and files, and can select a file to open. 

 



P a g e  | 95 

 

Step 3 − Finally, locate and select a file  to open and click the small triangle available on 

the Open button to open the file. 

Saving New Document 
 

To save the document the following steps to save an edited Word document: 

 

Step 1 − Click the File tab and select the Save As option. 

 

Step 2 − Select a folder where to save the document, Enter the file name of the 

document and Select the Save As option, by default it is the .docx format. 

 

Editing text documents 

Select Text 

Selecting text is a very important skill in Word. Whenever you want to edit or format text, 

you first need to select it. There are multiple ways to select text, letting you select a small 

amount to entire paragraphs at once. 

Click and drag across the text you want to select.  You can select any amount of text with 

this method, from a single character to your entire document.   

● Press and hold down the Shift key, and move the insertion point either with your 

mouse or the arrow keys to select text. 

● Double-click a single word to select it. 

● Press the Ctrl key and click in a sentence to select it. 

● Triple-click in a paragraph, or double-click in the left margin next to a paragraph, to 

select it. 
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● Click in the left margin to select an entire line, or click and drag in the left margin to 

select multiple lines. 

● Press Ctrl + A to select everything in the document. 

 

 
 

Edit Text 

Select the text you want to replace, then start typing the new text. 

 

Inserting and Deleting Text 

Insert and Add Text 

First we will see how inserted text will be added into the existing content without 

replacing any existing content. 

Step 1 − Click the location where to insert the text. 

Step 2 − Start typing the text that needs to be inserted. Word inserts the text to the left of 

the insertion point, moving the existing text to the right. 

Delete text 

 

To delete a single character: Place the insertion point next to the text that to deleted. 

Press 
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the DELETE key to delete text after, or to the right of, the insertion point. Press the 

BACKSPACE key to delete text before, or to the left of, the insertion point. 
 

Copy and Paste or Cut and Paste Operations 

Word makes use of a temporary memory which is called the clipboard. When copy or cut 

a text is selected, it stay on the clipboard temporarily and in the second step the text can 

paste the content at the desired location. 

Copy & Paste Operation 

 

The Copy operation will just copy the content from its original place and create a 

duplicate copy of the content at the desired location without deleting the text from its the 

original location. Procedure to copy the content in word – 

Step 1 − Select a portion of the text using any of the text selection methods. 

Step 2 – The various options available to copy the selected text in clipboard the different 

options are: 

● Using Right-Click −it will display the copy option, click this option to copy the 

selected content in clipboard.  

● Using Ribbon Copy Button − the copy button available at the ribbon to copy the 

selected content in clipboard. 

● Using Ctrl + c Keys − After selecting a text, just press Ctrl + c keys to copy the 

selected content in clipboard. 

Step 3 − Finally click at the place where to copy the selected text and use either of these 

two simple options − 

● Using Ribbon Paste Button − Just click the Paste button available at the ribbon to 

paste the copied content at the desired location. 

● Using Ctrl + v Keys − This is simplest way of pasting the content. Just press Ctrl + 

v keys to paste the content at the new location. 

 

Cut & Paste Operation 
 

The Cut operation will cut the content from its original place and move the content from 

its original location to a new desired location. Following is the procedure to move the 

content in word − 

Step 1 − Select a portion of the text using any of the text selection methods. 

Step 2 – The various options available to cut the selected text and put it in the clipboard.  
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● Using Right-Click −it will display cut option, just click this option to cut the 

selected content and keep it in clipboard. 

● Using Ribbon Cut Button −use cut button available at the ribbon to cut the 

selected content and keep it in clipboard. 

● Using Ctrl + x Keys − After selecting a portion of text, just press Ctrl + x keys to cut 

the selected content and keep it in clipboard. 

Step 3 − Finally, click at the place to move the selected text and use either of these two 

simple options − 

● Using Ribbon Paste Button − Just click the Paste button available at the ribbon to 

paste the content at the new location. 

● Using Ctrl + v Keys − This is simplest way of pasting the content. Just press Ctrl + 

v keys to paste the content at the new location. 

Undo and Redo operation 

Microsoft word provides two important features called the Undo and the Repeat or Redo. 

The Undo feature is used to undo the previous action and the Repeat or Redo feature is 

used to repeat the previous action. 

The Undo and Repeat buttons from the Quick Access toolbar. The Repeat button is also 

called Redo button and both the operations have the same meaning. 

Procedure to apply undo or repeat (redo) operations − 

Step 1 − click the Repeat (Redo) button, Word will repeat the same operation. 

Step 2 − Now to examine the undo operation, let us delete the last word operation 

character by character. 

Step 3 − Let us try to click the Undo button one by one.Word will recover all the deleted 

characters one by one after performing a few undo operations. 

 

Shortcut keys for undo Ctrl + Z, redo Ctrl + Y 
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Find search and replace 

Find and Replace operation in Word 2010. While working on editing a document to 

search a particular word in the document and to replace this word with another word at a 

few or all the places throughout the document. 

To replace an existing word with any other word using simple steps. 

Find Command 

The Find command enables to locate specific text in the document.  

Step 1 − Click the Find option in the Editing group on the Home tab or press Ctrl + F to 

launch the Navigation pane. 

Step 2 − Enter a word to search in the Search box, Word searches for the text entered 

and displays the results in the navigation pane and highlights the word in the document. 

Step 3 - Click the clear button (X) to clear the search and results and perform another 

search. 

 

Step 4 − finally click the close button (X) to close the Navigation Pane. 

Find & Replace Operation 
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Simple steps replace an existing word in the document. 

Step 1 − Click the Replace option in the Editing group on the Home tab or press Ctrl + H 

to launch the Find and Replace dialog box shown in Step 2 – 

Step 2 − Type a word want to search,replace the word using the Find and Replace dialog 

box as in the following screenshot – 

 

 

Step 3 − Click the Replace button available on the Find and Replace dialog box and  will 

see the first occurrence of the searched word would be replaced with the replace with 

word. Clicking again on Replace button would replace next occurrence of the searched 

word,to replace in all occurrences click Replace All button.  

Step 4 − use More >> button available on the dialog box to use more options and to 

make  search more specific like case sensitive search or searching for whole word only 

etc. 

Step 5 − Finally  click the Close (X) or Cancel button of the dialog box to close the box. 

 

Formatting page in Word 2010 

 

To change page size 
 

1. Select the Page Layout tab. 
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2. Click the Size command, and a drop-down menu will appear. The current 

page size is highlighted. 

3. Click the size option you want. The page size of the document changes. 

 

 
 

Setting Margins 

Margins are the space between the edge of the paper and the text. Adjust the right, left, 

top, and bottom margins of the document. By default, Word sets all margins left, right, 

top, and bottom to 1 inch. 

The following steps will help you understand how to set margins for an open document. 
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Converting files to different formats 

How to convert Word document to a PDF 

Converting a Word document to a PDF is the easiest task .To convert a Word document 

to a PDF because word document is not portable with all software 

Microsoft Word is a powerful word processor tool that is used for creating documents, 

memos, brochures, pamphlets, books, and more.PDF stands for Portable Document 

Format. It is one of the most commonly used file formats which allows us to 

distribute read-only documents. 

The file extension for PDF file format is .pdf. PDF file is used for documents like eBooks, 

application forms, scanned documents, etc.  There are the following methods to convert 

Word document to a PDF – 

 

Method 1: Using Word 

Microsoft Word provides the easiest way to convert Word document to a PDF. 

Step 1: Open the Word document  to convert in PDF file format. 

Step 2: Click on the File tab at the top left corner of the word document. 

 

Step 3: A list of File options appears on the screen. Click on Save As. 
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Step 3: Browse the location where to save the PDF file. Go to the Save as type. Click on 

the drop-down icon associate with Save as type. Select PDF (*.pdf) from the drop-down 

menu and click on the Save button at the bottom of the screen. 

 
 

Importing & Exporting documents 

Click the File tab in Outlook 2010,Click the Open tab at left bar; Then you will see the 

Import button in middle section. After clicking this Import button, it displays the Import 

and Export Wizard dialog box. 

The Export Wizard and Import Wizard help you transfer project data between Microsoft 

Project and other programs. The following is a list of formats you export to or import from. 

● Microsoft Excel (as a workbook or PivotTable report) 

● text-only (tab delimited) 

● comma-separated values (CSV) 

● Extensible Markup Language (XML) 
 

By defining or editing the export or import maps of these wizards helps to  transfer data 

to and from the task, resource. 

Sending files to others, 

Sending Word documents to friends, clients, teachers, co-workers or anyone else through 

email - have to print the document to share it with somebody for reading -- but 

straightforward, as well. Send your manuscript, research paper, reports, stories or 

virtually anything, as long as it is in a document format. Send a Word document via email 

as an attachment or with the Share feature in Word software. 

Using Tool bars, Ruler, Using Icons, Using Help  

Using Tool bars 

The Quick Access Toolbar displays a small selection of the more commonly used 

commands in the top left hand corner of the application window (above the Office 
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Button). By default, the Quick Access Toolbar includes the following commands: Save, 

Undo, Redo 

Customize Quick Access Toolbar button 

When you click on the Customize Quick Access Toolbar button (the down arrow to the 

right of the toolbar), a selection of popular commands is displayed for selection. 

 

Click on the command you want to add to the toolbar and the newly added command 

displays immediately. If you can‘t see the command you need to add, click on More 

Commands to display the full list.  

Another way to get to the Quick Access Toolbar tab in Word Options is to click the Office 

Button > Word > Options > Quick Access Toolbar. 

Ruler 

If you don't see the ruler at the top of your document, go to View > Ruler to display it. 

 

Set a tab stop using the ruler 

1. Select Left Tab  at the left end of the horizontal ruler to change it to the type of tab 

required. 
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2. Choose one of the following types: 

o  A Left tab stop sets the left end of the text line. The text fills toward the right. 

o  A Center tab stop sets the position at the middle of the text line.  The text centers on 

this position. 

o  A Right tab stop sets the right end of the text line. The text fills toward the left. 

o  A Decimal tab stop aligns numbers around a decimal point. Without regard to the 

number of digits, the decimal point remains in the same position. Use decimal tabs to 

line up numbers with decimal points. 

o  A Bar tab stop doesn't position text. It inserts a vertical bar at the tab position. Unlike 

other tabs, the bar tab is added to the text as soon as you click the ruler. Clear the bar 

tab stop before printing the document, else the vertical line is printed. 

3. Click or tap the bottom of the horizontal ruler where to set the tab stop. 

Using Icons 

1. Select Insert > Icons. 

 

Scroll through the icons or jump to a category by choosing a name in the navigation pane 

at the left. Also search by using the box near the top left corner. 

 

2. Choose an icon and then select Insert at the lower right. 

Insert multiple icons at the same time by choosing each of them before clicking Insert. 

https://support.microsoft.com/en-us/office/use-decimal-tabs-to-line-up-numbers-with-decimal-points-9d0fcf4d-43e8-4eb1-a1af-632b9e7cd538
https://support.microsoft.com/en-us/office/use-decimal-tabs-to-line-up-numbers-with-decimal-points-9d0fcf4d-43e8-4eb1-a1af-632b9e7cd538
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Using the Help Window 

To directly access the Help window, select Help and then the help command for the 

application such as Microsoft Word Help. Press the F1 key to make the Help window 

appear. 

The Help window provides two panes. The pane on the left provides three tabs: Contents, 

Answer Wizard, and Index. The right pane of the Help window provides either help subject 

matter or links to different Help topics. It functions a great deal like a Web browser 

window. You click a link to a particular body of information and that information appears 

in the right pane. 

Using the Contents Tab 

The Contents tab of the Help system is a series of books you can open. Each book has 

one or more Help topics in it, which appear as pages or chapters. To select a Help topic 

from the Contents tab, follow these steps: 

● In the Help window, click the Contents tab on the left side of the Help window. 

● Find the book that describes, in broad terms, the subject for which you need help. 

● Double-click the book, and a list of Help topics appears below the book, as shown in 

Figure  
 

 
● Click one of the pages (the pages contain a question mark) under a Help topic to 

display it in the right pane of the Help window. 
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● When you finish reading a topic, select another topic on the Contents tab or click the 

Help window's Close (X) button to exit Help. 
 

Using the Answer Wizard 

Another way to get help in the Help window is to use the Answer Wizard. The Answer 

Wizard works the same as the Ask a Question box or the Office Assistant; you ask the 

wizard questions and it supplies you with a list of topics that relate to your question. You 

click one of the choices provided to view help in the Help window.  To get help using the 

Answer Wizard, follow these steps: 

● Click the Answer Wizard tab in the Help window. 

● Type your question into the What Would You Like to Do? box. For example, you might 

type the question, How do I format text? 

● After typing your question, click the Search button. A list of topics appears in the 

Select Topic to Display box. Select a particular topic, and its information appears in 

the right pane of the Help window, as shown in Figure  

 

 
 

Using the Index 

The Index is an alphabetical listing of every Help topic available. It's like an index in a 

book.  Follow these steps to use the index: 

● In the Help window, click the Index tab. 
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● Type the first few letters of the topic for which you are looking. The Or Choose 

Keywords box jumps quickly to a keyword that contains the characters you have 

typed. 

● Double-click the appropriate keyword in the keywords box. Topics for that keyword 

appear in the Choose a Topic box. 

● Click a topic to view help in the right pane of the Help window. 

3.1.2 Formatting Documents 

Setting font styles, font selection-style, size, colour. 

Following is a screenshot to show a few font related buttons. 

 

Step 1 − Select the portion of text the font of which needs to be changed and click the 

Home tab. Now click the Font Type button to list down all the fonts available. 

 

Step 2 − Try to move the mouse pointer over the listed fonts.   

Step 3 − Similar way, to change the font size, click over the Font Size button which will 

display a font size list. Use the same procedure to select a desired font used while 

selecting a font type. 
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Change Font Colors 

The text that we type comes in black by default; to change the color of the font by 

following two simple steps − 

Step 1 − Select the portion of text the font color of which needs to be changed. Use any 

of the text selection method to select the portion of text. 

Step 2 − Click the Font Color button triangle to display a list of colors. Try to move the 

mouse pointer over different colors , the text color will change automatically. 

 

Apply Text Effects 

Microsoft word provides a list of text effect which add to the beauty of the document, 

especially to the cover page or the headings of the document. This is very simple to apply 

various text effects by following two simple steps − 

Step 1 − Select the portion of text to change to a bold font. 

Step 2 − Click the Text Effect button to display a list of effects including shadow, outline, 

glow, reflection etc. Try to move the mouse pointer over different effects and see the text 

effect will change automatically.  Select any of the text effect available by simply clicking 

over it. 

 



P a g e  | 110 

 

Making text bold 

It is very simple to change a selected portion of text into bold font by following two simple 

steps  

Step 1 − Select the portion of text that the font to be made bold.  

Step 2 − Click the Font Bold [ B ] button in the Home tab Font group, or simply use Ctrl + 

B keys to make the selected portion of text bold. 

Making Text Italic 

Step 1 − Select the portion of text the font of which needs to be italicized.  

Step 2 − Click the Font Italic [ I ] button in the Home tab Font group, or simply use the 

Ctrl + I keys to convert the portion of text in italic font. 

Underline the Text 

An underlined portion of text appears with an underline and we use the underlined 

portion of text to make it more distinguished from other text. It is very simple to change 

the selected text into underlined font by following two simple steps − 

Step 1 − Select the portion of text which needs to be underlined.  

Step 2 − Click Font Underline [ U ] button in the Home tab Font group, or simply use the 

Ctrl + U keys to put an underline under the text. 

 

Case settings 

Change Text to Lowercase 

Changing text to lowercase is where every word of a sentence is in lowercase. It is very 

simple to change a selected portion of text into lowercase by following two simple steps − 

Step 1 − Select the portion of text that needs to be put in lowercase.  

Step 2 − Click the Change Case button and then select Lowercase option to display all 

the selected words in lowercase. 

Change Text to Uppercase 

This is where every word of a sentence is in uppercase. It is very simple to change 

selected text into uppercase by following two simple steps − 

Step 1 − Select the portion of text that you want to change to a bold font.  

Step 2 − Click the Change Case button and then select UPPERCASE option to display all 

selected words in all caps. All characters of every selected word will be capitalized. 
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Highlight Text with Colors 

It is very simple to highlight a portion of text with a color by following two simple steps. 

Step 1 − Select the portion of text that needs to be highlighted with color.  

Step 2 − Click the Text Highlight Color button triangle to display a list of colors. Move 

mouse pointer over different colors and the text color changes automatically.  

Usually we highlight a text using yellow color. 
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Insert Special Symbols 

Here is a simple procedure to apply zoom-in or zoom-out operation using the View tab − 
 

Step 1 − To insert a special symbol, bring the cursor at the place where to insert the 

symbol. Click the Insert tab. Find two options under the symbol button (a) 

Equation and (b) Symbols.  

 

Step 2 − While clicking the Symbol button, a small list of symbols will appear as shown 

below. 

 

Step 3 − Now click on any of the available symbols in the box to insert that in the 

document at the selected location.  
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Setting Paragraph Style 

A paragraph style can contain formatting specifications, such as font, font size and color, 

indentation, alignment, and line spacing. 

Alignments 
 

The text in your paragraphs is aligned to the left margin by default, but you can easily 

align it to the right margin, center it between the margins, or justify it to spread evenly 

between the margins on a page. 

 
Left-Aligned Text 

A paragraph's text is left aligned when it is aligned evenly along the left margin. Here is a 

simple procedure to make a paragraph text left-aligned. 

Click anywhere on the paragraph you want to align and click the Align Text Left button 

available on the Home tab or simply press the Ctrl + L keys. 

 

Center Aligned Text 

Click anywhere on the paragraph you want to align and click the Center button available 

on the Home tab or simply press the Ctrl + E keys. 

 

Right-Aligned Text 

Click anywhere on the paragraph you want to align and click the Align Text Right button 

available on the Home tab or simply press the Ctrl + R keys. 

 

Justified Text 

A paragraph's text is justified when it is aligned evenly along both the left and the right 

margins. Following is a simple procedure to make a paragraph text justified. 
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Indent  

In word processing, the word indent is used to describe the distance, or number of blank 

spaces used to separate a paragraph from the left or right margins. 

 

Left Indentation 

Left indentation means to move the left edge of the paragraph inward towards the center 

of the paragraph. Click anywhere on the paragraph you want to indent left and click the 

Increase Indent button available on the Home tab or simply press the Ctrl + M keys. 

To remove left indentation by clicking the Decrease Indent button available on Home tab 

or simply press Ctrl + Shift+ M keys. 

Right Indentation 

Right indentation means to move the right edge of the paragraph inward towards the 

center of the paragraph.  

Click anywhere on the paragraph to indent and then click on the Increase Right Indent 

spinner available on the Page Layout tab. 

The Paragraph Dialog Box can also be used to set the left and the right indentations.  

First Line Indentation 

Move the left side of the first line of a paragraph inward toward the center.  

 

Hanging Indentation 

Move the left side of the first line of a paragraph leftward, away from the center which is 

called the hanging indentation.  

Line spacing 

A line spacing is the distance between two lines in a Microsoft Word document. Can 

increase or decrease this distance as per user requirement.  

Use the Line Spacing option available at the dialog box to set line spacing. 

Spacing between Lines 

Following are the simple steps to adjust spacing between two lines of the document. 

Step 1 − Select the paragraph or paragraphs to define spacing.  

Step 2 − Click the Line and Paragraph Spacing Button triangle to display a list of options 

to adjust space between the lines. Select any of the option available by simply clicking 

over it. 
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Spacing between Paragraphs 

Set distance between two paragraphs. Following are the simple steps to set this 

distance. 

Step 1 − Select the paragraph or paragraphs for which you want to define spacing and 

click the Paragraph Dialog Box launcher available on the Home tab. 

Step 2 − Click the Before spinner to increase or decrease the space before the selected 

paragraph. Similar way, click the After spinner to increase or decrease the space after 

the selected paragraph. Finally, click the OK button to apply the changes. 
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Margins 

Margins are the blank spaces that line the top, bottom, and left and right sides of a 

document. They are important because they help make a document look neat and 

professional. To change margins, click on the Margins button, found on the Page Layout 

tab. Word lists a number of pre-formatted options,by selecting ―Custom Margins,‖ found 

at the bottom of the Margins list to customize the margin as required by the user.. To 

apply the settings, click ―OK.‖ 

Bullets and Numbering 

Simple steps to create either the bulleted or the numbered lists in simple steps. 

Create a List from Existing Text 

This is very simple to convert a list of lines into a bulleted or numbered list. Following are 

the simple steps to create either bulleted list or numbered list. 

Step 1 − Select a list of text  to assign bullets or numbers.  

Step 2 − Click the Bullet Button triangle to display a list of bullets , select any of the 

bullet style available by simply clicking over it. 
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Step 3 − to create a list with numbers, then click the Numbering Button triangle instead 

of the bullet button to display a list of numbers to assign to the list, select any of the 

numbering style available by simply clicking over it. 

 

3.1.3 Setting Page Style 
 

Formatting Page 

Page Tab 
 

Using tabs gives you more control over the placement of text. By default, every time you 

press the Tab key, the insertion point will move 1/2 inch to the right. Adding tab stops to 

the Ruler allows you to change the size of the tabs, and Word even allows you to apply 

more than one tab stop to a single line. For example, on a resume you could left-align the 

beginning of a line and right-align the end of the line by adding a Right Tab, as shown in 

the image below. 

 

The tab selector 
 

The tab selector is located above the vertical ruler on the left. Move the mouse over the 

tab selector to see the name of the active tab stop. 

 

 
 

Types of tab stops: 

● Left Tab - left tab stop left-aligns the text at the tab stop 

● Center Tab - center tab stop centers the text around the tab stop 

● Right Tab - right tab stop right-aligns the text at the tab stop 

● Decimal Tab - decimal tab aligns decimal numbers using the decimal point 

● Bar Tab - bar tab draws a vertical line on the document 

● First Line Indent - first line indent inserts the indent marker on the Ruler and indents 

the first line of text in a paragraph 

● Hanging Indent - hanging indent inserts the hanging indent marker and indents all 

lines other than the first line 

 

Page margins 
 

A margin is the space between the text and the edge of your document. By default, a new 

document's margins are set to Normal, which means it has a one-inch space between 

the text and each edge. Depending on your needs, Word allows you to change your 

document's margin size. 
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To format page margins: 
 

1. Select the Page Layout tab, then click the Margins command. 

2. A drop-down menu will appear. Click the predefined margin size you want. 

3. The margins of the document will be changed. 

 
Layout Settings 

Page orientation 

Word offers two page orientation options: landscape and portrait. Landscape means the 

page is oriented horizontally, while portrait means the page is oriented vertically. 

Compare our example below to see how orientation can affect the appearance and 

spacing of text and images. 

To change page orientation 

1. Select the Page Layout tab. 

2. Click the Orientation command in the Page Setup group. 

3. A drop-down menu will appear. Click either Portrait or Landscape to change the page 

orientation. 

4. The page orientation of the document will be changed. 
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Paper Tray 

 

If you can‘t find the paper size you need on the Size menu, then you need to customize 

your paper size, which you do in the Page Setup dialog box‘s Paper tab. Here are the 

steps: 

● Choose Page Layout → Page Setup → Size. At the bottom of the Size menu, click 

More Paper Sizes. 

● In the Width and Height boxes, enter the size of your custom paper. 

● Click OK at the bottom, to close the dialog box and make the changes. 

● The Page Setup box closes, and your custom-sized document shows in Word. 

 

Border & Shading 

In MS Word we can apply the Borders and Shading to the written text, paragraph, etc. to 

make them look good and appealing like they pop out of the page. 

Applying Borders 

The border as the name suggests provides an outer/inner lining on the selected 

text/paragraph. In MS Word there are multiple types of borders which are as follows: 

● Bottom Border– Border at the bottom of the Paragraph. 

● Top Border– Border at the top of the Paragraph. 

● Left Border– Border on the left side of the Paragraph. 

● Right Border– Border on the right side of the Paragraph. 

● No Border– Removes all the borders. 
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● All Borders– Border on all sides of the Paragraph. 

● Outside Borders– Border outside the Paragraph. 

● Inside Borders– Border inside the Paragraph. 

● Inside Horizontal Border– Horizontal borders on both sides inside the Paragraph. 

● Inside Vertical Border– Vertical borders on both sides inside the Paragraph. 

 

Steps to Apply: 

Step 1: Select the text/Paragraph to apply Border. 

Step 2: Now, go to the Borders tab in the Paragraph menu under the Home bar. 

Step 3: Select the border of your choice. 
 

Applying Shades 

Shading feature in the Word Document is similar to highlighting the text/Paragraph.   

 

Steps to Apply: 

Step 1: Select the text to apply the Shading. 

Step 2: Now, go to the Shading tab in the Paragraph menu under the Home bar. 
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Step 3: Select the Shading Color of your choice. 

 

Columns 

Columns are used in many types of documents, but they are most commonly used in 

newspapers, magazines, academic journals, and newsletters. In this lesson, you will 

learn how to insert columns into a document and create column breaks. 

 

To add columns to a document: 

● Select the text you want to format. 

● Click the Page Layout tab. 

● Click the Columns command. A drop-down menu will appear.  

● Select the number of columns you want to insert. The text will then format into 

columns. 

● If you want to remove the columns, click the Columns command and select One for 

the number of columns. 

 

Header and Footer 

Headers and footers are parts of a document that contain special information such as 

page numbers and the total number of pages, the document title, company logo, any 

photo, etc. The header appears at the top of every page, and the footer appears at the 

bottom of every page. 

The following steps to add header and footer in a Word document. 

Step 1 − Click the Insert tab, and click either the Header button or the Footer button that 

which needs to be added first. 
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Step 2 − Once you select any of the headers, it will be applied to the document in 

editable mode and the text in the document will appear dimmed, Header and Footer 

buttons appear on the Ribbon and a Close Header and Footer button will also appear at 

the top-right corner. 

 

Step 3 − Type the information for document header and click Close Header and Footer to 

come out of the header insertion mode. 
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Setting Foot notes and End notes 

Footnotes and Endnotes are used to explain, comment on, or provide references to 

something in a document. Usually, footnotes appear at the bottom of the page, while 

endnotes come at the end of the document or section. 

Add a footnote 

● Click where you want to add the footnote.  Click Insert > Insert Footnote.   

● Word inserts a reference mark in the text and adds the footnote mark at the bottom 

of the page. 

● Type the footnote text. 

 

 

 

 
 

Add an endnote 

● Click where you want to add the endnote.  Click Insert > Insert Endnote. 

● Word inserts a reference mark in the text and adds the endnote mark at the end of 

the document. 

● Type the endnote text. 
 

Shortcut Keys for Footnotes and Endnotes 

● Alt+Ctrl+F to insert a footnote 

● Alt+Ctrl+D to insert an endnote 

 

Insert Page Breaks 
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The following steps is to insert page breaks in a Word document. 

Step 1 − Bring the insertion point immediately before the text that has to appear on a 

new page. 

Step 2 − Click the Insert tab, and click the Page Break button available in the Pages 

group. 

 

Word inserts a page break and moves all text after the page break onto a new page, use 

the Ctrl + Enter keys to create a page break at the pointed location. 

Column Break and Line Break 
 

 

 
 

● Place the insertion point where you want to add the break. 

● Click the Page Layout tab. 

● Click the Breaks command in the Page Setup group. A drop-down menu will appear. 

● Select Column / Section Breaks from the list of break types. 

● The text will shift to reflect the break. 
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Insert Frames into Document in Word 

1. In Word 2010 click File>Options>Customize Ribbon.  

2. In Word Options dialog of 2010 click Customize Ribbon from the left pane, and then 

check the Developer box in the right pane. See screenshot: 

 

  3. Then click Developer>Legacy Forms>Insert Frame button, and then drag the mouse     

to draw a frame as required. See screenshot: 

 

Creating Sections 

To create sections to divide the document into sections and each section can have a 

specific set of formatting that will only apply to the chosen section. Steps to create 

sections in Word: 

1. Place the cursor in the location where to split the document (the new section to begin). 

2. Click on the Page Layout tab in the Office Ribbon. 

https://gilsmethod.com/tag/office
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3. Click on the Breaks button in the Page Setup section. 

4. Click on one of the Section Breaks listed. 

● Next Page― Inserts a section break to start a new section on the next page. 

● Continuous― Inserts a section break and starts the new section on the same 

page. 

● Even Page ― Inserts a section break and starts a new section on the next even-

numbered page. 

● Odd Page – Inserts a section break and starts a new section on the next even-

numbered page. 

Anchoring and wrapping 

 

In Word, an anchor symbol in the left margin shows where a floating object (picture, text 

box, table) is attached to the text.  To remove the anchor, select  the object and delete it 

from the document. 

Anchoring Charts, Graphics and Other Objects 

Word contains features which facilitate insertion of graphics, charts, tables, 

photographs and other types of objects within a document.  

 

Instructions to anchor objects to the text to appear near. 

 

Anchoring objects in a word document 

To anchor graphics, tables & charts in your document: 

1. Select the item to be anchored 
 

2. Click the Format Tab in the Drawing Tools.   

Note: The Drawing Tools option will only be visible if an image is selected 
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3. Click on the Wrap Text button in the Arrange group and select More Layout Options 
 

4. In the Text Wrapping tab, choose any layout other than In Line with Text 
 

5. Click the Position tab 
 

6. In the Options section at the bottom of the dialogue box, tick both the Move object 

with text and Lock anchor boxes. 
 

7. Use the options in the Horizontal and Vertical sections of the same dialogue box to fix 

the position of the object as required 
 

8. To make text to flow around the object, move to the Text Wrapping tab and select the 

option. 
 

9. Click OK to close the Advanced Layout dialog box 
 

10. Click OK to activate the settings you've chosen 

3.1.4 Setting Document Style 
 

A style is a predefined combination of font style, color, and size of text that can be 

applied to selected text.  

 

 To select a style: 

1. Select the text you want to format. 

 
2. In the Style group on the Home tab, hover over each style to see a live preview 

in the document. Click the More drop-down arrow to see additional styles. 

 

 
 

3. Select the style you want. The selected text appears formatted in the style. 
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To apply a style set 
 

Style sets include a combination of title, heading, and paragraph styles. Style sets allows 

to format all of the elements of the document at once. 

 

Table of Contents 

A table of contents (or TOC) is a list of headings in the order in which they appear in the 

document.  List of headings can be set, which should be a part of the table of contents. A 

table of content helps in navigating through a Word document by providing associated 

page numbers and direct links to various headings available on those pages. 

 

Create Table of Contents 
 

The following will help you to create Table of Contents in your Microsoft Word using 

various levels of headings. 

Step 1 − Consider a document having different levels of headings. 
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Step 2 − insert a table of content anywhere in the document, but the best place is always 

at the beginning of the document and then click the References tab followed by the Table 

of Content button; this will display a list of Table of Contents options. 

 

Step 3 − Select any of the displayed options by simply clicking on it. A table of content 

will be inserted at the selected location. 
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Step 4 − Select number of levels of headings in the table of content. Click on the Insert 

Table of Content option available in the option menu, dialog box appears, select the 

number of levels needed in table of content. Turn ON or turn OFF the Show Page 

Numbers option. Once done, click the OK button to apply the options. 

 

 

 

Press the Ctrl key and then click over the any link available in the table of content, it will 

take you directly to the associated page. 

 

Index 

An index lists the terms and topics that are discussed in a document, along with the 

pages that they appear on. To create an index, mark the index entries by providing the 

name of the main entry and the cross-reference in document, and then build the index. 

 

Mark the entries 
 

1. Select the text you‘d like to use as an index entry, or just click where you want to 

insert the entry. 

2. On the References tab, in the Index group, click Mark Entry. 

 
 

3. You can edit the text in the Mark Index Entry dialog box. 
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● You can add a second-level in the Subentry box. If you need a third level, follow 

the subentry text with a colon. 

● To create a cross-reference to another entry, click Cross-reference under 

Options, and then type the text for the other entry in the box. 

● To format the page numbers that will appear in the index, select the Bold check 

box or Italic check box below Page number format. 

4. Click Mark to mark the index entry. To mark this text everywhere it shows up in the 

document, click Mark All. 

5. To mark additional index entries, select the text, click in the Mark Index Entry dialog 

box, and then repeat steps 3 and 4. 

 

Create the index 
 

After you mark the entries, you‘re ready to insert the index into your document. 

1. Click where you want to add the index. 

2. On the References tab, in the Index group, click Insert Index. 

 

 
 

3. In the Index dialog box, you can choose the format for text entries, page numbers, 

tabs, and leader characters. 
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4. You can change the overall look of the index by choosing from the Formats dropdown 

menu. A preview is displayed in the window to the top left. 

5. Click OK. 

 

Page Numbering 
 

Add Page Numbers 
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1. Click the Insert tab. 

2. Click the Page Number button. 

Next, choose where you want the page number to appear. You can choose either the 

header or footer, in the side margins, or where the text cursor is currently placed. 

3. Select a part of the page. 

There are plenty of built-in designs available, from plain numbers to more stylized 

numbers and shapes. 

4. Select a page number style. 

The page number is added as a new page header or footer. The page number will 

increment automatically for each page, while the other text and decoration will stay 

the same. 

5. Click the Close Header and Footer button. The page number is added. 

 

Date & Time 
 

1. Click the Insert tab. 

2. Click the Date and Time button. 

3. Select a date format. 

4. Check the Update automatically check box. 

If the Update automatically check box isn't checked, the date will be inserted as static 

text. 
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If it is checked, the date will be inserted as a field that can be updated automatically 

to reflect the current date. 

5. Click OK. 

The date and time field is inserted. By default, the field displays the current date 

and/or time in the selected format. 

 

Author 
 

By default, the author of a document is set to the user name which entered during 

installation of Word. However, you can change the user name, thus changing the main 

author, as well as add authors to or remove authors from a document. 

 

1. Click File, and then look for Author under Related People on the right. 

2. Right-click the author name, and then click Edit Property. 

3. Type a new name in the Edit person dialog box. 

 

Creating Master Document 

A master document is a Word file that contains links to a set of other, separate Word 

files, called subdocuments. The content of the subdocuments is not inserted into the 

master document. The master document only contains links to the subdocuments. This 

allows to edit the subdocuments separately. Any changes made to subdocuments are 

incorporated into the master document automatically. If there are multiple people 

working on a single document, a master document allows to send different parts of the 

document to different people to work on. 
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Creating Web pages 

1. Open Word.  

2. When the application opens, from the ―File‖ menu, choose ―Open.‖ Then, from the 

list of available documents, double click the document you wish to convert.  

Note: When the document opens, familiarize yourself with the layout. The converted 

document will not look exactly like the original.  
 

3. From the ―File‖ menu, choose ―Save as Web Page.‖ Click ―Save.‖  

Note: When you convert a document to HTML format, you retain the original 

document as a separate file. The new HTML file has the same file name but a 

different file extension (.htm).  
 

4. When the conversion is complete, the converted file appears in the window 

(filename.htm). View the HTML source code file by selecting the ―View‖ menu, then 

―HTML Source.‖  
 

5. Close your document by selecting the ―File‖ menu, then choosing ―Close.‖ Click the 

Close button (the ―X‖ in the upper-right corner) to close Word.  
 

6. Open your HTML file in a WWW browser to see how it will appear. You can adjust the 

layout of the page if necessary using Mozilla‘s editing options.  
 

7. Next, you must move your files to your Web directory using SSH Secure Shell file 

transfer software. 
 

8. Once you have published your page, view it in Mozilla to see how it will appear to the 

world. 

 

3.1.5 Creating Tables 

A table is a structure of vertical columns and horizontal rows with a cell at every 

intersection. Each cell can contain text or graphics, and can format the table in any way. 

Usually the top row in the table is kept as a table header and can be used to put some 

informative instruction. 

 

Create a Table 
 

The following steps to understand how to create a table in a Word document. 

Step 1 − Click the Insert tab followed by the Table button. This will display a simple grid 

as shown below. When the mouse is moved over the grid cells, it makes a table in the 

table that appears in the document. Pick the desired number of rows and columns. 

 

http://www.udel.edu/topics/connect/sw/ssh/sshwin/sshftp.html
http://www.udel.edu/topics/connect/sw/ssh/sshwin/sshftp.html
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Step 2 − Click the square representing the lower-right corner of the table, which will 

create an actual table in the document and Word goes in the table design mode.  

 

Delete a Table 
 

Following are the simple steps to delete an existing table from a word document. 

Step 1 − Click anywhere in the table to delete. 

Step 2 − Click the Layout tab, and click the Delete Table option under the Delete Table 

Button to delete the complete table from the document along with its content. 
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Rows and Columns  

A table is a structure of vertical columns and horizontal rows with a cell at every 

intersection. A Word table can contain as many as 63 columns but the number of rows is 

unlimited.  

 

Add a Row 

Following are the simple steps to add rows in a table of a word document. 

Step 1 − Click a row where to add an additional row and then click the Layout tab.  

Step 2 − Now use the Row & Column group of buttons to add any row below or above to 

the selected row,click the Insert Below button- it will add a row just below the selected 

row. 

Click the Insert Above button-it will add a row just above the selected row. 

 

Delete a Row 

The following steps will help you delete rows from a table of a Word document. 

Step 1 − Click a row which to delete from the table and then click the Layout tab. 

Step 2 − Click the Layout tab, and then click the Delete Rows option under the Delete 

Table Button to delete the selected row. 

 

Add a Column 

The following steps will help you add columns in a table of a Word document. 

Step 1 − Click a column where to add an additional column and then click the Layout tab. 

Step 2 − Now use the Row & Column group of buttons to add any column to the left or 

right of the selected column.  Click the Insert Left button- it will add a column just left to 

the selected column.. 

Click the Insert Right button, it will add a column just next to the selected column. 

 

Delete a Column 

Following are the simple steps to delete columns from a table of a word document. 

Step 1 − Click a column to delete from the table and then click the Layout tab. 

Step 2 − Click the Layout tab, and click the Delete Column option under the Delete Table 

Button to delete the selected column. 

 

Splitting Table 

Microsoft Word allows splitting a table into multiple tables but a single operation will 

always divide a table into two tables. Following are the simple steps to split a table into 

two tables in a Word document. 
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Step 1 − Bring the mouse pointer position anywhere in the row that should appear as the 

first row of the new table. 

Step 2 − Now click the Layout tab and then click the Split Table button which will split the 

table into two tables and the selected row will become the first row of the lower table. 

After splitting the table into two tables, it can be further divide it into two parts and can 

continue dividing the Word tables as long as a table has more than one row. 

 

Merging Cells 

The following steps will help to merge table cells in a Word document. 

Step 1 − Bring the mouse pointer position inside the first cell that to be merged. Now 

press the Shift key and click the cells around the cell which should be merged into the 

first cell. This will highlight the cells which you click and they will be ready to be merged. 

Step 2 − Now click the Layout tab and then click the Merge Cells button which will merge 

all the selected cells. 

 

Split a Cell 

The following steps to split a cell into two sub-cells of a table available in word document. 

Step 1 − Bring your mouse pointer position inside the cell that has to be divided into 

multiple cells. 

Step 2 − Now click the Layout tab and then click the Split Cells button; this will display a 

dialog box asking for the number of rows and columns to be created from the selected 

cell. 

Step 3 − Select the desired number of rows and columns that have to go into the 

resultant cell and finally click the OK button to apply the result. 

 

Add Borders to Table 

The following steps will help you add borders in a table cell available in Word document. 

Step 1 − Select the table to add border. To select a table, click over the table anywhere 

which will make the Cross icon visible at the top-left corner of the table. Click this cross 

icon to select the table. 

Step 2 − Click the Border button to display a list of options to put a border around the 

selected table. Select any of the option available by simply clicking over it. 

Step 3 − Try to add and remove different borders like left, right, top or bottom by 

selecting different options from the border options. 

Step 4 − Apply border to any of the selected row or column.  
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Step 5 − To delete the existing border, simply select the No Border option from the 

border options. 

 

Sorting in Table  

Sort the data in a Word 2010 table as well, which can make it a simpler process to get 

the data into a format that is suitable for the information that are presented with the 

document. 
 

Step 1: Open the Word document that contains that table that is to be sorted. 

Step 2: Select the table data that to be sorted by. 

Step 3: Click the Layout tab under Table Tools at the top of the window. 

 
Step 4: Click the Sort button in the Data section of the ribbon at the top of the window. 

 

 

Step 5: Set the parameters for the sort criteria, then click the OK button at the bottom of 

the window. 
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Add a Formula 

Following are the simple steps to add formula in a table cell available in Word document. 

Step 1 − Consider the following table with the total number of rows. Click in a cell that 

should contain the sum of the rows. 

Step 2 − Now click the Layout tab and then click the Formula button; this will display a 

Formula Dialog Box which will suggest a default formula, which is =SUM(LEFT). 

Select a number format using Number Format List Box to display the result or change the 

formula using the Formula List Box. 

 
 

 

Step 3 − Now click OK to apply the formula and see that the left cells have been added 

and the sum has been put in the total cell.  
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Cell Formulae 

The Formula dialog box provides the following important functions to be used as formula 

in a cell. 

Word formulae uses a reference system to refer to an individual table cells. Each column 

is identified by a letter, starting with A for the first column, B for the second column, and 

so on. After the letter comes the row number. Thus, the first cell in the first row is A1, the 

third cell in the fourth row is C4, and so on. 

 

3.1.6 Drawing 
 

Inserting Clip Arts 

Adding clip art in document can be a great way to illustrate important information or add 

decorative accents to existing text.  

● Select the Insert tab. 

● Click the Clip Art command in the Illustrations group. 
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● The clip art options appear in the task pane to the right of the document. 

● Enter keywords in the Search for: field that are related to the image you want to 

insert. 

● Place your insertion point in the document where you want to insert the clip art. 

● Click an image in the Clip Art pane. It will appear in the document. 

 

Adding Picture in Document 

The following steps will help you add an existing picture in your word document. It is 

assumed that you already have a picture available on your machine before you add this 

picture in your Word document. 

Step 1 − Click on the document where to add a picture. 

Step 2 − Click the Insert tab and then click the Picture option available in illustrations 

group, which will display the Insert Picture dialog box. 

Step 3 − Select a required picture using the Insert Picture dialog box. Click the Insert 

button, selected picture will be inserted into the document.  

Adding Shapes 

● Select the Insert tab, then click the Shapes command. A drop-down menu of shapes 

will appear. 

● Select the desired shape. 

● Click, hold, and drag in the desired location to add the shape to your document. 
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3.1.7 Tools 
 

Word Completion 

Autocomplete, or word completion, is a feature in which an application predicts the rest 

of a word a user is typing. In Android and iOS smartphones, this is called predictive text. 

In graphical user interfaces, users can typically press the tab key to accept a suggestion 

or the down arrow key to accept one of several. 

Autocomplete speeds up human-computer interactions when it correctly predicts the 

word a user intends to enter after only a few characters have been typed into a text input 

field. It works best in domains with a limited number of possible words (such as 

in command line interpreters), when some words are much more common (such as when 

addressing an e-mail), or writing structured and predictable text. 

 

Check Spelling and Grammar using Review tab 

Here is the simple procedure to find out the spelling mistakes and fix them − 

Step 1 − Click the Review tab and then click the Spelling & Grammar button. 

Step 2 − A Spelling and Grammar dialog box will appear and will display the wrong 

spellings or errors in grammar.  

Ignore, ignore all, add to dictionary,change, change all, autocorrect. 

Following are the different options in case you have grammatical mistake − 

https://en.wikipedia.org/wiki/Application_software
https://en.wikipedia.org/wiki/Android_(operating_system)
https://en.wikipedia.org/wiki/IOS
https://en.wikipedia.org/wiki/Smartphone
https://en.wikipedia.org/wiki/Graphical_user_interface
https://en.wikipedia.org/wiki/Tab_key
https://en.wikipedia.org/wiki/Arrow_key
https://en.wikipedia.org/wiki/Human-computer_interaction
https://en.wikipedia.org/wiki/Command_line_interpreter
https://en.wikipedia.org/wiki/E-mail
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Next Sentence,explain,options,undo 

Step 3 − Select one of the given suggestions you want to use and click the Change option 

to fix the spelling or grammar mistake and repeat the step to fix all the spelling or 

grammar mistake. 

Step 4 − Word displays a dialog box when it finishes checking for spelling and grammar 

mistakes, finally Click OK. 

 

Mail Merge 

Mail Merge is a useful tool that will allow to produce multiple letters, labels, envelopes, 

nametags, and more using information stored in a list, database, or spreadsheet. While 

performing a Mail Merge two documents are required (i) Word document (also can start 

with an existing one or create a new one) and (2) a recipient list, which is typically an 

Excel workbook. 

To use Mail Merge 

1. Open an existing Word document, or create a new one. 

2. Click the Mailings tab. 

3. Click the Start Mail Merge command. 

4. Select Step by Step Mail Merge Wizard. 
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The Mail Merge task pane appears follow the ough the six main steps to complete a 

merge. The following is an example of how to create a form letter and merge the letter 

with a recipient list. 
 

Step 1: 

1. Choose the type of document you want to create. In this example, select Letters. 
 

 
 

2. Click Next: Starting document to move to Step 2. 

Step 2: 

1. Select Use the current document. 

 

 
 

2. Click Next: Select recipients to move to Step 3. 

 

Step 3: 
 

From the address list so Word can automatically place each address into the document. 

The list can be in an existing file, such as an Excel workbook, or type a new address list 

from within the Mail Merge Wizard. 
 

1. From the Mail Merge task pane, select Use an existing list, then click Browse. 
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2. Locate your file in the dialog box, then click Open. 

 

 
 

3. If the address list is in an Excel workbook, select the worksheet that contains the list, 

then click OK. 
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4. In the Mail Merge Recipients dialog box,can check or uncheck each recipient to 

control which ones are used in the merge. Click OK to close the dialog box. 

 

 
 

5. From the Mail Merge task pane, click Next: Write your letter to move to Step 4. 

 

Step 4: 

 

When it's printed, each copy of the letter will basically be the same, except the recipient 

data—like the name and address—will be different on each one. Add placeholders for the 

recipient data so Mail Merge knows exactly where to add the data. In this step if the Mail 

Merge is with an existing letter, make sure the file is open. 

 

To insert recipient data 

 

1. Place the insertion point in the document where to add the information to appear. 

2. Select Address block, Greeting line, Electronic postage, or More items from the task 

pane. 

 
 



P a g e  | 148 

 

3. Depending on the selection, a dialog box may appear with various options. Select the 

desired options, then click OK. 

 

 
 

4. A placeholder appears in the document (for example: «AddressBlock»). 

5. Repeat these steps each time to enter information from the data record. 

6. From the Mail Merge task pane, click Next: Preview the letters to move to Step 5.  

 

Step 5: 

 

1. Preview the letters to make sure information from the recipient list  

2. Click Next: Complete the merge, followed by printing  
 

Template 

Microsoft Word template is a collection of styles which defines paragraph styles for 

regular text paragraphs, a title, and different levels of headings. Can also use any of the 

already existing templates for the Word document or can design a template which can be 

used for all the company documents. 

Using Existing Template 

A template is selected at the time when to create a new blank document. 

Step 1 − To start a new document, click the File tab and then click the New option; this 

will display the Available Templates. 
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Step 2 − Microsoft Word provides a list of templates arranged under Sample Templates 

Step 3 − Browse a list of available templates and finally select one by double-clicking 

over the template. While selecting a template select the Document Option available in 

the third column. This opens the document with predefined setting with which can modify 

document title, author name, heading, etc. based on the document requirement.  The file 

type is .dotx. 

 

Creating contents for books 

Whether you are working on a school project or creating advertising materials, a decent 

booklet can come in handy and inspire the wow factor. Using Microsoft Word 2010, you 

can create professional-looking booklets and print them out. 

Few simple steps 
 

How-To Create Booklets Using Microsoft Word 2010 

1. Click File, then Print, and at the bottom of the list, click Page Setup. 
 

2. In the Page Setup window, click the Margins tab. Then under Multiple pages, select 

Book fold from the drop menu. Under Sheets, either selectAll or the exact amount of 

pages.  
 

3. Create the booklet content, but keep in mind that content will print differently than a 

regular document. Page 1 and 4 will be printed on the same side, as Page 2 and 3 

will be on the opposite side. Each page size shrinks to the scale of half a regular 

page in landscape mode. The image below should help illustrate. 
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4. Click File then Print, and change the printing preference to the correct setting for the 

printer. For example, if the printer can automatically re-feed printed documents, use 

one of the Print on Both Sides settings.  

 

Creating Letter/Faxes 

Fax cover letters not only inform the fax recipient of the nature of the attached document 

but also provide the recipient with your business contact information. The cover letter 

doesn‘t have to contain a great deal of detail, but  add the fax recipient‘s name and 

number, sender contact information, a date, the number of pages within the fax and a 

short description of the document that are faxing.  

 

Creating Web pages, Using Wizards, 

Creating a web page using Microsoft Word might not be the first option one considers. 

But Word XP has a web page wizard that allows you to create a web page. Here is how to 

use it. 

1. From the File menu, click New. 

2. In the New Document task pane, click General Templates under New from template. 

3. Select the Web Pages tab, and then double-click on Web Page Wizard. Click 

the Next button. 

4. Type the title for the website and the location where it should be saved, and then 

click the Next button. 

5. Choose Vertical frame, Horizontal frame or Separate page as the navigation type for 

the website, and then click the Next button. 

6. Choose whether to add new pages to the website from blank new pages, template 

pages or existing word documents, and then click the Next button. 
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7. Modify the order of the pages as desired, and then click Next. 

8. Choose whether to add a visual theme to the website or not, and then click Next. 

9. Click Finish. 

 

After saving your file, you can open the HTML files in IE to check how things will look. 

Once satisfied, upload the web pages to a hosting provider to bring it online. For this you 

can use the hosting file manager, or a FTP client. 

 

Tracking Changes 

Track Changes is a feature built into Microsoft Word that keeps track of all the edits 

made to your document and lets you make comments. When Track Changes is turned 

on, the edit you make are highlighted, appearing in different colors or styles to separate 

them from the original text. 

 

Security 

A security word is a word chosen by you to help us verify your identity when you phone us 

or at any other time when we need to validate that it is you asking us for information or to 

do something on your account(s) . The security word is a memorable word chosen by you 

and can be anything you want. You will have provided this either as part of an online or 

paper application, on a form you‘ve sent us by post or you may have set or changed it 

when you were logged into your internet banking. For example it could be a memorable 

name or place or something that means something to you. For additional security we do 

not provide any guidance on what this word should be.   

 

 

https://www.businessinsider.com/category/microsoft-word
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Digital Signature 

A digital signature is an electronic, encrypted, stamp of authentication on digital 

information such as e-mail messages, macros, or electronic documents. A signature 

confirms that the information originated from the signer and has not been altered. 

 

3.1.8 Printing Documents 
 

To print a document, computer needs to be connected to a printer. 

1. A computer with Microsoft Word installed 

2. A printer set up and connected to your computer (wireless or connected by cable) 

Follow these step-by-step instructions to print a document from Microsoft Word 

Step 1: Open an existing Microsoft Word document or start a new document, if you have 

Windows 10 you can use Cortana to search for it. Before you print, type your text in the 

blank document or insert an image.  
 

Step 2: When you are ready, click on File in the top left-hand corner of your document. 

Then, click on Print.  

 

  

Step 3: Click on File then Print in the menu, this will bring up the ‗Print‘ dialogue box.  

Choose number of copies to be printed. 
 

Step 4: Printing features like  to print all pages or only certain pages.,can also change the 

orientation of the print from portrait to landscape and also printing on a certain size of 

paper and the quality of print.  
 

Step 5: To see each page, click the arrow at the bottom of the preview, and if the text is 

too small, use the zoom slider to adjust it. 
 

Step 6: After finishing the settings, click Print.  
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Shortcut keys 

 

Shortcuts for MS Word Functions Windows 10 

Open New Word Doc CTRL + N 

Open Existing Word Doc CTRL + O 

Save a Word Doc CTRL + S 

Save As a Word Doc F12 

Print a File CTRL + P 

Open Print Preview CTRL + F12 

Close a Word Doc CTRL + W 

Close MS Word ALT + F4 

Close Specific Word file CTRL + F4 

Undo CRLT + Z 

Re-do CRLT + Y 

Move cursor to the bottom of screen Ctrl + End 

Move cursor to the top of screen Ctrl + Home 

Scroll Up document by one screen Page Up 

Scroll down document by one screen Page Dn 

Move cursor to previous insertion point SHFT + F5 

Cut select content to Clipboard CTL + X 

Copy select content to Clipboard CTRL + C 

Paste select content to Clipboard CTRL + V 

Paste Clipboard content with matching format Ctrl + Shift + V 

Display the Paste Special dialog CTRL + Shift + V 

Cut selected content to Spike CTRL + F3 

Paste select content of Spike CTRL + Shift + F3 

Insert graphics ALT + N,M 

Find CTRL + F 

Bold CTRL + B 

Italic CTRL + I 

Underscore CTRL + U 

Underline for words CTRL + Shift + W 

Strikethrough CTRL + 5 

Change letter case Shift + F3 

Center Align Text CTRL + E 

Left Align Text CTRL + L 

Right Align Text CTRL + R 

Justify Text CTRL + J 

Apply subscript format CTRL + = 
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3.2 Open Office – Writer 

3.2.1 Introduction to Open Office Suite 

 

OpenOffice is the leading open-source office software suite for word processing, 

spreadsheets, presentations, graphics, databases and more. It is available in many 

languages and works on all common computers. It stores all your data in an International 

open standard format and can also read and write files from other common office 

software packages. OpenOffice is easy to learn. 

3.2.2 Selecting the Application Package 
 

OpenOffice is a productive office suite with a collection of different software packages 

such as 

● OpenOffice Writer - Word Processor to create text documents 

● OpenOfficeCalc - Spreadsheet to create worksheets 

● OpenOffice Base - Database 

● OpenOffice Impress - Presentation software 

● OpenOffice Draw - Drawing Software 

● OpenOffice Formula - Create formula and equations 

 

OpenOffice Writer is the word processor component of OpenOffice. In addition to the 

usual features of a word processor (spelling check, thesaurus, hyphenation, autocorrect, 

find and replace, automatic generation of tables of contents and indexes, mail merge 

and others), Writer provides these important features: 

● Templates and styles. 

● Page layout methods, including frames, columns, and tables. 

● Embedding or linking of graphics, spreadsheets, and other objects. 

● Built-in drawing tools. 

● Master documents-to group a collection of documents into a single document. 

● Change tracking during revisions. 

● Database integration, including a bibliography database. 

● Export to PDF. 

 

3.2.3 Working with Documents 

 

Creating a new document 

 

Creating a blank document 

You can create a new, blank document in Writer in a number of ways: 
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● Press the Control+N keys. 

● Use File > New > Text Document. 

● Click the New button on the main toolbar.  

Each method opens a new, empty document. If you already have a document open, the 

new document appears in a new window. 

 

Creating a document from a template 

You can use templates to create new documents in Writer. Templates serve as the 

foundation of a set of documents, to make sure they all have a similar layout. For 

example, all the documents of the Writer Guide are based on the same template. As a 

result, all the documents look alike—they have the same headers and footers, use the 

same fonts, and so on. 

Once you do have templates on your system, you can create new documents based on 

them by using File > New > Templates and Documents. This opens a window where you 

can choose the template you want to use for your document. 

The example shown below uses a template called "book" in the My Templates folder. 

Select it, then click the Open button. A new document is created based on the formats 

defined in the template. 

 

 
Creating a document from a template 
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Opening an existing document 

Here is one way to open an existing document in Writer: 

1. Click File > Open (or press Control+O). 

2. In the file chooser, you can reduce the list of files by selecting the type of file you are 

looking for. If you choose Text documents as the file type, you will only see 

documents Writer understands. 

3. Select the file you want, and then click Open. 

 

This method opens Word (*.doc) files, as well as OOo files and other formats. 

You can also open an existing OOo Writer document using the same methods you would 

use to open any document in your operating system. 

 

Saving a document 

There are three ways to save a document in Writer: 

● Press Control+S. 

● Select File > Save. 

● Click the Save button on the main toolbar. 

 

You also can tell Writer to save your document automatically at regular intervals. To 

enable this, you must configure OpenOffice.org to save all documents automatically. 

1. Select Tools > Options. The Options window appears. 

2. Select Load/Save > General. 

3. Click on Save AutoRecovery information every. This enables the box to set the 

interval. The default value is 30 minutes. Enter the value you want by typing it or by 

pressing the up or down arrow keys. 

 

 

Saving as a Microsoft Word document 

You may need to share your documents with other people who do not use 

OpenOffice.org, but use Microsoft Word instead. Fortunately, OpenOffice.org can read 

and write Word files. To save a document as a Microsoft Word file: 

1. First save your document in OpenOffice.org's format (*.odt). If you do not, any 

changes you made since the last time you saved will only appear in the Microsoft 

Word version of the document. 

2. Then click File > Save As. The Save As dialog box (shown below) appears. 

3. In the Save as type drop-down menu, select the type of Word format you need. 

4. Click Save. 

 



P a g e  | 157 

 

From this point on, all changes you make to the document will occur only in the Microsoft 

Word document. You have actually changed the name of your document. If you want to 

go back to working with the OpenOffice.org version of your document, you must open it 

again. 

To have OOo save documents in a default Microsoft Word file format, go to Tools > 

Options > Load/Save > General. There is a section named Default file format. 

Under Document type, select Text document, under Always save as, select your preferred 

file format. 

 

 
Save As dialog box. 

 

3.2.4 Formatting Documents 

 

In Apache OpenOffice, you can apply formatting to documents in two different ways. You 

can do so directly using menus and toolbars, or you can use styles and templates. 

 

To a new user, it may seem easier to format a document directly, applying formatting only 

as needed. However, this can be repetitive, and problematic when working with longer 

documents. You can save yourself a lot of time and trouble by using styles and 

templates, which cause your document to follow predefined formatting rules. While this 

may seem complex at first glance, it is actually an easy-to-learn tool that affords a great 

deal of flexibility and consistency when authoring documents. 

 

Styles can be used in all Apache OpenOffice programs with the exception of Apache 

Math. 
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Benefits of Styles Over Direct Formatting 

 

Suppose we've written a long report that is divided into chapters, each marked by a 

heading. We need these headings to be displayed in a particular sans serif font. We also 

need these headings to be displayed in large, bold text, and centered on the page. To 

apply this formatting manually, we would need to set up the following formatting for each 

heading individually: 
 

"Liberation Sans, 16 point, bold, centered..." 
 

At the same time, we want the rest of our text to be displayed in a smaller, serif font, as 

follows: 

"Liberation Serif, 11 points, justified..." 

 

While it is possible to accomplish this with direct formatting, two problems arise: 

consistency (remembering to use the exact same font size, font face, and alignment each 

time) and maintenance. What happens if you decide you need the body of your report to 

be displayed in a different font, or that you need your chapter headings to be slightly 

smaller? If you've applied the formatting directly, you'll need to do a lot of work to fix this. 

 

This is where styles come in. Suppose that instead of setting each chapter heading's 

formatting individually, as shown above, we predefine all these rules in a style named 

"Heading 1". This way, each time we come across text we want to make into a chapter 

heading, we can simply select "Heading 1" as its formatting. 

 

Likewise, we can predefine the body formatting in a style named "Body Text" and apply 

this style to the body text of the document as necessary. In this way, the administration 

of document becomes much simpler. For example, to change the font used for all 

chapter headings, we only need to modify the definition of "Heading 1". The change will 

then be reflected throughout our document. 

 

Beyond this, styles can provide a lot more than just consistency and ease of 

administration. They permit the creation of an automatic table of contents, numbered 

chapters, the setting of colors, insertion of symbols, and more. 

 

Adding Styles to Your Document 
 

You can create, edit, and apply styles to your document through the 'Styles and 

Formatting' panel. This panel is accessed through one of the following methods: 
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Method 1: 

● Format → Styles and Formatting 

 

Method 2: 

● Press  F11 

● The 'Styles and Formatting' panel will appear 

 

Method 3: 

● Open the 'Styles and Formatting' panel as an option through the Sidebar Once the 

panel is open: 

● Right click anywhere inside the 'Styles and Formatting' panel 

● Select ―New‖ or ―Modify‖ 

 

You will then be presented with a large selection of options. The best way to learn is to 

experiment and set up a style according to your own preferences. 

 

Templates 

Once a style has been defined, it can be saved in a file called a "Template" for future use 

in additional documents. This allows for easy consistency across documents or projects. 

 

File → Templates → Save will save a copy of the current document as a template. We 

can use this template for a new document by selecting File → New → Templates and 

documents → Templates and double clicking on the needed template. 
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Note that both the styles AND the content of that document will be saved in the template 

 

It is possible to go further and set our preferred template as the default template for all 

documents. To do so: 

 

● File → Templates → Organize 

❖ Double-click "My Templates" 

❖ Select the required template 

❖ Click the  Commands  button 

❖ Select "Set as Default Template" 

 

Right-clicking on the template in the list will also provide this option 

 

To modify an existing template: 

● File → Templates → Edit 

❖ Double click template file 

 

Alternate method: 

● File → Templates → Organize 

❖ Double-click My Templates 

❖ Select template from list 

❖ Select Edit under Commands 

 

Once the changes are ready, save the document as a normal document. 

 

 

3.2.5 Setting Page style 

 

In Writer, page styles define the basic layout of pages, including page size, margins, 

headers and footers, borders and backgrounds, number of columns, and so on. 

 

Writer comes with several page styles, which you can modify as you wish, and you can 

define your own. You can have one or many page styles in a single document. 

 

All pages in a Writer document are based on styles. If you do not apply a specific page 

style, Writer uses the Default page style. Refer to Applying styles to change the page 

style. 

 

Any modifications of page styles, including the Default page style, apply only to the 

document you are working on. If you want the changes to be the default for all 

documents, you need to put the changes into a template and make that template the 

default template. 

https://wiki.openoffice.org/wiki/Documentation/OOoAuthors_User_Manual/Writer_Guide/Applying_styles
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Setting up a book chapter sequence of pages 

 

Book chapters typically start on a right-hand page, with the first page of the chapter 

having a different layout from the rest of the pages. The other pages in the chapter are 

―mirrored" for double-sided printing. For example, page numbers in the header or footer 

may be positioned on the outside edge of pages and a wider margin (allowing for binding) 

may be placed on the inside edge. 

 

Table shows the properties of two page styles (Right Page and Default) set up for a 

typical book chapter's sequence of pages. 

 

Page Style Desired effect Property: setting 

Right Page 
First page always on the right (an 

odd numbered page) 
Page > Page Layout: Right 

 No header or footer Header > Header on: Not selected 

 
Top margin of page larger than on 

other pages 
Page > Margins > Top: 6.00cm 

Default Mirrored margins Page > Page Layout: Mirrored 

 

Header with page number on the top 

outside of the page, and chapter title 

in the top middle center of the page 

Header > Header on: Selected 

Header > Header > Same content 

left/right: Not selected 

Table - Properties of customized page styles to be used in a book chapter 

 

The figure below illustrates the transitions from Right Page to Default, with the change of 

header between left and right pages shown by the # symbol. 

 

 
Right Page and then Default page style with different header for alternate pages 

To apply this page scenario 

 

1. Set up the page styles. 

On the Styles and Formatting window, click the Page Styles icon  (fourth from 

left) to display a list of page styles. 

 

a. Right-click on Right Page and select Modify from the pop-up menu. 

b. On the Organizer page of the Page Style: Right Page dialog box, change Next 

Style to Default. 
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Specifying the next style after the first page of a chapter 

 

c. On the Page page, specify a larger left margin for binding, and a larger top margin 

to move the chapter title down the page. 

 

 
Setting page margins and layout for the Right Page style. 

d. On the Header and Footer pages, be sure the Header on and Footer 

on checkboxes are not selected. Click OK to save your changes. 

e. On the Styles and Formatting window, in the list of page styles, right-click 

on Default and select Modify from the pop-up menu. 

f. On the Organizer page of the Page Style: Default dialog box, be sure Next 

Style is Default. 
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g. On the Page page of the Page Style: Default dialog box, select Mirrored for Page 

layout and set the Inner and Outer margins to the same width as 

the Left and Right margins, respectively, on the Right Page style. 

 

 
Setting page margins and layout for the Default page style 

 

h. On the Header page of the Page Style: Default dialog box, select the Header 

on checkbox and deselect the Same content left/right checkbox. Click OK to save 

your changes. 

 

 
Setting up the header properties for the Default page style 

 

2. Set up the Heading 1 paragraph style to start on a new right-hand page.   

In the Styles and Formatting window, right-click on Heading 1 and select Modify. 

a. On the Text Flow page of the Paragraph Style dialog box, in the Breaks section, 

select Insert, With Page Style, and Right Page. Click OK to save your changes. 
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Setting a paragraph style to start on a page of a selected style 

 

3. To start a new chapter, apply the paragraph style Heading 1 to the first paragraph, 

which will be the title of the chapter. 

 

By default, paragraph style Heading 1 is assigned to Outline Level 1. The assignment of 

paragraph styles to outline levels is done through Tools > Outline Numbering. 

 

4. To set up the headers: 

 On a left page, put the cursor in the header and insert a page number field on the 

left (Insert > Fields > Page Number). 

 

a. Press Tab to put the cursor in the middle and insert a Chapter reference: 

Press Control+F2 to display the Fields dialog box. 

On the Document page, for Type select Chapter and for Format select Chapter 

name. Make sure that Layer is set to 1, and then click Insert. 

 

 
Inserting a chapter title into the header of a page 

 

b. On a right page, put the cursor in the header, press Tab, insert 

a Chapter reference, press Tab again, and insert a page number field. 

 

c. If you need to adjust the tab stops for the header, modify the Header paragraph 

style. Do not manually adjust the tab stops. 



P a g e  | 165 

 

3.2.6 Creating Tables 

 

Before you insert a table into a document, it helps to have an idea of the visual result you 

want to obtain as well as an estimate of the number of rows and columns required. Every 

parameter can be changed at a later stage; however, thinking ahead can save a large 

amount of time as changes to fully formatted tables often require a significant effort. 

 

Inserting a new table 

 

To insert a new table, position the cursor where you want the table to appear, then use 

any of the following methods to open the Insert Table dialog box: 

 

● From the main menu, select Table > Insert > Table. 

● Press Control+F12. 

● From the Standard toolbar, click the Table icon  

 

 
Inserting a new table using the Insert Table dialog box 

 

Here you can specify the properties for the new table. 

 

Under Name, you can enter a different name than the OOo-generated default for the 

table. This might come in handy when using the Navigator to quickly jump to a table. 

 

Under Size, specify the initial number of columns and rows for the new table. You can 

change the size of the table later, if necessary. 

 

Under Options, set up the initial table characteristics. Selecting the options in this section 

of the dialog produces the following results: 

 

● Heading — Defines the first row(s) in the table as headings. The default Table 

Heading paragraph style is applied to the heading rows and thus makes the text 
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centered, bold, and italic. You can edit the OOo-predefined Table Heading paragraph 

style in the Styles and Formatting window to change these default settings. When 

splitting a table into two tables, the Heading row(s) are copied in the second table. 
 

● Repeat heading — Repeats the heading row(s) of the table at the top of subsequent 

pages if the table spans more than one page.  The first ... rows —Specifies the 

number of rows to be repeated. Default is 1. 
 

● Don‘t split table — Prevents the table from spanning more than one page. This can 

be useful if the table starts near the end of a page, and would look better if it were 

completely located on the following page. If the table becomes longer than would fit 

on one page, you will need to either deselect this option or manually split the table. 
 

● Border — Surrounds each cell of the table with a border. This border can be modified 

or deleted later. 

 

The AutoFormat button opens a dialog from where it is possible to select one of the many 

predefined table layouts. See Automatic formatting of tables for more information. 

 

After making your choices, click OK. Writer creates a table as wide as the text area (from 

the left page margin to the right page margin), with all columns the same width and all 

rows the same height. You can then adjust the columns and rows later to suit your 

needs. 

 

To directly insert a table with the default properties, click on the little arrow next to the 

Table icon on the Standard toolbar. A graphic appears where you can choose the table‘s 

size (rows and columns). To create the table, click on the cell that you want to be on the 

last row of the last column. Holding down the mouse button over the Table icon will also 

display the graphic. 

 

Creating nested tables 

 

You can create tables within tables, nested to a depth only limited by imagination and 

practicality. The figure below demonstrates a simple, two-level example. 

 

To achieve this, simply click in a cell of an existing table and use any of the methods 

mentioned in Inserting a new table above. 

 

 
Nested table example. The shaded table is nested in a cell of the larger table 

 

 

https://wiki.openoffice.org/wiki/Documentation/OOo3_User_Guides/Writer_Guide/Formatting_table_layout#Automatic_formatting_of_tables
https://wiki.openoffice.org/wiki/Documentation/OOo3_User_Guides/Writer_Guide/Creating_a_table#Inserting_a_new_table
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Using AutoCorrect to create a table 

 

You can also create a table by typing a series of hyphens (-) or tabs separated by plus 

signs. Use the plus signs to indicate column dividers, while hyphens and tabs are used to 

indicate the width of a column. 

 

For example, this character sequence: 

+-----------------+---------------+------+ 

 

Creates a table like this: 

 
This function can be disabled or enabled in Tools > AutoCorrect. On the Options tab, 

deselect or select Create table. 

 

When using tabs instead of a table to line up your data, always make sure that you know 

how wide they are set and remember that default tabs may be different when the 

document is displayed on a different computer or even when copying the same data in a 

new document. 

 

Create a table from formatted text 

 

It is possible to create a table starting from plain text by means of the Table > Convert > 

Text to Table menu. In order for this command to work effectively, the starting text needs 

to have clear demarcation between what will become the columns of the table. 

Paragraph marks indicate the end of a row. 

 

To convert text to a table, start by selecting the text you want to convert and select Table 

> Convert > Text to Table to open the dialog box shown below. 

 
Dialog box to configure the text to table conversion 
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In the top part of the dialog box, select the symbol that separates the columns. This 

would normally be a tab, but it could be a semicolon or comma if you are importing a CSV 

file. The other options in this dialog are the same as those in the dialog used to insert a 

table shown above. 

 

Example 
 

In this example we will convert the following text into a table. 
 

Row 1 Column 1; Row 1 Column 2; Row 1 Column 3 

Row 2 Column 1; Row 2 Column 2; Row 2 Column 3 
 

In this case, the separator between elements is a semicolon. By selecting the text and 

applying the conversion, we obtain the following result. 
 

Row 1 Column 1 Row 1 Column 2 Row 1 Column 3 

Row 2 Column 1 Row 2 Column 2 Row 2 Column 3 

You can also use the Convert menu to perform the opposite operation; that is, to 

transform a table into plain text. This may be useful when you want to export the table 

contents into a different program. 

 

To transform a table into text, place the cursor anywhere in the table, select Table > 

Convert > Table to Text in the main menu, pick the preferred row separator, and 

click OK to finish. 

 

3.2.7 Drawing - Tools 
 

You can use Writer‘s drawing tools to create graphics, such as simple diagrams using 

rectangles, circles, lines, text, and other predefined shapes. You can also group several 

drawing objects to make sure they maintain their relative position and proportion. 

You can place the drawing objects directly on a page in your document, or you can insert 

them into a frame. 

 

You can also use the drawing tools to annotate photographs, screen captures, or other 

illustrations produced by other programs, but this is not recommended because: 

 

● You cannot include images in a group with drawing objects, so they may get out of 

alignment in your document. 

● If you convert a Writer document to another format, such as HTML, the drawing 

objects and the graphics will not remain associated; they are saved separately. 

 

In general, if you need to create complex drawings, it is recommended to use 

OpenOffice.org Draw, which includes many more features such as layers, styles, and so 

on. 

 

https://wiki.openoffice.org/wiki/Documentation/OOo3_User_Guides/Writer_Guide/Creating_a_table#WG9-2.png
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Creating drawing objects 

 

To begin using the drawing tools, display the Drawing toolbar, by clicking View > Toolbars 

> Drawing. 

 

If you are planning to use the drawing tools repeatedly, you can tear off this toolbar and 

move it to a convenient place on the window. 

 

 
1 Select | 2 Line | 3 Rectangle | 4 Ellipse | 5 Freeform Line | 6 Text | 7 Callouts 

| 8 Basic Shapes | 9 Symbol Shapes | 10 Block arrows | 11 Flowcharts | 12 Callouts 

| 13 Stars | 14 Points | 15 Fontwork Gallery | 16 From File | 17 Extrusion On/Off 

Drawing toolbar 

 

To use a drawing tool 

1. Click in the document where you want the drawing to be anchored. You can 

change the anchor later, if necessary. 

2. Select the tool from the Drawing toolbar. The mouse pointer changes to a 

drawing-functions pointer . 

3. Move the cross-hair pointer to the place in the document where you want the 

graphic to appear and then click-and-drag to create the drawing object. Release 

the mouse button. The selected drawing function remains active, so you can draw 

another object of the same type. 

4. To cancel the selected drawing function, press the Esc key or click on 

the Select icon (the arrow) on the Drawing toolbar. 

5. You can now change the properties (fill color, line type and weight, anchoring, and 

others) of the drawing object using either the Drawing Object Properties toolbar or 

the choices and dialog boxes reached by right-clicking on the drawing object. 

 

Set or change properties for drawing objects 
 

To set the properties for a drawing object before you draw it: 
 

1. On the Drawing toolbar, click the Select tool. 

2. On the Drawing Object Properties toolbar, click on the icon for each property and 

select the value you want for that property. 

3. For more control, or to define new attributes, you can click on 

the Area or Line icons on the toolbar to display detailed dialog boxes. 

 

https://wiki.openoffice.org/wiki/Documentation/OOo3_User_Guides/Writer_Guide/Using_drawing_tools#Setting_or_changing_properties_for_drawing_objects
https://wiki.openoffice.org/wiki/Documentation/OOo3_User_Guides/Writer_Guide/Using_drawing_tools#Creating_drawing_objects
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The default you set applies to the current document and session. It is not retained when 

you close the document or close Writer, and it does not apply to any other document you 

open. The defaults apply to all the drawing objects except text objects. 

 

 
1 Line | 2 Arrow Style | 3 Line Style | 4 Line Width | 5 Line Color | 6 Area | 7 Area Style 

/ Filling | 8 Rotate | 9 To Foreground | 10 To Background | 11 Bring to Front | 12 Send 

to Back | 13 Alignment | 14 Change Anchor | 15 Ungroup | 16 Group 

Drawing Object Properties toolbar 

 

To change the properties for an existing drawing object 

1. Select the object. 

2. Continue as described above. 

 

You can also specify the position and size, rotation, and slant and corner radius 

properties of the drawing object: 
 

1. Right-click on the drawing object and then click Position and Size from the pop-up 

menu. The Position and Size dialog box is displayed. 

2. Choose any properties, as required. 

 

Resizing a drawing object 

 

The same considerations for resizing an image apply also to resizing an object. Select the 

object, click on one of the eight handles around it and drag it to its new position. For a 

scaled resizing, select one of the corner handles and keep the Shift key pressed while 

dragging the handle to its new position. 

 

For more sophisticated control of the size of the object, select Format > Object > Position 

and Size from the menu bar. Use the Position and Size dialog box to set the width and 

height independently. If the Keep ratio option is selected, then the two dimensions 

change so that the proportion is maintained, allowing for a scaled resizing. 

 

Grouping drawing objects 
 

To group drawing objects: 
 

1. Select one object, then hold down the Shift key and select the others you want to 

include in the group. The bounding box expands to include all the selected 

objects. 

2. With the objects selected, hover the mouse pointer over one of the objects and 

choose Format > Group > Group from the menu bar or right-click and 

choose Group > Group from the pop-up menu. 
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3.2.8 Printing Documents 
 

Quick printing 

Click the Print File Directly icon  to send the entire document to the default printer 

defined for your computer. 

  

Controlling printing using the Print dialog box 
 

For more control over printing, use File > Print to display the Print dialog box. 
 

 
Print dialog 

On the Print dialog box, you can choose: 

● Which printer to use (if more than one are installed on your system) and the 

properties of the printer—for example, orientation (portrait or landscape), 

which paper tray to use, and what paper size to print on. The properties 

available depend on the selected printer; consult the printer's documentation 

for details. 

● Which pages to print, how many copies to print, and in what order to print 

them. 

● Use dashes to specify page ranges and commas or semicolons to separate 

ranges; for example, 1, 5, 11-14, 34-40. 

● Selection is the highlighted part of a page or pages. 

● Which items to print. Click the Options button to display the Printer Options 

dialog box. For details about print options and setting defaults for 

Writer(Printing, Faxing, Exporting, and Emailing). 

 

Previewing pages before printing 

 

The normal page view in Writer shows what each page will look like when printed, but it 

shows only one page at a time. If you are designing a document to be printed double-
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sided, you may want to see what facing pages look like. OOo provides a way to do this in 

Page Preview. 

Click File > Page Preview, or click the Page Preview icon.  

 

The Writer window changes to display the current page and the following page and the 

Page Preview toolbar replaces the Formatting toolbar. 

 

 
Page Preview toolbar 

 

● To display left and right pages in their correct orientation (facing pages), click 

the Book Preview icon . 

● To print the document in this page view, click the Print page view icon.  

 

● To choose margins and other options for the printout, click the Print options page 

view icon  to display the Print Options dialog box. For more 

information, (Printing, Faxing, Exporting, and Emailing). 

 

Exporting to PDF 

 

OpenOffice.org can export documents to PDF (Portable Document Format). This industry-

standard file format for file viewing is ideal for sending the file to someone else to view 

using Acrobat Reader or other PDF viewers. 

 

Quick export to PDF 

Click the Export Directly as PDF icon  to export the entire document using the default 

PDF settings. You are asked to enter the file name and location for the PDF file, but you 

do not get a chance to choose a page range or the print quality. 

 

Controlling PDF content and quality 

 

For more control over the content and quality of the resulting PDF, use File > Export as 

PDF.  You are asked to enter the location and file name of the PDF to be created, and 

then the PDF Options dialog box opens. 

 

Here you can choose which pages to include in the PDF, the type of compression to use 

for images (which affects the quality of images in the PDF), and other options. 

 

Closing a document 

 

To close a document, click File > Close. 
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You can also close a document by clicking on the Close icon on the document window. In 

Windows XP, this button looks like the red X shown in Figure 10. 

 

If more than one OOo window is open, each window looks like the sample shown on the 

left in Figure 10. Closing this window leaves the other OOo windows open. 

 

If only one OOo window is open, it looks like the sample shown on the right in Figure 10. 

Notice the small black X below the large red X. Clicking the small X closes the document 

but leaves OOo open. Clicking the large red X closes OOo completely. 

 

 
Figure 10 Close icons in Windows XP 

 

If the document has not been saved since the last change, a message box is displayed. 

Choose whether to save or discard your changes. 

 

 
Figure 11 Warning about unsaved changes on close 

 

● Save: The document will be saved and then closed. 

● Discard: The document will be closed, and all modifications since the last save 

will be lost. 

● Cancel: Nothing will happen, and you will return to the document. 

 

 

3.2.9 Operating with MS Word documents 
 

Create and edit doc and docx documents with OpenOffice Writer online 

 

OpenOffice Writer online is an extension that allows to create, edit and view any 

Microsoft Word documents in both doc and docx formats. It is a word processor and 

publishing tool. It allows to create large documents, reports, and books, and simple 

enough for a quick memo.  
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It is a document editor integrated with our file manager to manage only DOC, DOCX and 

ODT file types with this desktop app. 

 

The Open Office writer main features are: 

 

● Wizards for standard documents such as letters, faxes, agendas, minutes, or 

carrying out more complex tasks such as mail merges. You can also create your own 

templates, or download templates from the Templates repository. 

● Advanced Styles and Formatting. 

● Table of Contents & References to increase the usefulness of your long, complex 

documents by generating a table of contents or indexing terms, bibliographical 

references, illustrations, tables, and other objects. 

● Text frames and linking for publishing tasks like newsletters and flyers 

● Notes and comments on the side of the document. This makes notes a lot easier to 

read. 

● AutoCorrect dictionary to trap typing mistakes on the fly, checking your spelling as 

you type. 

● AutoComplete to reduce typing effort. It also suggests common words and phrases to 

complete while you are typing. 

***** 
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Introduction to MS Office – MS Excel and Open Office - Calc 

4.1. MS Excel 

4.1.1 Introduction 

Spreadsheet and its application 

● Microsoft Excel is a spreadsheet tool capable of performing calculations, analyzing 

data and integrating information from different programs. 

● By default, documents saved in Excel 2010 are saved with the .xlsx extension. 

How to open Excel? 

Start the excel application following the below mentioned steps. 

Step 1 − Click on the Start button. 

 

Step 2 − Click on All Programs option from the menu. 

Step 3 − Search for Microsoft Office from the sub menu and click it. 

Step 4 − Search for Microsoft Excel 2010 from the submenu and click it. 

The following basic window appears as below:  
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Menus  

Main Menu 

The Main Menu Bar at the top of the screen gives you access to different commands that 

are used for such tasks as opening and closing files, printing documents, formatting 

data, and other operations. 

 

 

File 

The File menu is the leftmost item in the Excel ribbon. The File ribbon items enable you 

to perform file management functions, including open, save, close, and print.  

 

Home 

The Home menu is the second menu in the Excel menu bar. The Home ribbon items 

include options for formatting font, color, conditional formatting, filter, number type, and 

more.  

 

Insert 

The Insert menu helps you insert various options and items into an Excel spreadsheet. 

You can insert a variety of things ranging from pivot table to picture, clip art, shapes, 

screen shots, charts and graphs, text box, header and footer, symbols, equation, and 

more. 

 

Page Layout 

Page Layout menu has the collection of functions like configuring pages for viewing and 

printing—including page size, margins, colors and fonts, and so on. You can also 

customize cell height and width on the Page Layout menu. 

 

Formulas  

The Formulas menu is where you find all the number-crunching options. Excel comes 

with lots of formulas including financial, logical, text, date & time, lookup & reference, 

and math & trigonometry. 

 

Data 

The Data menu also contains many important functions like including imports and 

connections with databases. You also access the sort, filter, remove duplicates, data 

validation, consolidation, group, ungroup, and subtotal functions on the Data menu. 
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Review 

The Review menu is where many of those tasks take place. You can make comments in 

cells, check spelling, track changes, and even restrict permission using items in the 

Review menu. 

 
View 

On the View menu, you customize the way spreadsheets appear on the screen. Options 

include displaying grid lines between cells, toggling the formula bar and headings, and 

more.  This menu also gives you options to view and record macros. 

 

Quick Access Toolbar 

This toolbar just above the File tab and its purpose is to provide a convenient resting 

place for the Excel's most frequently used commands.  

Ribbon 

 

Ribbon contains commands organized in three components − 

● Tabs − They appear across the top of the Ribbon and contain groups of related 

commands. Home, Insert, Page Layout are the examples of ribbon tabs. 

● Groups − They organize related commands; each group name appears below the 

group on the Ribbon. For example, group of commands related to fonts or group of 

commands related to alignment etc. 

● Commands − Commands appear within each group as mentioned above. 
 

Title Bar 

This lies in the middle and at the top of the window. Title bar shows the program and the 

sheet titles. 

 

Help 

The Help Icon can be used to get excel related help anytime. This provides nice tutorial 

on various subjects related to excel. 

 

Zoom Control 

Zoom control lets you zoom in for a closer look at your text. The zoom control consists of 

a slider that you can slide left or right to zoom in or out. The + buttons can be clicked to 

increase or decrease the zoom factor. 
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View Buttons 

The group of three buttons located to the left of the Zoom control, near the bottom of the 

screen, lets you switch among excel's various sheet views. 

● Normal Layout view − This displays the page in normal view. 

● Page Layout view − This displays pages exactly as they will appear when printed. This 

gives a full screen look of the document. 

● Page Break view − This shows a preview of where pages will break when printed. 

 

Sheet Area 

The area where the data is entered. The flashing vertical bar is called the insertion point 

and it represents the location where text will appear. 

 

Row Bar 

Rows are numbered from 1 onwards to Maximum limit is 1,048,576 rows. 

 

Column Bar 

Columns are numbered from A to Z start the series of AA, AB and so on. Maximum limit is 

16,384 columns. 

 

Status Bar 

This displays the current status of the active cell in the worksheet. A cell can be in either 

of the four states  

a) Ready mode which indicates that the worksheet is ready to accept user input 

b) Edit mode indicates that cell is editing mode. 

c) A cell enters into Enter mode when a user types data into a cell  

d) Point mode triggers when a formula is being entered using a cell reference by mouse 

pointing or the arrow keys on the keyboard. 
 

Dialog Box Launcher 

This appears as a very small arrow in the lower-right corner of many groups on the 

Ribbon. Clicking this button opens a dialog box or task pane that provides more options 

about the group tab located in the upper-left corner of the Excel Ribbon.  

Sl.No. Option & Description 

1 
Save-If an existing sheet is opened, it would be saved as is, otherwise it will 

display a dialogue box asking for the sheet name. 

2 
Save As-A dialogue box will be displayed asking for sheet name and sheet type. By 

default, it will save in sheet 2010 format with extension .xlsx. 

3 Open-This option is used to open an existing excel sheet. 
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4 Close-This option is used to close an opened sheet. 

5 Info-This option displays the information about the opened sheet. 

6 Recent-This option lists down all the recently opened sheets. 

7 New-This option is used to open a new sheet. 

8 Print-his option is used to print an opened sheet. 

9 
Save & Send-This option saves an opened sheet and displays options to send the 

sheet using email etc. 

10 Help-This option is to get the required help about excel 2010. 

11 Options-This option to set various option related to excel 2010. 

12 Exit-Use this option to close the sheet and exit. 

 

 

If you already have an opened sheet then it will display a window showing the details 

about the in case of already opened sheet the screen will appear as shown below. 

Backstage view shows three columns. 

 

First column of the backstage view will have the following options – 

Sheet Information 

Click Info option available in the first column, it displays the following information in the 

second column of the backstage view − 

● Compatibility Mode − If the sheet is not a native excel 2007/2010 sheet, a Convert 

button appears here, enables easily to update its format. Otherwise, this category 

does not appear. 

● Permissions − Use this option to protect the excel sheet. Set a password so that 

nobody can open the sheet, or can lock the sheet so that nobody can edit the sheet. 
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● Prepare for Sharing − This section highlights important information about the sheet 

before send it to others, such as a record of the edits developed the sheet. 

● Versions − If the sheet has been saved several times, to access previous versions of 

it from this section. 

● Sheet Properties 

 

Sheet area is the place where the text is typed. The flashing vertical bar is called the 

insertion point and it represents the location where text will appear when typed. When 

you click on a box then the box is highlighted. When you double click the box, the flashing 

vertical bar appears and start entering the data. 

Keep the mouse cursor at the text insertion point and start typing.  

There are following three important points while typing − 

● Press Tab to go to next column. 

● Press Enter to go to next row. 

● Press Alt + Enter to enter a new line in the same column. 

 

Open the workbook 

How to open workbook from excel in the below mentioned steps. 

Step 1 − Click the File Menu as shown below 

There are two more columns Recent workbooks and Recent places, recently opened 

workbooks and the recent places from where workbooks are opened. 
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Step 2 − Clicking the Open Option will open the browse dialog as shown below. Browse 

the directory and find the file to open. 
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Step 3 − Select the workbook  

 
 

Formulas in MS Excel 

Formulas are the Bread and butter of worksheet. Without formula, worksheet will be just 

simple tabular representation of data. A formula consists of special code, which is 

entered into a cell. It performs some calculations and returns a result, which is displayed 

in the cell. 

Formulas use a variety of operators and worksheet functions to work with values and 

text. The values and text used in formulas can be located in other cells, which makes 

changing data easy and gives worksheets their dynamic nature. For example, you can 

quickly change the data in a worksheet and formulas works. 

 

Elements of Formulas 

A formula can consist of any of these elements − 

● Mathematical operators, such as +(for addition) and *(for multiplication) 

Example − 

▪ =A1+A2 Adds the values in cells A1 and A2. 

● Values or text 

Example − 

▪ =200*0.5 Multiplies 200 times 0.15. This formula uses only values, and it 

always returns the same result as 100. 

● Cell references (including named cells and ranges) 
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Example − 

▪ =A1=C12 Compares cell A1 with cell C12. If the cells are identical, the formula 

returns TRUE; otherwise, it returns FALSE. 

● Worksheet functions (such as SUM or AVERAGE) 

Example − 

▪ =SUM(A1:A12) Adds the values in the range A1:A12. 

 

Creating Formula 

For creating a formula you need to type in the Formula Bar. Formula begins with '=' sign. 

When building formulas manually, you can either type in the cell addresses or you can 

point to them in the worksheet. Using the Pointing method to supply the cell addresses 

for formulas is often an easier and more powerful method of formula building. When you 

are using built-in functions, you click the cell or drag through the cell range that you want 

to use when defining the function‘s arguments in the Function Arguments dialog box. See 

the below screenshot. 

As soon as you complete a formula entry, Excel calculates the result, which is then 

displayed inside the cell within the worksheet (the contents of the formula, however, 

continue to be visible on the Formula bar anytime the cell is active). If you make an error 

in the formula that prevents Excel from being able to calculate the formula at all, Excel 

displays an Alert dialog box suggesting how to fix the problem. 

 

Copying Formulas in MS Excel 

Copying formulas is one of the most common tasks that you do in a typical spreadsheet 

that relies primarily on formulas. When a formula uses cell references rather than 
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constant values, Excel makes the task of copying an original formula to every place that 

requires a similar formula. 

Relative Cell Addresses 

MS Excel does it automatically adjust the cell references in the original formula to suit 

the position of the copies that you make. It does this through a system known as relative 

cell addresses, whereby the column references in the cell address in the formula change 

to suit their new column position and the row references change to suit their new row 

position. 

 

After writing the formula in the 9th row, we can drag it to the remaining columns and the 

formula gets copied. After dragging we can see the formula in the remaining columns as 

below. 

● column C : =SUM(C3:C8) 

● column D : =SUM(D3:D8) 

● column E : =SUM(E3:E8) 

● column F : =SUM(F3:F8) 

● column G : =SUM(G3:G8) 
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Excel calculates the result, which is then displayed inside the cell within the worksheet 

(the contents of the formula, however, continue to be visible on the Formula bar anytime 

the cell is active).  
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Cell References in Formulas 

Most formulas you create include references to cells or ranges. These references enable 

your formulas to work dynamically with the data contained in those cells or ranges. For 

example, if your formula refers to cell C2 and you change the value contained in C2, the 

formula result reflects new value automatically.  

When you use a cell (or range) reference in a formula, you can use three types of 

references − relative, absolute, and mixed references. 

 

Relative Cell References 

The row and column references can change when you copy the formula to another cell 

because the references are actually offsets from the current row and column. By default, 

Excel creates relative cell references in formulas. 

 

 

 

Absolute Cell References 

The row and column references do not change when you copy the formula because the 

reference is to an actual cell address. An absolute reference uses two dollar signs in its 

address: one for the column letter and one for the row number (for example, $A$5). 
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Formatting Cell 

MS Excel Cell can hold different types of data like Numbers, Currency, Dates, etc. You 

can set the cell type in various ways as shown below − 

● Right Click on the cell » Format cells » Number. 

● Click on the Ribbon from the ribbon. 
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Various Cell Formats 

Below are the various cell formats. 

● General − This is the default cell format of Cell. 

● Number − This displays cell as number with separator. 

● Currency − This displays cell as currency i.e. with currency sign. 

● Accounting − Similar to Currency, used for accounting purpose. 

● Date − Various date formats are available under this like 17-09-2013, 17th-Sep-

2013, etc. 

● Time − Various Time formats are available under this, like 1.30PM, 13.30, etc. 

● Percentage − This displays cell as percentage with decimal places like 50.00%. 

● Fraction − This displays cell as fraction like 1/4, 1/2 etc. 

● Scientific − This displays cell as exponential like 5.6E+01. 

● Text − This displays cell as normal text. 

● Special − Special formats of cell like Zip code, Phone Number. 

● Custom − You can use custom format by using this. 

Toolbars in Excel 

 

Excel toolbar (also called Quick Access Toolbar). It enables users to save important 

shortcuts and easily access them when needed is presented to get access to various 

commands to perform the operations. It is presented with an option to add or delete 

commands to it to access them quickly. 

 

Using Icons 

In Excel 2010, there is an option which facilitates user to show icons in data cells by 

applying desired condition. Excel includes 20 Icon Sets in four categories; Shapes, 

Directional, Indicators, and Ratings, and along with this it also enables user to easily 

format and customize the icon sets to make data cells prominent, which shows an 

exclusive importance. 

 

https://www.google.co.in/search?biw=1536&bih=714&sxsrf=ALiCzsZ_NUKnrZkyfy5WJ6dUwV97ZyxmZQ:1653532861445&q=What+is+a+toolbar+in+Excel?&tbm=isch&source=iu&ictx=1&vet=1&fir=zCXm5v4AsX1kvM%252C4Zpqofqv5XWV4M%252C_&usg=AI4_-kQ04Ya2xTTo5QnK-hsD5iQEzo05ww&sa=X&ved=2ahUKEwikrtL2kfz3AhVDSWwGHQfkDcIQ9QF6BAgUEAE#imgrc=zCXm5v4AsX1kvM
https://www.google.co.in/search?biw=1536&bih=714&sxsrf=ALiCzsZ_NUKnrZkyfy5WJ6dUwV97ZyxmZQ:1653532861445&q=What+is+a+toolbar+in+Excel?&tbm=isch&source=iu&ictx=1&vet=1&fir=zCXm5v4AsX1kvM%252C4Zpqofqv5XWV4M%252C_&usg=AI4_-kQ04Ya2xTTo5QnK-hsD5iQEzo05ww&sa=X&ved=2ahUKEwikrtL2kfz3AhVDSWwGHQfkDcIQ9QF6BAgUEAE#imgrc=zCXm5v4AsX1kvM
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Using Help 

If you get stuck and need help with Excel 2010 features, you can use the Excel Help 

window to quickly find the answers. The Excel Help button — the blue circle with a 

question mark, located to the right of the last Ribbon tab — provides quick access to 

Help. 
 

Certain commands on the Ribbon display a ScreenTip that says Press F1 for Help when 

you hover the mouse cursor over them. When you see this, press F1 to see Help 

information related specifically to that command. 

 

MS Excel Keyboard Shortcuts 

MS Excel offers many keyboard short-cuts. Below is the list of all the major shortcut keys 

in Microsoft Excel. 

● Ctrl + A − Selects all contents of the worksheet. 

● Ctrl + B − Bold highlighted selection. 

● Ctrl + I − Italicizes the highlighted selection. 

● Ctrl + K − Inserts link. 

● Ctrl + U − Underlines the highlighted selection. 

● Ctrl + 1 − Changes the format of selected cells. 

● Alt + = − Creates a formula to sum all of the above cells 

● Ctrl + ' − Inserts the value of the above cell into cell currently selected. 

● Ctrl + Home − Moves to cell A1. 

● Ctrl + ~ − Switches between showing Excel formulas or their values in cells. 

● F2 − Edits the selected cell. 

● Alt + Enter − While typing text in a cell pressing Alt + Enter will move to the next line 

allowing for multiple lines of text in one cell. 

 

Spreadsheet Types 

Excel offers three general ways to arrange data in your spreadsheet so you can use it as 

a database with your worksheet formulas: 

1. Simple (or ―Gray Cell‖) Tables, which I‘ve used since Excel 2.0. 

2. Excel Tables, introduced in Excel 2007. 

3. PivotTables with a Tabular Report Layout, introduced in Excel 2010. 

 

 

Working with Spreadsheets  

Creating New Worksheet 

Three new blank sheets always open when you start Microsoft Excel.  
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How to create a new worksheet 

Step 1 − Right Click the Sheet Name and select Insert option. 

 

Step 2 − Insert dialog with select Worksheet option as selected from the general tab. 

Click the Ok button. 

 

Now you should have your blank sheet as shown below ready to start typing your text. 

Using the Shift+F11 keys new blank sheet is opened. 

How to open workbook from excel  

Step 1 − Click the File Menu as shown below. Open option in File Menu.  
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There are two more columns Recent workbooks and Recent places, where you can see 

the recently opened workbooks and the recent places from where workbooks are 

opened. 

 

Step 2 − Clicking the Open Option will open the browse dialog as shown below. Browse 

the directory and find the file you need to open. 

 

Step 3 − Once you select the workbook your workbook will be opened as below – 
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Saving New Sheet 

To save your sheet/workbook  following are the steps to save an edited excel sheet − 

Step 1 − Click the File tab and select Save As option. 

 

Step 2 − Select a folder where to save the sheet, Enter file name Select a Save as type, 

by default it is .xlsx format. 

Step 3 − Finally, click on Save button and saved with the entered name in the selected 

folder. 

 

Saving New Changes 

After opening workbook and to save this sheet with the same name, then use either of 

the following simple options − 

● Just press Ctrl + S keys to save the changes. 

● click on the floppy icon available at the top left corner and just above the File tab. 

This option will also save the changes. 

● Save option available just above the Save As option as shown in the above screen 

capture. 

If your sheet is new and it was never saved so far, then with either of the three options, 

word would display you a dialogue box to let you select a folder, and enter sheet name 

and click save. 

 

Setting Margins 

Margins 

Margins are the unprinted areas along the sides, top, and bottom of a printed page. All 

printed pages in MS Excel have the same margins. 
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Steps to set the margin 

Choose Page Layout » Page Setup » Margins drop-down list,  can select Normal, Wide, 

Narrow, or the custom Setting. 

 

 

 

Converting files to different formats 

In Excel, open the workbook that you want to save for use in another program. 

● On the File tab, click Save As. 

● To save the workbook to a different location, specify the drive and location in the file 

path and folder boxes. 
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● In the File name box, accept the suggested name or type a new name for the 

workbook. 

● In the Save as type list, click the format (PDF, XPS, etc.) that you know you can open 

in the other program. 

 

In Excel, you can import data from different data sources. Some of the data sources are 

as follows − 

● Microsoft Access Database 

● Web Page 

● Text File 

● SQL Server Table 

● SQL Server Analysis Cube 

● XML File 

 

Importing Data from Microsoft Access Database 

To import data from MS Access database, follow the steps given below  

Step 1 − Open a new blank workbook in Excel. 

Step 2 − Click the DATA tab on the Ribbon. 

Step 3 − Click From Access in the Get External Data group. The Select Data Source dialog 

box appears. 

 

 

Step 4 − Select the Access database file to import. Access database files will have the 

extension .accdb. 

The Select Table dialog box appears displaying the tables found in the Access database. 

Import all the tables in the database at once or import only the selected tables. 
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Step 5 − Select the Enable selection of multiple tables box and select all the tables. 

 

Step 6 − Click OK. The Import Data dialog box appears. 
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The following options to view the data you are importing in the workbook − 

● Table 

● PivotTable Report 

● PivotChart 

● Power View Report 

 

PivotTable Report is selected by default. 

Excel also gives the options to put the data in your workbook − 

● Existing worksheet 

● New worksheet 

Another check box that is selected and disabled – Add this data to the Data Model. 

Whenever you import data tables into your workbook, they are automatically added to the 

Data Model in the workbook.  

● If we select Table, Existing worksheet option gets disabled, New worksheet option 

gets selected and Excel creates as many worksheets as the number of tables are 

imported from the database. The Excel tables appear in these worksheets. 

● If you select PivotTable Report, Excel imports the tables into the workbook and 

creates an empty PivotTable for analyzing the data in the imported tables.  

● Excel tables for the imported data tables will not appear in the workbook. However, 

you will find all the data tables in the PivotTable fields list, along with the fields in 

each table. 

● If you select PivotChart, Excel imports the tables into the workbook and creates an 

empty PivotChart for displaying the data in the imported tables.  

● If you select the option - Only Create Connection, a data connection will be 

established between the database and your workbook.  

Importing Data from Other Sources 

Excel provides the options to choose various other data sources.  Import data from these 

in few steps. 

Step 1 − Open a new blank workbook in Excel. 

Step 2 − Click the DATA tab on the Ribbon. 

Step 3 − Click from Other Sources in the Get External Data group. 
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Dropdown with various data sources appears. 

 

 

Export Excel sheet 

If your data is shared between other programs, like a database, you may need to save 

data as a different file type or bring in files of a different file type. 

Exporting Data 

When you have data that needs to be transferred to another system, export it from Excel 

in a format that can be interpreted by other programs, such as a text or CSV file. 

1. Click the File tab.   

2. At the left, click Export. 

 

  
  

3. Click the Change File Type. 

4. Under Other File Types, select a file type. 

● Text (Tab delimited): The cell data will be separated by a tab. 

● CSV (Comma delimited): The cell data will be separated by a comma. 

● Formatted Text (space delimited): The cell data will be separated by a space. 

● Save as Another File Type: Select a different file type when the Save As dialog box 

appears. 

● The file type you select will depend on what type of file is required by the program 

that will consume the exported data. 
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5. Click Save As. 

6. Specify where you want to save the file.   

7. Click Save. 
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● A dialog box appears stating that some of the workbook features may be lost.  Click 

Yes. 
 

 

Sending files to others 
 

Workbook can be shared to others within Excel. Others can edit the workbook or just view 

it. 

 

1. Select Share. 

2. Select permissions and then Apply. 

3. Add people. 

4. Type a message if you like. 

5. Select Send. 

 

 
 

 

Spreadsheet Addressing - Rows, Columns and Cells 

MS Excel is in tabular format consisting of rows and columns. 

● Row runs horizontally while Column runs vertically. 

● Each row is identified by row number, which runs vertically at the left side of the 

sheet. 

● Each column is identified by column header, which runs horizontally at the top of the 

sheet. 

● For MS Excel 2010, Row numbers ranges from 1 to 1048576; in total 1048576 

rows, and Columns ranges from A to XFD; in total 16384 columns. 
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Navigation with Rows and Columns 

Let us see how to move to the last row or the last column. 

● You can go to the last row by clicking Control + Down Navigation arrow. 

● You can go to the last column by clicking Control + Right Navigation arrow. 

 

 

 

Cell Introduction 

The intersection of row and column is called cell.  Cell is identified with Combination of 

column header and row number.  For example − A1, A2. 

 

Excel 2010 includes two types of referencing, i.e, Absolute and Relative, these 

referencing.  To find out the different type of data cell address, then you can easily show 

it by providing certain parameters. Excel ADDRESS function provide list of options to 
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show address in desired ways; with row/column headers or row/column numbers, with 

absolute, relative or mixed format, etc.  The syntax of ADDRESS function is; 

=ADDRESS(row_number, column_num,[abs_num],[a1],[sheet_text]) 

The first argument row_number refers to the number of row in which data cell is existed, 

next argument column_num refers to column number in which it is present, third 

argument [abs_num] refers to list which provide different options; Absolute, Absolute 

row/Relative column, Relative row/Absolute column, and Relative. On choosing desired 

option from the list, you will see the address in specified format, the [a1] refers to two 

different ways, i.e, with row/column number(R1C1) or row/column headers(A1B1) in 

which you want to show address. The last argument shows sheet text in the address. 

Selecting cells - shortcut 

1. Select the Last Used Cell 

 The keyboard shortcut to select the last used cell on a sheet is: Ctrl+End. 

Ctrl+End  will take you to the intersection of the last used column and last used row. 

2. Select the First Visible Cell 

3. The keyboard shortcut to select the first visible cell on a sheet is: Ctrl+Home 

 Using Ctrl+Home will always take you to the first visible cell (excluding hidden 

 rows/columns) on the sheet, unless your sheet has Freeze Panes. 

4. The keyboard shortcut to select the last cell in a contiguous range is: Ctrl+Arrow Key 

5. Add Cells to the Selected Range 

    The keyboard shortcut to add cells to the selected range is: Shift+Arrow Key 

6. Select Multiple Cells in Contiguous Range Ctrl+Shift+Arrow Key 

7. Select All Cells 

 The keyboard shortcut to all cells in the current used range is: Ctrl+A 

4.1.2 Entering Data and Deleting Data 

 

In MS Excel, there are 1048576*16384 cells. MS Excel cell can have Text, Numeric 

value or formulas. An MS Excel cell can have maximum of 32000 characters. 

Inserting Data 
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For inserting data in MS Excel, just activate the cell type text or number and press enter 

or Navigation keys. 

 

Cut Copy Paste 

MS Excel provides copy paste options in different ways. The simplest method of copy 

paste is as below. 

Copy Paste 

● To copy and paste, just select the cells you want to copy. Choose copy option after 

right click or press Control + C. 

● Select the cell where you need to paste this copied content. Right click and select 

paste option or press Control + V. 
 

 
 

Copy Paste using Office Clipboard 

When you copy data in MS Excel, it puts the copied content in Windows and Office 

Clipboard. You can view the clipboard content by Home → Clipboard. View the clipboard 

content. Select the cell where you need to paste. Click on paste, to paste the content. 
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Below are the various options available in paste special. 

● All − Pastes the cell‘s contents, formats, and data validation from the Windows 

Clipboard. 

● Formulas − Pastes formulas, but not formatting. 

● Values − Pastes only values not the formulas. 

● Formats − Pastes only the formatting of the source range. 

● Comments − Pastes the comments with the respective cells. 

● Validation − Pastes validation applied in the cells. 

● All using source theme − Pastes formulas, and all formatting. 

● All except borders − Pastes everything except borders that appear in the source 

range. 

● Column Width − Pastes formulas, and also duplicates the column width of the copied 

cells. 

● Formulas & Number Formats − Pastes formulas and number formatting only. 

● Values & Number Formats − Pastes the results of formulas, plus the number. 

● Merge Conditional Formatting − This icon is displayed only when the copied cells 

contain conditional formatting. When clicked, it merges the copied conditional 

formatting with any conditional formatting in the destination range. 

● Transpose − Changes the orientation of the copied range. Rows become columns, 

and columns become rows. Any formulas in the copied range are adjusted so that 

they work properly when transposed. 
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Undo and Redo 
 

The Undo and Redo features let you remove or repeat single or multiple typing actions, 

but all actions must be undone or redone in the order you did or undid them  

● The Ctrl + Z (for undo) and Ctrl + Y (for redo) keyboard shortcuts. 

● The undo and redo buttons in the Quick Access Toolbar. 
 

Filling Continuous rows, columns, Highlighting values  

1. Select one or more cells you want to use as a basis for filling additional cells. For a 

series like 1, 2, 3, 4, 5..., type 1 and 2 in the first two cells. ... 

2. Drag the fill handle . 

3. If needed, click Auto Fill Options. and choose the option you want. 

You can easily add sequential numbers to rows of data by dragging the fill handle to fill a 

column with a series of numbers or by using the ROW function. 

 

Fill a column with a series of numbers 

1. Select the first cell in the range that you want to fill. 

2. Type the starting value for the series. 

3. Type a value in the next cell to establish a pattern. 

 

For example, if you want the series 1, 2, 3, 4, 5..., type 1 and 2 in the first two cells. If you 

want the series 2, 4, 6, 8..., type 2 and 4. 

1. Select the cells that contain the starting values. 

2. Drag the fill handle  across the range that you want to fill. 

To fill in increasing order, drag down or to the right. To fill in decreasing order, drag up or 

to the left. 

 

Highlighting Values 

Conditional formatting makes it easy to highlight certain values or make particular cells 

easy to identify. This changes the appearance of a cell range based on a condition (or 

criteria). You can use conditional formatting to highlight cells that contain values which 

meet a certain condition. Or you can format a whole cell range and vary the exact format 

as the value of each cell varies. 

Highlighting the values can be done based on highlight cells rules,top/bottom rules,Data 

bars, Color scales, Icon sets. 

 

https://support.microsoft.com/en-us/office/row-function-3a63b74a-c4d0-4093-b49a-e76eb49a6d8d
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Example: 

1. Select Highlight Cells Rules or Top/Bottom Rules. We'll choose Highlight Cells Rules 

for this example. A menu will appear with several rules. 

2. Select the desired rule (Greater Than, for example). 
 

 
 

 

3. From the dialog box, enter a value in the space provided, if applicable. In this 

example, we want to format cells that are greater than $5000, so we'll enter 

5000 as our value. If you want, you can enter a cell reference instead of a 

number. 

4. Select a formatting style from the drop-down menu. 

 

 
 

5. The formatting will be applied to the selected cells. 
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Find, Sesarch and Replace 

MS Excel provides Find & Replace option for finding text within the sheet. 

Find and Replace Dialogue 

Let us see how to access the Find & Replace Dialogue. 

To access the Find & Replace, Choose Home → Find & Select → Find or press Control + 

F Key. 

 

You can see the Find and Replace dialogue as below. 
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You can replace the found text with the new text in the Replace tab. 

 

 

Inserting Data 

MS Excel cell can have Text, Numeric value or formulas. An MS Excel cell can have 

maximum of 32000 characters. 

For inserting data in MS Excel, just activate the cell type text or number and press enter 

or Navigation keys. 

 

Inserting Cells, Rows, Columns, Sheets 

To insert Cells 

To add a new individual cell to an Excel spreadsheet, follow the steps below: 

 

1. Select the cell of where you want to insert a new cell by clicking the cell once with 

the mouse. 

2. Right-click the cell of where you want to insert a new cell. 

3. In the right-click menu that appears, select Insert. 

4. Choose either Shift cells right or Shift cells down depending on how you want to 

affect the data around the cells. 
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To insert rows 

1. Select the row below where you want the new row to appear. 

 
 
 

2. Click the Insert command on the Home tab. 
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3. The new row appears in your worksheet. 

 

 

When inserting new rows, columns, or cells, can see the Insert Options button by the 

inserted cells. This button allows to choose how Excel formats them. By default, Excel 

formats inserted rows with the same formatting as the cells in the row above them. To 

access more options, however your mouse over the Insert Options button and click the 

drop-down arrow that appears. 

 

To insert columns 

1. Select the column to the right of where you want the new column to appear. 

For example, if you want to insert a column between A and B, select column 

B. 
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2. Click the Insert command on the Home tab. 

 
3. The new column appears in your worksheet. 

 

 

By default, Excel formats inserted columns with the same formatting as the column to 

the left of them. To access more options, hover your mouse over the Insert Options 

button and click the drop-down arrow that appears. 

 

To insert a new worksheet in front of an existing worksheet, select that worksheet and 

then, on the Home tab, in the Cells group, click Insert, and then click Insert Sheet. Tip: 

You can also right-click the tab of an existing worksheet, and then click Insert. On the 

General tab, click Worksheet, and then click OK. 
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Insert Sheets 

The default number of sheets that appears by clicking the Microsoft Office button and 

choosing Excel Options can be changed and also have the ability to insert new 

worksheets if needed while working. 

To insert a new worksheet: 

● Left-click the Insert Worksheet icon. A new sheet will appear. It will be named 

Sheet4, Sheet5, or whatever the next sequential sheet number may be in the 

workbook. 

 

● Press the Shift and the F11 keys on your keyboard. 

Insert Symbol 

You can easily insert a special character, fraction, or other symbol in your PowerPoint 

presentations and Excel workbooks. The most important thing to understand when 

inserting symbols, fractions, special characters, or international characters is that the 

font you use is critical. Not all fonts have the same characters in them. For example, the 

Elephant font has no fraction characters in it, while Verdana does. As a result it's 

important to use the right font to find the symbol or character you want. 

These marks are static symbols. If you're looking for an interactive check box that you 

can click on to check or uncheck, see: Add a check box or option button (Excel). 

Symbol such as currency (¥), music (♫), or check marks (✔) 

1. Place your cursor in the file at the spot where you want to insert the symbol. 

2. Go to Insert > Symbol. 

 
 

3. Pick a symbol, or choose More Symbols. 

4. Scroll up or down to find the symbol you want to insert.  Different font sets often 

have different symbols in them and the most commonly used symbols are in 

the Segoe UI Symbol font set. Use the Font selector above the symbol list to pick the 

font you want to browse through. 

https://support.microsoft.com/en-us/office/add-a-check-box-or-option-button-form-controls-9f201e46-8f6b-4a9d-a320-f44b28088cb0
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5. When you find the symbol you want, double-click it. The symbol will be inserted in 

your file. 

6. Select Close. 

How do I import data from an external source in Excel? 

Excel can import data from external data sources including other files, databases, or web 

pages. 

1. Click the Data tab on the Ribbon.. 

2. Click the Get Data button. ... 

3. Select From File. 

4. Select From Text/CSV. ... 

5. Select the file you want to import. 

6. Click Import. ... 

7. Verify the preview looks correct. ... 

8. Click Load. 
 

Insert Frames 

You can use a group box or a frame control to group related controls (such as option 

buttons, check boxes, or closely related contents) into one visual unit. Group boxes and 

frame controls are rectangular objects with optional labels. Use a group box or a frame 

control to visually organize related items on a form. 

Insert Clip Art 

1. Choose Insert Tab » Clip Art. 

2. Clicking Clip Art will open the search box as shown in the below screen-shot. Choose 

from the list of available Clip Arts. 

3. Click on Clip Art to Insert it in the worksheet. 
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Insert Pictures 

1. Go to the Insert tab. 

2. Click the Illustrations button. 

3. Select Picture and choose where the image should come from.  Typically, the image 

is located on your computer. If that‘s the case, select ‗From this device‘. 

4. Select the images you want to insert. 

5. Resize the image to fit the cell. 

 

 
 

Insert Files 

1. Click inside the cell of the spreadsheet where you want to insert the object. 

2. On the Insert tab, in the Text group, click Object Object icon on the ribbon. 

3. In the Object dialog box, click the Create from File tab. 

4. Click Browse, and select the file you want to insert. 

If you want to insert an icon into the spreadsheet instead of show the contents of the file, 

select the Display as icon check box. If you don‘t select any check boxes, Excel shows the 

first page of the file. In both cases, the complete file opens with a double click. Click OK. 
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Insert Functions in Excel 

1. Click the cell where you want to add a formula. 

2. Click the Insert Function button. 

3. Search for a function using one of these methods: Type a few keywords that describe 

the function you want and click Go.  

4. Select the desired function.  Click OK.  

5. Enter the formula arguments.  Click OK. 

Inserting Page Breaks 

Insert Horizontal Page Break − For example, if you want row 14 to be the first row of a 

new page, select cell A14. Then choose Page Layout » Page Setup Group » Breaks » Insert 

Page Break. 

 
 

Insert vertical Page break − In this case, make sure to place the pointer in row 1. Choose 

Page Setting Layout » Page Setup » Breaks » Insert Page Break to create the page break. 
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4.1.3 Setting Formula 

 

The Excel + Operator 

 A B 

1 = 2 + 7 + 1   

2     

3     

 

The simplest type of Excel addition formula is made up of the = sign, followed by two or 

more numbers, with the + operator in between them. 

For example, to add together the numbers 2, 7 and 1, type the following into any Excel 

cell: 

= 2 + 7 + 1 

which returns the result 10. 

 A B 

1 = B1 + B2 + B3 2 

2   7 

3   1 

 

As with all Excel formulas, instead of typing the numbers directly into your addition 

formula, you can use references to cells containing numbers. 

The Excel addition formula in cell A1 of the spreadsheet on the right adds together the 

contents of cells B1, B2 and B3 (which contain the values 2, 7 and 1). Again, the formula 

returns the value 10. 

The Excel Sum Function 

Instead of using the + operator, you can use the Excel Sum Function to perform addition 

in Excel. The syntax of this function is: 

=SUM( number1, [number2], ... ) 

where number1, [number2], etc. are one or more numbers (or references to cells 

containing numbers) that you want to add together. 

https://www.excelfunctions.net/excel-sum-function.html
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 A B 

1 =SUM( B1, B2, B3 ) 2 

2   7 

3   1 

 

An example of the Excel Sum function is shown in cell A1 of the spreadsheet on the right. 

In this example, the Sum function is used to add together the three values in cells B1, B2 

and B3 (i.e. the values 2, 7 and 1). Again, the function returns the value 10. 

Supplying a Range of Cells to the Sum Function 

You can also supply one or more ranges of cells to the Excel Sum function (rather than 

typing in each individual value or cell reference). 

For example, in the above example spreadsheet, in order to find the sum of the values in 

cells B1-B3, you could simply type the formula: 

=SUM( B1:B3 ) 

This is much quicker than typing multiple cell references, particularly if you have a large 

set of values that you want to add together. 

The Excel - Operator 

 A B 

1 = 11 - 2 - 5   

2     

3     

 

The simplest type of Excel subtraction formula consists of the = sign, followed by two or 

more numbers, with the - operator in between them. 

For example, to subtract the numbers 2 and 5 from 11, type the following into any Excel 

cell: 

= 11 - 2 - 5 

which returns the value 4. 
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 A B 

1 = B1 - B2 - B3 11 

2   2 

3   5 

 

As with all Excel formulas, instead of typing the numbers directly into your subtraction 

formula, you can use references to cells containing numbers. 

The Excel subtraction formula in cell A1 of the spreadsheet on the right subtracts the 

values in cells B2 and B3 (i.e. the values 2 and 5) from the value in cell B1 (i.e. the value 

11). 

Again, the formula returns the value 4. 

Using the Excel * Operator 

  A B 

1 = 4 * 3 * 10   

2     

3     

 

The simplest way to perform multiplication in Excel is to type in the = sign, followed by 

two or more numbers, separated by the * operator. 

For example, to multiply the numbers 4, 3 and 10, type the following into any Excel cell: 

= 4 * 3 * 10 

which returns the result 120. 

  A B 

1 

= B1 * B2 * 

B3 4 

2   3 

3   10 
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As with all Excel formulas, instead of typing numbers directly into the formula, you can 

use references to cells containing numbers in your multiplication formula. 

An example of how perform multiplication in Excel, using cell references, is shown in cell 

A1 of the above spreadsheet on the right. This formula multiplies the numbers in cells 

B1, B2 and B3 (i.e. the values 4, 3 and 10), and again, returns the value 120. 

 

Using the Excel Product Function 
 

Instead of using the * operator, as shown above, you can use the built-in Excel Product 

Function to perform a multiplication in Excel.  The syntax of the Excel Product function is: 

=PRODUCT( number1, [number2], ... ) 

where number1, [number2], etc. are one or more numeric values (or references to cells 

containing numeric values) that you want to multiply together. 

  A B 

1 =PRODUCT( B1, B2, B3 ) 4 

2   3 

3   10 

 

An example of the Excel Product function is shown in cell A1 of the spreadsheet on the 

right. 

In this example, the Product function is used to multiply the three values in cells B1, B2 

and B3 (i.e. the values 4, 3 and 10). 

Once again, the product of the three numbers is calculated to be 120. 

 

Supplying a Range of Cells to the Product Function 

You can also supply one or more ranges of cells to the Excel Product function (rather 

than typing in each individual value or cell reference). 

For example, in the above example spreadsheet, in order to find the product of the 

values in cells B1-B3, you could simply type the formula: 

=PRODUCT( B1:B3 ) 

This is much quicker than typing multiple cell references, particularly if you have a large 

set of values that you want to find the product of. 

https://www.excelfunctions.net/excel-product-function.html
https://www.excelfunctions.net/excel-product-function.html
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Using the Excel / Operator 

  A B 

1 = 15 / 4   

2     

3     

 

The simplest way to divide in Excel is to use the / operator. 

For example, to divide the number 15 by 4, type the following into any Excel cell: 

= 15 / 4 

which returns the result 3.75. 

As with all Excel formulas, instead of typing numbers directly into the division formula, 

you can use references to cells containing numeric values. 

  A B 

1 = B1 / B2 15 

2   4 

3     

 

An example of how to divide in Excel, using cell references, is shown in cell A1 of the 

spreadsheet on the right. This division formula divides the value in cell B1 (the number 

15) by the value in cell B2 (the number 4). 

Again, the formula returns the value 3.75. 

Exponentiation 

The Excel EXP function calculates the value of the mathematical constant e, raised to the 

power of a given number. 

The syntax of the function is:  

EXP(number) 

where the number argument is the real number that you want to raise e to the power of. 
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Using other Formulae 

AVERAGE 

The AVERAGE function should remind you of simple averages of data, such as the 

average number of shareholders in a given shareholding pool. 

=AVERAGE(number1, [number2], …) 

 

Example: 

=AVERAGE(B2:B11) – Shows a simple average, also similar to (SUM(B2:B11)/10) 
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COUNT 

The COUNT function counts all cells in a given range that contain only numeric values. 

=COUNT(value1, [value2], …) 

 

Example: 

COUNT(A:A) – Counts all values that are numerical in A column. However, you must 

adjust the range inside the formula to count rows. 

 

COUNT(A1:C1) – Now it can count rows. 

 

 
 

IF 

The IF function is often used when you want to sort your data according to a given logic. 

The best part of the IF formula is that you can embed formulas and functions in it. 

=IF(logical_test, [value_if_true], [value_if_false]) 
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Example: 

=IF(C2<D3,―TRUE‖,‖FALSE‖) – Checks if the value at C3 is less than the value at D3. If 

the logic is true, let the cell value be TRUE, otherwise, FALSE 

 

=IF(SUM(C1:C10) > SUM(D1:D10), SUM(C1:C10), SUM(D1:D10)) – An example of a 

complex IF statement. First, it sums C1 to C10 and D1 to D10, then it compares the sum. 

If the sum of C1 to C10 is greater than the sum of D1 to D10, then it makes the value of 

a cell equal to the sum of C1 to C10. 

 

TRIM 

The TRIM function makes sure your functions do not return errors due to extra spaces in 

your data. It ensures that all empty spaces are eliminated. Unlike other functions that 

can operate on a range of cells, TRIM only operates on a single cell. Therefore, it comes 

with the downside of adding duplicated data to your spreadsheet. 

=TRIM(text) 
 

Example: 

TRIM(A2) – Removes empty spaces in the value in cell A2. 

 

 
 

MAX & MIN 

The MAX and MIN functions help in finding the maximum number and the minimum 

number in a range of values. 

=MIN(number1, [number2], …) 
 

Example: 

=MIN(B2:C11) – Finds the minimum number between column B from B2 and column C 

from C2 to row 11 in both columns B and C. 
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=MAX(number1, [number2], …) 
 

Example: 

=MAX(B2:C11) – Similarly, it finds the maximum number between column B from B2 and 

column C from C2 to row 11 in both columns B and C. 

 

 
 

 
 

4.1.4 Formatting Spreadsheets 
 

Labelling of columns and rows 

To change the column headings to letters, select the File tab in the toolbar at the top of 

the screen and then click on Options at the bottom of the menu. When the Excel Options 

window appears, click on the Formulas option on the left. Then uncheck the option called 

"R1C1 reference style" and click on the OK button. 
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Formatting Cells 

In MS Excel, you can apply formatting to the cell or range of cells by Right Click » Format 

cells » Select the tab. Various tabs are available as shown below 

 

 

● Number − You can set the Format of the cell depending on the cell content. Find 

tutorial on this at MS Excel - Setting Cell Type. 

● Alignment − You can set the alignment of text on this tab. Find tutorial on this at MS 

Excel - Text Alignments. 

● Font − You can set the Font of text on this tab.  Find tutorial on this at MS Excel - 

Setting Fonts. 

● Border − You can set border of cell with this tab.  Find tutorial on this at MS Excel - 

Borders and Shades. 

● Fill − You can set fill of cell with this tab. Find tutorial on this at MS Excel - Borders 

and Shades. 

● Protection − You can set cell protection option with this tab. 

 

Formatting Row 

1. Select the row or rows that you want to change. 

2. On the Home tab, in the Cells group, click Format. 

 

 
3. Under Cell Size, click Row Height. 

4. In the Row height box, type the value that you want, and then click OK. 

https://www.tutorialspoint.com/excel/excel_setting_cell_type.htm
https://www.tutorialspoint.com/excel/excel_text_alignments.htm
https://www.tutorialspoint.com/excel/excel_text_alignments.htm
https://www.tutorialspoint.com/excel/excel_setting_fonts.htm
https://www.tutorialspoint.com/excel/excel_setting_fonts.htm
https://www.tutorialspoint.com/excel/excel_borders_and_shades.htm
https://www.tutorialspoint.com/excel/excel_borders_and_shades.htm
https://www.tutorialspoint.com/excel/excel_borders_and_shades.htm
https://www.tutorialspoint.com/excel/excel_borders_and_shades.htm
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Change the row height to fit the contents 

1. Select the row or rows that you want to change. 

2. On the Home tab, in the Cells group, click Format. 
 

 
 

 3. Under Cell Size, click AutoFit Row Height. 
 

Formatting Column 

1. Select the column or columns that you want to change. 

2. On the Home tab, in the Cells group, click Format. 

 

3. Under Cell Size, click Column Width. 

4. In the Column width box, type the value that you want. 

5. Click OK. 

Change the column width to automatically fit the contents (Autofit) 

1. Select the column or columns that you want to change. 

2. On the Home tab, in the Cells group, click Format. 

 

 
 

3. Under Cell Size, click AutoFit Column Width. 
 

Formatting Sheet 

● To change the default column width for a worksheet, click its sheet tab. 

● To change the default column width for the entire workbook, right-click a sheet tab, 

and then click Select All Sheets on the shortcut menu. 
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1. On the Home tab, in the Cells group, click Format. 

 

 
 

2. Under Cell Size, click Default Width. 

3. In the Standard column width box, type a new measurement, and then click OK. 

 

Category - Alignment 

1. Horizontal Alignment − You can set horizontal alignment to Left, Centre, Right, etc. 

● Left − Aligns the cell contents to the left side of the cell. 

● Center − Centers the cell contents in the cell. 

● Right − Aligns the cell contents to the right side of the cell. 

● Fill − Repeats the contents of the cell until the cell‘s width is filled. 

● Justify − Justifies the text to the left and right of the cell. This option is applicable 

only if the cell is formatted as wrapped text and uses more than one line. 

2. Vertical Alignment − You can set Vertical alignment to top, Middle, bottom, etc. 

● Top Aligns the cell contents to the top of the cell. 

● Center - Centers the cell contents vertically in the cell. 

● Bottom Aligns the cell contents to the bottom of the cell. 

● Justify Justifies the text vertically in the cell; this option is applicable only if the cell is 

formatted as wrapped text and uses more than one line. 

Font 

When you enter data in a worksheet, Excel automatically uses the Calibri font style in size 

11 but a different font style or size also can be changed 
 

 
 

● Select the cell or cell range that has the text or number you want to format. 

● Click the arrow next to Font and pick another font. 
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● To change font size, click the arrow next to the default Font Size and pick the size 

you want.  In our example below, we‘ve changed the font style to Century and size to 

9. 

 

 
 

Apply Borders 

MS Excel enables you to apply borders to the cells. For applying border, select the range 

of cells Right Click » Format cells » Border Tab » Select the Border Style. 
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Then you can apply border by Home Tab » Font group » Apply Borders. 

 
Apply Shading 

You can add shading to the cell from the Home tab » Font Group » Select the Color. 

 

 

Hiding / Locking Cell 

1. Select the column you want to protect. 

2. Press Ctrl+Shift+F. Excel displays the Format Cells dialog box. 

3. Make sure the Protection tab is displayed.  

4. The Protection tab of the Format Cells dialog box.  Make sure both the Locked and 

Hidden check boxes are selected. (It is the Hidden check box that controls whether 

the cell contents are visible in the formula bar or not.) 

5. Click OK to dismiss the dialog box. 

6. With the column still selected, display the Home tab of the ribbon. 

7. Starting in the Cells group, click Format | Hide & Unhide | Hide Columns. Excel hides 

the column. 
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8. Again, starting in the Cells group, click Format | Protect Sheet. Excel displays the 

Protect Sheet dialog box.  

9. Again, starting in the Cells group, click Format | Protect Sheet. Excel displays the 

Protect Sheet dialog box. (See Figure 2.) 

 

 

 

10. Enter a password to be used in protecting the worksheet. 

11. Using the check boxes, select what type of protection you want applied to the 

worksheet.  At a minimum you should choose Select Locked Cells and Select 

Unlocked Cells.  (These two options are selected by default in a worksheet.) 

12. Click OK to dismiss the dialog box. You are prompted to re-enter your password (the 

one from step 9), which you should do. 
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Anchoring Objects 

Anchoring is a Microsoft Excel feature that allows you to quickly copy formulas and apply 

them to cells of your choosing. Some formulas are assigned to specific cells, and 

anchoring allows you to assign the formula to multiple cells at once. 

Formatting Layout for Graphics, Clipart 

You can change the appearance of your picture or clip art to enhance its visual impact. 

The format tab offers you various options for formatting pictures like contrast, changing 

color, line style, cropping, etc. The steps to format picture or clip art are given below; 

● Select the picture or clip art that you want to format 

● Format tab appears in the Ribbon 

● Click the Format tab 

● It displays four groups of related commands to modify or format picture or clip art 

Apply cell borders 

1. Select the cell or range of cells that you want to add a border to. 

Tip:  

▪ To quickly select the whole worksheet, click the Select All button. 

▪  

2. On the Home tab, in the Font group, click the arrow next to Borders , and then 

click the border style that you want. 

 

Tip:  The Borders button displays the most recently used border style. You can click 

the Borders button (not the arrow) to apply that style. 

Change text color and alignment 

1. Select the cell or range of cells that contain (or will contain) the text that you want to 

format. You can also select one or more portions of the text within a cell and apply 

different text colors to those sections. 
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2. To change the color of text in the selected cells, on the Home tab, in the Font group, 

click the arrow next to Font Color , and then under Theme Colors or Standard 

Colors, click the color that you want to use. 

Note:  To apply a color other than the available theme colors and standard colors, 

click More Colors, and then define the color that you want to use on the Standard tab 

or Custom tab of the Colors dialog box. 

3. To change the alignment of the text in the selected cells, on the Home tab, in 

the Alignment group, click the alignment option that you want. 

 

For example, to change the horizontal alignment of cell contents, click Align Text 

Left , Center , or Align Text Right  

Apply cell shading 

1. Select the cell or range of cells that you want to apply cell shading to. 

2. On the Home tab, in the Font group, click the arrow next to Fill Color , and then 

under Theme Colors or Standard Colors, click the color that you want. 

Worksheet Row and Column Headers 

The column heading or column header used to identify each column in the worksheet. 

The column header is located above row 1 in the worksheet. The row heading or row 

header is the gray-colored column located to the left of column 1 in the worksheet 

containing the numbers (1, 2, 3, etc.) used to identify each row in the worksheet. Taken 

together, the column letters and the row numbers in the two headings create cell 

references which identify individual cells that are located at the intersection point 

between a column and row in a worksheet. 

To print the column and/or row headings for the current worksheet in Excel: 

1. Click Page Layout tab of the ribbon. 

2. Click on the Print checkbox in the Sheet Options group to activate the feature. 

 

https://www.lifewire.com/cell-references-relative-absolute-and-mixed-3123401
https://www.lifewire.com/cell-references-relative-absolute-and-mixed-3123401
https://www.lifewire.com/description-of-ribbon-3123973
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Follow these steps to print the column and row headings for a worksheet: 

 
Click the worksheet. If you want to do this for multiple worksheets, you 

can group them. 

 

 
On the Ribbon, click the Page Layout tab. 

 

 
In the Sheet Options group, under Headings, select the Print check box. 

 
Note: You can also click the small expansion icon , and then under Print, 

select the Row and column headings check box . 

To print the worksheet, press CTRL+P to open the Print dialog box, and then 

click OK. 

 

Turning Row and Column Headings on or off in Excel 

The row and column headings do not have to be displayed on a particular worksheet. 

Reasons for turning them off would be to improve the appearance of the worksheet or to 

gain extra screen space on large worksheets – possibly when taking screen captures. As 

with printing, the row and column headings must be turned on or off for each individual 

worksheet. To turn off the row and column headings in Excel: 

1. Click on the File menu to open the drop-down list. 

2. Click Options in the list to open the Excel Options dialog box. 

3. In the left-hand panel of the dialog box, click on Advanced. 

4. In the Display options for this worksheet section – located near the bottom of the 

right-hand pane of the dialog box – click on the checkbox next to the Show row and 

column headers option to remove the checkmark. 

https://support.microsoft.com/en-us/office/group-worksheets-4e1f7747-3d63-4fd7-8a36-838b05adc0f0
https://www.lifewire.com/dialog-box-dialog-box-launcher-3123860
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5. To turn off the row and column headings for additional worksheets in the current 

workbook, select the name of another worksheet from the drop-down box located 

next to the Display options for this worksheet heading and clear the checkmark in 

the Show row and column headers checkbox. 

6. Click OK to close the dialog box and return to the worksheet. 

Sheet Name 

By default, Excel names worksheets Sheet1, Sheet2, Sheet3 and so on, but you can 

easily rename them. 

 

3 ways to rename a worksheet 

● Double-click the sheet tab, and type the new name. 

● Right-click the sheet tab, click Rename, and type the new name. 

● Use the keyboard shortcut Alt+H > O > R, and type the new name. 

Working with columns, rows, and cells 
 

By default, every row and column of a new workbook is set to the same height and width. 

Excel allows you to modify column width and row height in different ways. 
 

To modify column width 
 

1. Position your mouse over the column line in the column heading so the white 

cross becomes a double arrow . 

 

 
 

2. Click and drag the column to the right to increase column width or to the left 

to decrease column width. 
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3. Release the mouse. The column width will be changed in your spreadsheet. 

 

 

If you see pound signs (#######) in a cell, it means the column is not wide enough to 

display the cell content. Simply increase the column width to show the cell content. 

To set column width with a specific measurement 

1. Select the columns you want to modify. 

2. Click the Format command on the Home tab. The format drop-down menu 

appears. 

3. Select Column Width. 

 
 

4. The Column Width dialog box appears. Enter a specific measurement. 

 

 
 

5. Click OK. The width of each selected column will be changed in your worksheet. 

 

Select AutoFit Column Width from the format drop-down menu, and Excel will 

automatically adjust each selected column so all of the text will fit. 
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To modify row height 

1. Position the cursor over the row line so the white cross becomes a double 

arrow . 

 

 
 

2. Click and drag the row downward to increase row height or upward to 

decrease height. 

 

 
 

3. Release the mouse. The height of each selected row will be changed in your 

worksheet. 

 

 

To set row height with a specific measurement 

1. Select the rows you want to modify. 

2. Click the Format command on the Home tab. The format drop-down menu 

appears. 

3. Select Row Height. 
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4. The Row Height dialog box appears. Enter a specific measurement. 

 

 
 

5. Click OK. The selected rows heights will be changed in your spreadsheet. 

 

Select AutoFit Row Height from the format drop-down menu, and Excel will automatically 

adjust each selected row so all of the text will fit. 

To insert rows 

1. Select the row below where you want the new row to appear. 
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2. Click the Insert command on the Home tab. 

 

 
 

3. The new row appears in your worksheet. 

 

 

When inserting new rows, columns, or cells, you will see the Insert Options button by 

the inserted cells. This button allows you to choose how Excel formats them. By default, 

Excel formats inserted rows with the same formatting as the cells in the row above them. 

To access more options, hover your mouse over the Insert Options button and click the 

drop-down arrow that appears. 

 



P a g e  | 239 

 

To insert columns 

1. Select the column to the right of where you want the new column to appear. 

For example, if you want to insert a column between A and B, select column 

B. 

 

 
 

2. Click the Insert command on the Home tab. 

 

 
 

3. The new column appears in your worksheet. 

 

 



P a g e  | 240 

 

By default, Excel formats inserted columns with the same formatting as the column to 

the left of them. To access more options, however your mouse over the Insert Options 

button and click the drop-down arrow that appears. 

 

When inserting rows and columns, make sure to select the row or column by clicking its 

heading so all of the cells in that row or column are selected. If you select just a cell in 

the row or column, only a new cell will be inserted. 

Visibility - Row, Column, Sheet, Security 

Hide / Unhide - Column / Row 

If the first row (row 1) or column (column A) is not displayed in the worksheet, it is a little 

tricky to unhide it because there is no easy way to select that row or column. You can 

select the entire worksheet, and then unhide rows or columns (Home tab, Cells group, 

Format button, Hide & Unhide command), but that displays all hidden rows and columns 

in your worksheet, which you may not want to do. Instead, you can use the Name box or 

the Go To command to select the first row and column. 

● To select the first hidden row or column on the worksheet, do one of the following: 

o In the Name Box next to the formula bar, type A1, and then press ENTER. 

 

 
 

○ On the Home tab, in the Editing group, click Find & Select, and then click 

Go To. In the Reference box, type A1, and then click OK. 

 

 
 

● On the Home tab, in the Cells group, click Format. 
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● Do one of the following: 

● Under Visibility, click Hide & Unhide, and then click Unhide Rows or Unhide Columns. 

● Under Cell Size, click Row Height or Column Width, and then in the Row Height or 

Column Width box, type the value that you want to use for the row height or column 

width. 

 

Sheet 

You can hide any worksheet to remove it from view. The data in hidden worksheets is not 

visible, but it can still be referenced from other worksheets and workbooks, and can 

easily unhide hidden worksheets as needed. 

 

1. Select the worksheets that you want to hide. 

2. On the Home tab, in the Cells group, click Format > Visibility > Hide & Unhide > Hide 

Sheet. 

 
To unhide worksheets, follow the same steps, but select Unhide. You'll be presented with 

a dialog box listing which sheets are hidden, so select the ones you want to unhide. 
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Security  

With sheet protection, you can control how a user can work within worksheets. You can 

specify what exactly a user can do within a sheet, thereby making sure that none of the 

important data in your worksheet are affected. For example, you might want a user to 

only add rows and columns, or only sort and use AutoFilter. Once sheet protection is 

enabled, you can protect other elements such as cells, ranges, formulas, and ActiveX or 

Form controls. To prevent other users from accidentally or deliberately changing, moving, 

or deleting data in a worksheet, you can lock the cells on your Excel worksheet and then 

protect the sheet with a password. Say you own the team status report worksheet, where 

you want team members to add data in specific cells only and not be able to modify 

anything else. With worksheet protection, you can make only certain parts of the sheet 

editable and users will not be able to modify data in any other region in the sheet. 

 

Sheet formatting and style 

 

A cell style is a defined set of formatting characteristics, such as fonts and font sizes, 

number formats, cell borders, and cell shading. To prevent anyone from making changes 

to specific cells, you can also use a cell style that locks cells. Excel has several 

predefined cell styles that you can apply. 

Sheet Background Color  

You can highlight data in cells by using Fill Color to add or change the background color 

or pattern of cells. Here's how: 

1. Select the cells you want to highlight. 

2. Click Home > the arrow next to Fill Color , or press Alt+H, H. 
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3. Under Theme Colors or Standard Colors, pick the color you want. 

 

To use a custom color, click More Colors, and then in the Colors dialog box select the 

color you want. 

To apply the most recently selected color, you can just click Fill Color . You'll also find 

up to 10 most recently selected custom colors under Recent Colors. 

Apply a pattern or fill effects 

When you want something more than a just a solid color fill, try applying a pattern or fill 

effects. 

1. Select the cell or range of cells you want to format. 

2. Click Home > Format Cells dialog launcher, or press Ctrl+Shift+F. 

 

3. On the Fill tab, under Background Color, pick the color you want. 
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4. To use a pattern with two colors, pick a color in the Pattern Color box, and then pick 

a pattern in the Pattern Style box. 

To use a pattern with special effects, click Fill Effects, and then pick the options you 

want. 

 

Borders and shading 

Applying Borders and Shading to Tables 

1. Select the cells, rows, or columns you want to format. 

To apply the borders and shading to an entire table, you can select the entire table or 

simply position the insertion point cursor inside the table without a selecting any 

rows, columns, or cells. 

2. Click Table from the menu bar and select Borders and Shading. 

3. Click the Borders tab. 

4. Select the line style. 

5. Select a line color from the Color drop-down menu. 

6. In the Border box, click Box to apply the border to all four sides. Or, click in the 

preview area to apply the border to selected sides. To remove a border from a side, 

click it again. You can apply different style borders to each side. 
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7. Click the Shading tab. 

8. Select the fill percent. 

9. Select the foreground color from the ForeGround drop-down menu. 

10. Select the background color from the Background drop-down menu. 

11. Click OK to apply the borders and shading settings. 

 

Shortcut Keys 

Close a workbook. Ctrl+W 

Open a workbook. Ctrl+O 

Go to the Home tab. Alt+H 

Save a workbook. Ctrl+S 

Copy selection. Ctrl+C 

Paste selection. Ctrl+V 

Undo recent action. Ctrl+Z 

Remove cell contents. Delete 

Choose a fill color. Alt+H, H 

Cut selection. Ctrl+X 

Go to the Insert tab. Alt+N 

Apply bold formatting. Ctrl+B 

Center align cell contents. Alt+H, A, C 

Go to the Page Layout tab. Alt+P 

Go to the Data tab. Alt+A 

Go to the View tab. Alt+W 

Open the context menu. 
Shift+F10 or 

Windows Menu key 

Add borders. Alt+H, B 

Delete column. Alt+H, D, C 

Go to the Formula tab. Alt+M 

Hide the selected rows. Ctrl+9 

Hide the selected columns. Ctrl+0 
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4.1.5 Working with Sheets 

Sorting in MS Excel 

1. Select a single cell in the column you want to sort. 

2. On the Data tab, in the Sort & Filter group, click. to perform an ascending sort (from 

A to Z, or smallest number to largest). 

3. Click. to perform a descending sort (from Z to A, or largest number to smallest). 

Sorting data in MS Excel rearranges the rows based on the contents of a particular 

column.  You may want to sort a table to put names in alphabetical order. Or, maybe you 

want to sort data by Amount from smallest to largest or largest to smallest. 

To Sort the data follow the steps mentioned below: 

● Select the Column by which you want to sort data. 

● Choose Data Tab » Sort Below dialog appears. 

● If you want to sort data based on a selected column, Choose Continue with the 

selection or if you want sorting based on other columns, choose Expand Selection. 
 

 

 

● You can Sort based on the below Conditions. 

o Values − Alphabetically or numerically. 

o Cell Color − Based on Color of Cell. 

o Font Color − Based on Font color. 

o Cell Icon − Based on Cell Icon 
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● Clicking Ok will sort the data. 

 

Sorting option is also available from the Home Tab. Choose Home Tab » Sort & Filter. You 

can see the same dialog to sort records. 

 

 

Filtering in MS Excel 

Filtering data in MS Excel refers to displaying only the rows that meet certain conditions. 

(The other rows gets hidden.) 

Using the store data, if you are interested in seeing data where Shoe Size is 36, then you 

can set filter to do this. Follow the below mentioned steps to do this. 

● Place a cursor on the Header Row. 

● Choose Data Tab » Filter to set filter. 
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● Click the drop-down arrow in the Area Row Header and remove the check mark from 

Select All, which unselects everything. 

● Then select the check mark for Size 36 which will filter the data and displays data of 

Shoe Size 36. 
 

 

● Some of the row numbers are missing; these rows contain the filtered (hidden) data. 

● There is drop-down arrow in the Area column now shows a different graphic — an 

icon that indicates the column is filtered. 

 

 

 

Data Validation 

MS Excel data validation feature allows you to set up certain rules that dictate what can 

be entered into a cell. For example, you may want to limit data entry in a particular cell to 

whole numbers between 0 and 10. If the user makes an invalid entry, you can display a 

custom message as shown below. 
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Validation Criteria 

To specify the type of data allowable in a cell or range, follow the steps below, which 

shows all the three tabs of the Data Validation dialog box. 

● Select the cell or range. 

● Choose Data » Data Tools » Data Validation. Excel displays its Data Validation dialog 

box having 3 tabs settings, Input Message and Error alert. 

 

Consolidate data in Excel 

Data consolidation is a very interesting and useful feature of Excel. It helps the user to 

gather the data together from different worksheets and collect them in a master 

workbook. In this way, it allows the users to take the data together. Data in a single table 

is easy to update. 

Consolidate is an Excel function that let the users to collect the data from different 

locations and summarize it into one Excel table. The main trouble with the data 

consolidation method is that it is a bit tricky to work with data consolidation.  

Creating subtotals  

The Subtotal command allows you to automatically create groups and use common 

functions like SUM, COUNT, and AVERAGE to help summarize your data.  
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Data must be correctly sorted before using the Subtotal command, so you may want to 

review our lesson on Sorting Data to learn more. 

To create a subtotal: 

1. First, sort your worksheet by the data you want to subtotal.  

 

2. Select the Data tab, then click the Subtotal command. 

 

 

 

3. The Subtotal dialog box will appear. Click the drop-down arrow for the At each 

change in: field to select the column you want to subtotal.  

4. Click the drop-down arrow for the Use function: field to select the function you want 

to use.  

 

http://www.gcflearnfree.org/excel/sorting-data/1/
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5. In the Add subtotal to: field, select the column where you want the calculated 

subtotal to appear. click OK. 

 

6. The worksheet will be outlined into groups, and the subtotal will be listed below 

each group.  

 

4.1.6 Creating Charts (Drawing Charts)  

 

Creating Charts with Insert Chart 

To create charts using the Insert Chart tab, follow the steps given below. 

Step 1 − Select the data. 

Step 2 − Click the Insert tab on the Ribbon. 

Step 3 − Click the Insert Column Chart on the Ribbon. 
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The 2-D column, 3-D Column chart options are displayed. Further, More Column Charts… 

option is also displayed. 

 

Step 4 − Move through the Column Chart options to see the previews. 

Step 5 − Click Clustered Column. The chart will be displayed in your worksheet. 
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Step 6 − Give a meaningful title to the chart by editing Chart Title. 

 

 

4.1.7 Printing 

To print a worksheet in Excel, execute the following steps. 

1. On the File tab, click Print. 

2. To preview the other pages that will be printed, click 'Next Page' or 'Previous Page' at 

the bottom of the window. 
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4.1.8 Using Tools 

 

Errors checking  

Errors are quite common. You will not find a single person who does not make any errors 

in Excel. When the errors are part and parcel of Excel, one must know how to find those 

errors and resolve those issues. 

When using Excel routinely, we may encounter many errors flagged if the error handler is 

enabled. Otherwise, we may get potential calculation errors. So if you are new to error 

handling in Excel, this article is a perfect guide for you. 

 

Spell Check Basis 

Let us see how to access the spell check 

● To access the spell checker, Choose Review ➪ Spelling or press F7. 

● To check the spelling in just a particular range, select the range before you activate 

the spell checker. 

● If the spell checker finds any words it does not recognize as correct, it displays the 

Spelling dialogue with suggested options. 
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Exploring Options 

Let us see the various options available in spell check dialogue. 

● Ignore Once − Ignores the word and continues the spell check. 

● Ignore All − Ignores the word and all subsequent occurrences of it. 

● Add to Dictionary − Adds the word to the dictionary. 

● Change − Changes the word to the selected word in the Suggestions list. 

● Change All − Changes the word to the selected word in the Suggestions list and 

changes all subsequent occurrences of it without asking. 

● AutoCorrect − Adds the misspelled word and its correct spelling (which you select 

from the list) to the AutoCorrect list. 

 

Formula Auditing  

The formula function in Excel is one of the most useful things any business owner or 

employee can use, especially when large volumes of data need to be evaluated. 

Sometimes you are given completed worksheets that you need to do extra analysis on. It 

is sometimes difficult to see where all of the functions in the file are and where they are 

coming from. When this happens, knowing how to use the Formula Audit toolbar is 

essential. 

 

Formula Audits can be done several different ways. If you click on the Excel ribbon tab 

called Formulas, you can see the section labeled Formula Auditing. You may have to 

customize the ribbon to see this option. Below are the various ways that you can audit a 

formula. 

Creating & Using Templates in MS Excel 

Template is essentially a model that serves as the basis for something. An Excel template 

is a workbook that‘s used to create other workbooks. 

Viewing Available Templates 

To view the Excel templates, choose File » New to display the available templates screen 

in Backstage View. You can select a template stored on your hard drive, or a template 

from Microsoft Office Online. If you choose a template from Microsoft Office Online, you 

must be connected to the Internet to download it. The Office Online Templates section 

contains a number of icons, which represents various categories of templates. Click an 

icon, and you‘ll see the available templates. When you select a template thumbnail, you 

can see a preview in the right panel. 
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Pivot table 

A PivotTable is a powerful tool to calculate, summarize, and analyze data that lets you 

see comparisons, patterns, and trends in your data. PivotTables work a little bit 

differently depending on what platform you are using to run Excel. 

Steps to Create Pivot table 

1. Select the cells you want to create a PivotTable from. 

Note:  Your data should be organized in columns with a single header row. 

2. Select Insert > PivotTable. 

 
 

3. This will create a PivotTable based on an existing table or range. 
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4. Choose where you want the PivotTable report to be placed. Select New Worksheet to 

place the PivotTable in a new worksheet or Existing Worksheet and select where you 

want the new PivotTable to appear.  

5. Click OK 

 

Tracking Changes 

When you highlight changes as you work, Excel marks any revisions (such as changes, 

insertions, and deletions) with a highlighting color. 

● Click Review > Track Changes, and then click Highlight Changes. 

● In the Highlight Changes dialog box, select the Track changes while editing check 

box. 

 

Security 

To prevent others from accessing data in your Excel files, protect your Excel file with a 

password. 

1. Select File > Info. 

2. Select the Protect Workbook box and choose Encrypt with Password. 

3. Enter a password in the Password box, and then select OK. 

4. Confirm the password in the Reenter Password box, and then select OK. 
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Customization 
 

● In the right part of the Customize the Ribbon window, select the tab to which you'd like 

to add a new group. 

● Click the New Group button. 

● To rename your custom group, select it, click the Rename 

● Click OK to save and view your changes. 

4.2 Open Office - Calc 

4.2.1 Introduction 

4.2.1.1 Introduction to Spreadsheets 
 

Calc is the spreadsheet component of OpenOffice.org (OOo). You can enter data, usually 

numerical data, in a spreadsheet and then manipulate this data to produce certain 

results. Alternatively you can enter data and then use Calc in a ‗What If...‘ manner by 

changing some of the data and observing the results without having to retype the entire 

workbook or sheet. A major advantage of electronic spreadsheets is that the data is 

easier to alter. If the correct functions and formulas have been used, the program will 

apply these changes automatically. 

4.2.1.2 Overview of a Worksheet 
 

Calc works with elements called workbooks. Workbooks consist of a number of individual 

worksheets, each containing a block of cells arranged in rows and columns. These cells 

hold the individual elements; text, numbers, formulas etc., which make up the data to be 

displayed and manipulated. Each workbook can have many worksheets and each 

worksheet can have many individual cells.  

 

1. Title Bar 

At the top of the window is the ―Title Bar‖. It is used to show the name of the file and 

name of the application. In OpenOffice calc, the default name for the first unsaved 

worksheet is ―Untitled1‖. When you save the file, Untitled will change to the name in 

which you saved. 

2. Control Buttons 

 In the right corner of title bar, (1) minimize, (2) maximize / restore and (3) close control 

buttons are available. 

 3. Menu Bar 

Below the title bar is the menu bar. Most of the menus are very similar to what you learnt 

in OpenOffice Writer. 
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File - menu contains the commands of all file management tasks like, Create a new file, 

Open an existing file, Close the current file, Save a file, Save a file in another name, print 

file, Export file etc. 

Edit - menu contains the editing commands like, cut, copy, paste, Undo, Redo, Fill etc., 

Most of the menu items are similar to Writer Edit menu. But, for Calc, some special 

editing options are available under this menu. 

View - menu contains the commands which are used to modify the environment of calc. 

Insert – menu contains commands for inserting various calc elements such as cells, 

columns, rows, functions, charts etc., 

Format – menu contains the commands of various text and cell formatting features. 

Tools – menu contains various tools and functions such as spell check, protect 

document, insert pictures, macros, etc., 

Data – menu contains the commands to manipulate data in a spreadsheet such as sort, 

filter, subtotal, validity etc., 

Window – menu shows display options such as New Window, Close Windows, Split and 

Freeze. 

Help – menu lists in-built help features available with OpenOffice. 

 

4. Tools Bar 

Under the menu bar, there are three toolbars available by default. They are: 

(1) Standard Toolbar 

(2) Formatting Toolbar 

(3) Formula bar 
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Standard Toolbar – contains frequently used menu such as File, Edit, Data etc., 

commands as icons such as New Open Save, Send, Print, Print Preview, Cut, Copy, Paste, 

Sorting, Inserting chart etc., 

Formatting Toolbar – contains frequently used text and cell formatting commands as 

such as changing font style, font size, font colour, alignments, cell formatting etc., 

Formula bar – This is a very important element in a spreadsheet. It contains Name box, 

Function Wizard, Sum button, Function button and Input line (Refer Figure 9.4). 

 
 

Name box : It display the current cell address 

Function Wizard : It is used to insert function 

Sum button : It is used to quickly insert sum function. 

Input Line : This is used to show the contents of the current cell. It always shows actually 

what you typed in a cell. It is also used to edit the contents. 

5. Scroll bar 

Spreadsheet window also has two sets of scroll bars (1) Vertical Scrollbar and (2) 

Horizontal Scrollbar (Refer Figure 9.5) 

Vertical Scroll bar: It is used to move the screen up and down. 

Horizontal Scroll bar: It is used move the screen left and right. 

Scroll buttons: used to move the screen to the relative distance. 
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6. Row, Column, Cell and Cell Pointer 

Below the formula bar contains the worksheet of work area which consit of grid cells The 

worksheet has number of rows and columns, where each column is labelled as A, B, C, D 

….. AA, AB, AC ….. and the rows are numbered from 1, 2, 3 ….  

 
Cell 

Intersection of each row and column makes a box which is called as ―Cell‖. Each cell has 

a unique address. 

Cell address is the combination of column heading and row number. For example, the 

intersection of column B and row 4 makes a cell B4. (Figure 9.7) . Every cell is thus 

identified by its unique cell address. 

 

7. Worksheet tabs 

 

At the bottom of the grid of cells are the sheet tabs. By default there are 3 sheets 

―Sheet1‖, ―Sheet2‖ and ―Sheet3‖,  When you open a new worksheet, sheet1 is the 

default active sheet. Active sheet tab will appear in white colour. If you click on another 

sheet, it will become active and its colour will turn white. Multiple sheets can also be 
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selected by clicking the sheet and press the Ctrl button (Ctrl + Click). Selected sheets will 

turn to white colour. 

8. Status bar 

Below the sheet tabs and horizontal scrolling bar is the ―Status Bar‖. It shows the current 

status of the worksheet. 

Sheets count: Displays current serial number of the sheet / total number of sheets 

available. 

Page Style: Displays the page style of the current sheet. To make changes, just double- 

click on ―Default‖ and it will show you the ―Page Style‖ dialog box, which is used to 

change the margin, orientation, paper size, inserting header, footer, border style etc., 

Selection Mode: Displays the selection mode of the current sheet. There are three modes 

available to select the cells of a worksheet. They are, Standard (STD), Extend (EXT) and 

Add (ADD). 

Unsaved Changes: An asterisk ( * ) symbol indicates the changes made in the worksheet 

but not yet saved. If you have saved your changes, it will disappear. 

 

4.2.1.3 Creating Worksheet and Workbooks 
 

A single page in a file prepared with an electronic spreadsheet tool is referred to as a 

worksheet. A Calc file with one or more worksheets is referred to as a workbook. 

To create a new workbook and worksheet 

● Start�All programs�openoffice�calc or double click on the openoffice icon on 

the desktop and select the spread sheet 
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A worksheet is a grid of cells 

 

 

4.2.1.4 Organizing files, Managing files and workbooks 

 

Saving Worksheet 

The process of saving a worksheet is very similar to saving a document. Steps to save a 

worksheet are as follows: 

Step 1: File → Save (or) Ctrl + S (or) Click ―Save‖ icon on the standard tool bar. 

Step 2: If the spreadsheet has not been saved previously, the Save As dialog box 

will appear. 

Step 3: Type the name in ―File Name‖ list box. OpenOffice Calc Spreadsheets are 

stored with extension .ods by default. 

Step 4: Click ―Save‖ button. 
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After clicking the save button, the given file name is displayed in the title bar  

 

Closing a Worksheet 

After saving the worksheet; it remains open. So, you can continue to working with the 

spreadsheet. When the work is finished, you should save using File → Save (or) 

Click ―Save‖ icon (or) Ctrl+S and then to close the 

worksheet using File → Close command (or) Press Ctrl + W. 

Opening an existing worksheet 

1. Using Open dialog box 

To reopen an existing worksheet, the File → Open command (or) ―Open‖ icon (or) Ctrl + 

O can be used. An Open dialog box appears that is similar to ―Save As‖ dialog box. 

The name of the file to be opened can be chosen from the list or folder in which 

worksheet has been saved. 
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2. Using Recent documents 

OpenOffice keeps a list of recently opened files. File → Recent Documents option can be 

used to open an existing worksheet from the list 

 

4.2.1.5 Functions & Formulas 

Creating Formulae 

Operators 

Operators are symbols for doing some mathematical, statistical and logical calculations. 

Combination of values, operators and cell references is called as ―Expression‖. Calc 

supports a variety of operators which are categorized as: 

 1. Arithmetic Operators 

Arithmetic operators are symbols for performing simple arithmetic operations such as 

addition, subtraction, multiplication, division etc., These operators return a numerical 

result. 

 

 2. Relational Operators 

Relational operators are symbols used for comparing two values such as greater than, 

less than, equal to etc. The relational operators are also called as "Comparative 

operators". These operators return either a True or a False. 
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 3. Range Reference Operator 

Colon (:) is the range reference operator. It is used to group a range of cells. An 

expression using a range operator has the following syntax: 

reference left : reference right 

where reference left is the starting cell address of a linear group of cells or upper left 

corner address of a rectangular group Reference right is the last cell address of a linear 

group or lower right corner address of a rectangular group of cell. 

4. Text Operator  

In Calc, ―&‖ is a text operator which is used to combine two or more text. Joining two 

different texts is also known as ―Text Concatenation‖ (Refer Figure 9.21). An expression 

using the text operator has the following syntax: 

text reference1 & text reference2 
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When arithmetic operators are used in a formula, Calc calculates the results using the 

rule of precedence followed in Mathematics. The order is: 

I. Exponentiation ( ^ ) 

II. Negation ( - ) 

III. Multiplication and Division ( *, /) 

IV. Addition and Subtraction (+, -) 

Construction of formula 

To construct a formula, follow the steps below: 

● Cell pointer should be in the cell in which you want to display the result. 

● Formula should begin with an = sign. 

● In a formula, use only cell reference (cell address) instead of the actual values 

within the cells. 

● While constructing a formula, BODMAS rule should be kept in mind. 

Functions 

● Enter the data and select a cell 

● Click the Insert menu � Functions or Ctrl + F2. The ‗ Insert Function ‗ dialog box 

appears 

● Select a Function from a Category  

● Select the range  A1:B1 in the function arguments 

● Click OK 
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4.2.1.6 Working with Multiple Sheets 
 

To insert a new worksheet 

● Click Insert menu � Sheet, Insert Sheet dialog box appears 

● Select the options  for  position and sheet or file 

● Click OK 

 

To copy or move a worksheet 

● Right click on the worksheet you want to copy/move 

● Select Move/Copy sheet option 

● In the dialog box, choose where the sheet will appear in the Insert Before 

● If you want to copy , check the box, copy and click OK 
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To rename a worksheet 

● Right-click the worksheet you want to rename 

● Then select rename sheet option 

● In the appearing dialog box type the name and click ok. 

 

 

 

 

To delete a worksheet 

● Right click on the worksheet to be deleted 

● Then select Delete Sheet option, and then select yes. 
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4.2.1.7 Creating Charts & Printing Charts 
 

● Open OpenOffice Calc and enter data 

● Click the Insert menu � Chart 

● Cart and Chart wizard will appear 

● Choose Chart type (Column, Bar , Pie,…) Click Next 

● Select the data range, then click Next 

● Customise the Data range 

● Add chart title , x-axis, y-axis 

● Choose Left/Right/Top/Bottom from Display Legend Radio Button 

● Then Click Finish Button 

 

Printing Chart 

● Select format�Page from the main menu 

● Select the sheet tab 

● Specify which details to print 

● Click charts check box, then click ok button 

● Then click File Menu�Print 
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4.2.1.8 Operating with MS excel documents, which are already created and saved in MS Excel 

● Launch OpenOffice Calc and open the Excel sheet you want to transfer to the 

OpenOffice format.  

● Click "File" at the top of the Calc window, followed by "Save As" from the menu to 

open the Save As dialog box. 

● Select "ODF Template" in the "Save As Type" drop-down menu. 

● Click "Save" to transfer the Excel worksheet to the OpenOffice format. 

 

***** 
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Introduction to MS Office – MS Access and Open Office - Base 

5.1 MS Office - MS Access 

5.1.1 Introduction 

 

Microsoft Access is a database management system that enables to store, retrieve, sort, 

summarize and report results speedily and effectively. It can combine data from various 

files through creating relationships, and can make data entry more efficient and 

accurate. 

A database is a collection of data that is stored in a computer system. Databases in 

Access 2010 are composed of four objects: tables, queries, forms, and reports. Together, 

these objects allows to enter, store, analyze, and compile the data however needed. 

 

Tables 

All data are stored in tables. Tables are organized into vertical columns and horizontal 

rows. 
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Queries  

Queries are a way of searching for and compiling data from one or more tables. 

 

Forms 

The reason forms are used so often is that they are an easy way to guide people into 

entering data correctly. 

 

 

Reports 

Reports offer the ability to present the data in print, the ability to create a report from 

any table or query. 
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5.1.2 Planning a database 

 

Database planning means the software is capable of managing and consolidating all the 

data generated. 

A properly designed database provides  access to up-to-date, accurate information.  

Because a correct design is essential to achieving the goals in working with a database.  

The design process consists of the following steps: 

▪ Determine the purpose of database     

This helps to prepare for the remaining steps. 

▪ Find and organize the information required      

Gather all of the types of information you might want to record in the database, such as 

product name and order number. 

▪ Divide the information into tables     

Divide your information items into major entities or subjects, such as Products or Orders. 

Each subject then becomes a table. 

▪ Turn information items into columns     

Decide what information you want to store in each table. Each item becomes a field, and 

is displayed as a column in the table. For example, an Employees table might include 

fields such as Last Name and Hire Date. 

▪ Specify primary keys     

Choose each table‘s primary key. The primary key is a column that is used to uniquely 

identify each row. An example might be Product ID or Order ID. 

▪ Set up the table relationships     

Look at each table and decide how the data in one table is related to the data in other 

tables. Add fields to tables or create new tables to clarify the relationships, as necessary. 

▪ Refine your design     

Analyze design for errors. Create the tables and add a few records of sample data. See if 

you can get the results you want from your tables. Make adjustments to the design, as 

needed. 

▪ Apply the normalization rules     

Apply the data normalization rules to see if your tables are structured correctly. Make 

adjustments to the tables, as needed. 
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5.1.3 Starting Access 

 

When you start Access 2010, you see the Microsoft Office Backstage view, where you 

can get information about the current database, create a new database, open an existing 

database, and view featured content from Office.com. 

 

 

Backstage view also contains many other commands that you can use to adjust, 

maintain, or share your databases. Commands in Backstage view generally apply to 

entire databases, not to objects inside  a database. You can get to Backstage view at any 

time by clicking the File tab.  

5.1.4 Access Screen 

 

Access environment, includes the Ribbon, Backstage view, Navigation pane, Document 

Tabs bar and Record Navigation bar.  
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5.1.5 Creating a New Database 

 

To create a new database, do the following 

1. Start Access. 

2. On the New tab in Backstage view, click Blank Database. 

3. On the right, type a name for your database in the File Name box. 

To change the location in which you create the file, click Browse next to the File 

Name box, browse to and select the new location, and then click OK. 

4. Click Create. 

5.1.6 Creating Tables 

 

Create a new table in a new database 

1. Click File > New, and then select Blank desktop database. 

2. In the File Name box, type a file name for the new database. 

3. To browse to a different location and save the database, click the folder icon. 

4. Click Create. 

The new database opens, and a new table named Table1 is created and opens in 

Datasheet view. 

Create a new table in an existing database 

1. Click File > Open, and click the database if it is listed under Recent. If not, select 

one of  the browse options to locate the database. 

2. In the Open dialog box, select the database that you want to open, and then 

click Open. 

3. On the Create tab, in the Tables group, click Table. 

A new table is inserted in the database and the table opens in Datasheet view. 

Add a field by entering data 

When you create a new table or open an existing table in Datasheet view, you can add a 

field to the table by entering data in the Add New Field column of the datasheet . Access 

automatically assigns a data type for the field, based on the value that you enter. If no 

other data type is implied by your input, Access sets the data type to Text but you can 

change the data type. 
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To enter data in the Add New Field column 

1. Create or open a table in Datasheet view by right-clicking the table that you want 

in the  Navigation Pane and then clicking Datasheet view from the shortcut menu. 

2. In the Add New Field column, enter the name of the field that you want to create.  

Use a  descriptive name so that the field will be easier to identify. 

3. Enter data in the new field. 

5.1.7 Working with Forms 

 

Start the Form Wizard 

1. On the Create tab, in the Forms group, click Form Wizard.  

2. Follow the directions on the pages of the Form Wizard. 

3. On the last page of the wizard, click Finish. 

1. On the Create tab in the Forms group, click Form Wizard. The wizard starts. 
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2. From the Tables/Queries drop-down list, select the table (or query) to base the 

form on. The fields for the selected table load in the Available Fields list box. 

 

3. Move the fields to include on the form from the Available Fields list box to 

the Selected Fields list box. To do so, double-click a field name to move it or 

highlight the field name and click >. To move all fields at once, click >>. 

 

4. Click Next > 
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5. Select the layout for the form. Your options are "Columnar", "Tabular", 

"Datasheet", and "Justified". 
 

6. Click Next >. 
 

7. Enter a title for the form. 
 

8. Select an option for the view you want to open the form in. Your options are: 
 

 

 

Open the form to view or enter information (opens in Form view). 
 

Modify the form's design (opens in Design view). 
 

9. Click Finish. The form loads in the view you selected. 
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5.1.8 Creating Queries 
 

Create a select query 

Create a query to focus on specific data. 

 

1. Select Create > Query Wizard . 

2. Select Simple Query and then OK. 

3. Select the table that contains the field, add the Available Fields, you want 

to Selected Fields, and select Next. 

4. Choose whether you want to open the query in Datasheet view or modify the 

query in Design view, and then select Finish. 
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1. If you did not add any number fields (fields that contain numeric data), skip ahead 

to step 6. If you added any number fields, the wizard asks whether you want the 

query to return details or summary data. 

 Do one of the following: 

a. If you want to see individual records, click Detail, and then click Next. Skip ahead 

to step 6. 

b. If you want to see summarized numeric data, such as averages, click Summary, 

and then click Summary Options. 

 

 

2. In the Summary Options dialog box, specify which fields you want to summarize, and 

how you want to summarize the data. Only number fields are listed. 
 

For each number field, choose one of the following functions: 
 

a. Sum    The query returns the sum of all the values of the field. 

b. Avg    The query returns the average of the values of the field. 

c. Min    The query returns the smallest value of the field. 

d. Max    The query returns the largest value of the field. 
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3. If you want the query results to include a count of the records in a data source, select 

the appropriate Count records in data source name check box. 
 

4. Click OK to close the Summary Options dialog box. 
 

5. If you did not add a date/time field to the query, skip ahead to step 6. If you added a 

date-time field to the query, the Query Wizard asks you how you would like to group 

the date values. For example, suppose you added a number field ("Price") and a 

date/time field ("Transaction_Time") to your query, and then specified in 

the Summary Options dialog box that you want to see the average value of the 

number field "Price". Because you included a date/time field, you could calculate 

summary values for each unique date/time value, for each day, for each month, for 

each quarter, or for each year. 
 

 

Select the time period that you want to use to group the date/time values, and then 

click Next. 

 

6. On the last page of the wizard, give the query a title, specify whether you want to 

open or modify the query, and then click Finish. 

 

If you choose to open the query, the query displays the selected data in Datasheet view. 

If you choose to modify the query, the query opens in Design view. 

 
Create a query by working in Design view 

1. On the Create tab, in the Other group, click Query Design.  

 

2. Double-click each data source that you want to use or select each data source 

and then click Add. 
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Add a join 

▪ To add a join, drag a field from one data source to a corresponding field on 

another data  source. Access displays a line between the two fields to show that a join 

has been created. 

 

Change a join 
 

1. Double-click the join you want to change. 

The Join Properties dialog box appears. 
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2. In the Join Properties dialog box, review the three options. 
 

3. Click the option that you want to use, and then click OK. 

After the joins are ready, you add output fields — fields that have data that you want in 

the query results. 

To add a field, drag the field from a data source in the upper pane of the query design 

window down to the Field row of the design grid, in the bottom pane of the query design 

window. 

When you add a field this way, Access automatically fills in the Table row of the design 

grid to reflect the data source of the field. 

Summarize data 

This step is optional. 

You might want to summarize data, especially if your data is numeric. For example, you 

might want to see the average price, or total sales. 

To summarize data in a query, you use the Total row. By default, the Total row is not 

displayed in Design view. 

1. With the query open in Design view, on the Design tab, in the Show/Hide group, 

click Totals. 

Access displays the Total row in the query design grid. 

2. For each field that you want to summarize, choose the function to use from the 

list in the Total row. The functions that are available depend on the data type of the field. 

View the results 

To see the query results, on the Design tab, click Run. Access displays the results of your 

query in Datasheet view. 

To make further changes to the query, click Home > View > Design View to switch back to 

Design view. 

Change your fields, expressions, or criteria and rerun the query until it returns the data 

that you want. 

5.1.9 Finding Information in Databases 

When you enter text in the Search box, the first matching value is highlighted in real time 

as you enter each character. You can use this feature to quickly search for a record with 

a matching value. 

You can also search for a specific record in a table or form by using the Find option. 
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This is an effective choice for locating a specific record when the record that you want to 

locate satisfies specific criteria, such as search terms, and comparison operators, such 

as "equals" or "contains". 

1. Open the table or form, and then click the field that you want to search. 

2. On the Home tab, in the Find group, click Find. 

5.1.10 Creating Reports 

1. On the Create tab in the Reports group, click Report Wizard. The wizard starts. 

 

2. From the Tables/Queries drop-down list, select the table (or query) to base the 

report on. The fields for the selected table load in the Available Fields list box. 

3. Move the fields to include on the report from the Available Fields list box to 

the Selected Fields list box. To do so, double-click a field name to move it or 

highlight the field name and click >. To move all fields at once, click >>. 
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4. Click Next 

.  

 

5. To group records on the report by a particular field, highlight the field in the list 

box and click >. 
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6. Add more grouping levels if desired. You can use the arrows to change the order 

of the grouping levels if needed. 

 

7. When you finish defining how you want records grouped, click Next >. 

 

8. In the first drop-down list, select the field to sort records by. By default, records 

will be sorted in ascending order by the field you select. If you want to sort in 

descending order, click the Ascending button to change its label to "Descending". 
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9. You can specify up to four levels of sorting. When you finish specifying sorting 

options, click Next >. 

 

10. In the Layout field, select the format of the report. Your options are "Stepped", 

"Block", and "Outline".  
 

11. In the Orientation field, select whether to lay out the report in portrait or 

landscape mode. 
 

12. If you want all fields to fit on a single page, ensure the Adjust the field width so all 

fields fit on a page check box is marked. 
 

13. Click Next >. 
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14. Enter a title for the report. 
 

15. Select an option for the view you want to open the report in. Your options are: 

● Preview the report (opens in Print Preview mode). 

● Modify the report's design (opens in Design view). 
 

16. Click Finish. The report loads in the view you selected. 

 

 

 
 

 

Once the wizard has done its job, future changes to the Sorting and Grouping are made 

in the Group, Sort, and Total area: Design > Group & Sort. You may change the order of, 

remove, or edit any existing items. You may also add a group and a sort as well. 
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5.1.11 Types of Reports 

● Columnar 

● Tabular 

● justified 
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5.1.12 Printing and Print Preview  

Use the Print Preview option to check how the printed version of your report will appear. 

You can open a report in Print Preview by using one of the following methods: 

▪ To preview a report that is not already open, in the Navigation Pane, right-click the 

report that you want to preview, and then click Print Preview. 

Or  

▪ Click File > Print, and then click Print Preview. 

or 

▪ If the report is open, right-click the document tab for the report, and then 

click Print Preview. 

Print a report 

1. In the Navigation Pane, select the report that you want to print. 

2. Click File and then click Print. 

3. On the Print area of the File options, click the Print option to open the Print dialog 

box. 

4. Change the page format setup or other print options or printer selection as 

needed, and  then click OK to print your report. 

5.1.13 Importing data from other databases viz. MS Excel etc. 

 

1. On the External Data tab, in the Import & Link group, click the command for the type 

of file that you are importing from. 

For example, if you are importing data from an Excel worksheet, click Excel. If you 

don't see the correct program type, click More. 

 

2. In the Get External Data dialog box, either click Browse to browse to the source data 

file, or type the full path of the source data file in the File name box. 

 

3. Click the option that you want under Specify how and where you want to store the 

data in the current database. You can create a new table by using the imported data, 

or create a linked table that maintains a link to the data source. 

 

4. Click OK. 

Depending on your choice, the Link Objects dialog box or the Import Objects dialog 

box opens. 

 

5. Use the dialog box to finish the process. The exact procedure you follow depends on 

the import or link option that you choose. 
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6. On the last page of the wizard, click Finish. 

If you chose to import, Access asks whether you want to save the details of the 

import operation that you just completed. 

 

7. If you think that you will be performing this same import operation again, click Save 

import steps, and then enter the details. 

You can then easily reproduce the import operation by clicking Saved Imports in 

the Import group on the External Data tab, clicking the import specification, and then 

clicking Run. 

 

8. If you don't want to save the details of the operation, click Close. 

Access imports the data into a new table, and then displays the table under Tables in 

the Navigation Pane. 

 

Import an Excel worksheet into Access 

 

1. On the File tab, click New, and then click Blank Database. 

 

2. Type a name for the new database in the File Name box, and then click Create. The 

new database opens, and Access creates a new empty table, Table1. 

 

3. Close Table1. 

When asked if you want to save changes to the design of Table1, click No. 

4. On the External Data tab, in the Import & Link group, click Excel.  

5. In the Get External Data dialog box, click Browse. 

 

6. Use the File Open dialog box to locate your file. 

 

7. Select the file, and then click Open. 

 

8. In the Get External Data dialog box, ensure that the Import the source data into a 

new table in the current database option is selected. 

 

9. Click OK. 

The Import Spreadsheet Wizard starts, and asks you a few questions about your 

data. 

 

10. Follow the instructions, clicking Next or Back to navigate through the pages. On the 

last page of the wizard, click Finish. 

 

Access imports the data into a new table, and then displays it under All Tables in the 

Navigation Panel.  



P a g e  | 294 

 

5.2 Open Office – Base 

5.2.1 Introduction 
 

5.2.1.1 Database concepts 

 

A database is a collection of data stored together to serve multiple applications as 

possible. A database should be a repository of data needed for an organization's data 

processing. 

The data are stored in an object called table. The table includes rows and columns. Each 

row indicates an entity, and the columns are the attributes. 

Base is a fully featured desktop database management system, designed to meet the 

needs of a broad array of users.  In a database, table stores information for a group of 

things we call fields. For example, a table might hold an address book, a stock list, a 

phone book or a price list. A database can have from one to several tables. 

 

5.2.1.2 Creating a New Database  

To create a new database, click the arrow next to the New icon. In the drop-down menu, 

select Database. This opens the Database Wizard. You can also open the Database 

Wizard using File > New > Database. 

 

The first step of the Database Wizard has one question with two choices: Create a new 

database or Connect to an existing database. For this example, select Create a new 

database and then click Next. 

The second step has two questions with two choices each. The default choice for the first 

question is Yes, register the database for me and the default choice for the second 

question is Open the database for editing. Make sure these choices are selected and 

click Finish. Enter the database name and click save. 
 

5.2.1.3 Creating Tables 

● Open openoffice base 

● Create a new database 

Now database window will open  

● Click the Tables icon in the Database list, or use Alt+a. The three tasks that you 

can perform on a table are in the Task list 
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● Click create table using design view 

● Add the fields to the table. 

● Enter the fieldname and field type 

● Mark the primary key  

● Save the table, enter the table name and click OK 

● Now the table appears in the table pane. for example create a table student 

● Now click on the student table 

● Insert data and close the active window 

● Now the table created. 

5.2.1.4 Working with Forms 

 

● Open your database and create table 

● Click the Form icon in the database list, and click Use Wizard  to create a form 
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● Form wizard opens, select the table from Tables/Queries and select fields. 

● Click Arrange controls on your form 

 

 

 

 

● Set data entry mode and Apply Style, then next 
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P a g e  | 298 

 

● Set name ,and name your form title, Click Finish 

 

 

● The Form created 

 

 

5.2.1.5 Creating Queries 

 

Step 1: Open the first query in Design View. 

 Click Create Query in Design View. 
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Step 2: Add tables. 

 

 

1. Click Fuel to highlight it. 

2. Click Add. 

3. Click Close. 

  

 
Step 3: Add fields to the table at the bottom. 

1. Double-click the FuelID field in the Fuel table. 

2. Double-click the Odometer field. 

3. Double-click the FuelQuantity field. 

The table at the bottom of the query window should now have three columns. 

 
 

Step 4: Set the criterion for the query. 

We want the query's FuelID to begin with the numeral 1. 

1. Type >0 in the Criterion cell under FuelID in the query table 

2. Click the Run Query icon in the Query Design toolbar. This icon is circled in red 

below. 
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Query Design toolbar. 

The figures below contain the Fuel table with entries and the query results based 

upon the Fuel table. 

 
Fuel table 

 

 
Query of the fuel table 

Step 5: Save and close the query. 

Since this query contains the ending odometer reading for our calculations, name it 

End-Reading when saving it. Then close the query. 

 
Fuel economy calculation field. 

 

5.2.1.6 Finding Information in Databases 

 

● Open existing database, double click and open table 

● Click find record icon or Ctrl+F 

● Enter data and search 
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5.2.1.7 Creating Reports 

 

Reports provide information found in the database in a useful way. In this they are 

similar to queries. Reports are generated from the database's tables or queries. They can 

contain all of the fields of the table or query or just a selected group of fields. 

1. Create a new report. 

a. Click the Reports icon in the Database list in the Automobile - 

OpenOffice.org window. 

b. In the Tasks list, click Use Wizard to Create Report. The Report Wizard 

window opens. 

2. Select the fields. 

a. Select Table: Vacations in the Tables or Queries dropdown list. 

b. Use the > to move these fields from the Available fields list to the Fields in 

report list: Date, Motel, Tolls, Miscellaneous, Breakfast, Lunch, Supper, 

and SnackCost. Click Next. 

3. Label the fields: answering the question How do you want to label the fields. 

Shorten Miscellaneous to Misc. Click Next. 

4. Since we are grouping by the date, use the > button to move the Date field to the 

Grouping list. Click Next. 

 
Adding fields to a report 
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5. Sort options.  We do not want to do any additional sorting. Click Next. 

6. Choose layout.  We will be using the default settings for the layout. Click Next. 

7. Create report. 

o Label the report: Vacation Expenses. 

o Select Static report. 

 Click Finished. 

 

5.2.1.8 Types of Reports 

 

o Static report 

o Dynamic report 

Static reports contain the data in the selected fields at the time the report was created. 

Dynamic reports can be updated to show the latest data. 

Dynamic reports update only the data that is changed or added to a table or query. It 

does not show any modifications made to a table or query. 

5.2.1.9 Printing and Printing Preview 

 

● To print preview, double click and open the report 

● To print preview, click file menu, click page preview 

● To print, click file menu and print 

● Select the printer, choose name and copies 

● Then click print 

 

5.2.1.10 Operating with other databases (MS access etc.) 

OpenOffice.org (OOo) is able to read and write from a wide variety of databases, as long 

as they support one of the standard interface specifications such as ODBC or JDBC. 

Microsoft Access (Ms-Access) supports ODBC.  

The process has simple steps: 

1. Create an ODBC Data Source for each database you want to use (you only 

need to do this once per database) 

2. Create an ODBC Data Source within OpenOffice.org for each database (you 

only need to do this once) 

Creating an ODBC Data Source for the MS-Access database 

Within MS-Windows, choose Start -> Settings -> Control Panel and double-click the ODBC 

Data Sources icon to run the ODBC Data Source Administrator:  
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Click on the Add button to display the Create New Data Source dialogue box: 

 

 

Select the Microsoft Access Driver and press the Finish button. This will display the ODBC 

Microsoft Access Setup dialogue box: 
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Give the new data source a name (e.g. the same name as your MS-Access database) and 

a description. Use the Select button to select your MS-Access database file (*.dbf) and 

press OK. 

You should now see the ODBC Data Source you have created listed in the ODBC Data 

Source Administrator: 

 

 

 

Click OK to close the Administrator. Note that every database you want to use in OOo will 

need to have its own ODBC Data Source defined here. 



P a g e  | 305 

 

Creating a Data Source within OOo 

From within an OOo application, select Tools -> Data Sources... You will notice that OOo 

comes with one pre-installed Data Source called Bibliography. Ignore this, and press the 

New Data Source button. 

 

Select Database Type ODBC, and press the select button [...] and choose the ODBC Data 

Source you have just created. Give it a name, press the Apply button, and press OK to 

close the Data Source Administration tool. 

Using the Data Source within OOo 
 

There are other FAQs which describe using the database features within OOo. However, 

as a quick preview, select View -> Data Sources (or press F4). You are now ready to use 

your MS-Access database within OOo applications: 

 

***** 
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Introduction to MS Office Power Point and Open Office Impress 

6.1 MS Office - MS Power Point 

6.1.1 MS Power Point 

6.1.1.1 Introduction to presentation 

 

Power Point (PPT) is a powerful, easy-to-use presentation graphics software program 

which allows you to create professional-looking electronic slide shows. PPT is used to 

present information in an organized manner to an individual or group. Using clip art, 

sound clips, movie clips, graphs, organization charts, imported Web screens, and many 

other features, you can easily create a presentation that will impress your audience and 

convey your message clearly and professionally.  

 

Information can be displayed using an electronic presentation application. This 

information is usually presented as a slide show — the data is displayed on a slide that 

may be viewed on a computer monitor or projected onto a screen using an LCD projector. 

A presentation might consist of multiple slides that are exhibited one after the other. The 

presentation tool in MS Office is MS PowerPoint. Microsoft PowerPoint is a popular 

presentation application, although there are alternatives such as Corel Presentations 

OpenOffice.org, Impress, etc.  

 

Three major components of a presentation program are: 

(i) An editor that allows text to be input and formatted  

 

(ii) a means for inserting visual pictures, audio, and video  

 

(iii) and a slide-show system to display the final content. 
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6.1.1.2 Opening new presentation 

When beginning a new project in PowerPoint, you'll often want to start with a new blank 

presentation. 

Select the File tab to go to Backstage view. 

 

 

 

 

 

Select New on the left side of the window, and then click Blank Presentation. 

 

 

 

 

 

 

 

 

 

 

 

 

A new presentation will appear. 

 

6.1.1.3 Different presentation templates 

A template is a predesigned presentation you can use to create a new slide show quickly. 

Templates often include custom formatting and designs, so they can save you a lot of 

time and effort when starting a new project. 

Click the File tab to access Backstage view, then select New. 
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You can click a suggested search to find templates or use the search bar to find 

something more specific. In our example, we'll search for the keyword chalkboard. 

 

 

Select a template to review it. 

 

A preview of the template will appear, along with additional information on how the 

template can be used. 

Click Create to use the selected template. 
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6.1.1.4 Setting backgrounds 

Step 1 − In the Design ribbon, under the Background group, click the Background 

Styles command. 

 

 

Step 2 − Select one of the background styles that suits your requirements. 
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Step 3 − To edit the background for a specific slide, right-click on the desired background 

slide and select "Apply to Selected Slides". 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Step 4 − Selected slide(s) now have the new background. 

The graphics in the slide background can distract you from the actual content, in such 

cases you can hide the graphics and retain a plain background till you finish working on 

the content. To do this, select the slide and check the "Hide Background Graphics" 

checkbox. 
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6.1.1.5 Selecting presentation layouts 
 

By default, the Title Slide layout that has been assigned to the new slide, while clicking 

new slide. PowerPoint gives nine different layouts to choose from, and can even create 

own custom layouts also. 

 

Change the Slide Layout 
 

1. Select the slide that you want to change the layout for. 

2. Select Home > Layout. 

3. Select the layout that you want. 

The layouts contain placeholders for text, videos, pictures, charts, shapes, clip art, a 

background, and more. 

 

 

 

6.1.2 Creating a presentation 
 

Slides contain placeholders, which are areas on the slide that are enclosed by dotted 

borders. Placeholders can contain many different items, including text, pictures, and 

charts. Some placeholders have placeholder text, or text you can replace. They also 

have thumbnail-sized icons that represent specific commands such as Insert 

Picture, Insert Chart, and Insert ClipArt. In PowerPoint, hover over each icon to see the 

type of content you can insert in a placeholder. 
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6.1.2.1 Setting presentation styles 
 

Placeholders are arranged in different layouts that can be applied to existing slides or 

chosen when you insert a new slide. A slide layout arranges your content using different 

types of placeholders, depending on what information you might want to include in your 

presentation. 

In the example above, the layout is called Title and Content and includes title and 

content placeholders. While each layout has a descriptive name, you can also tell from 

the image of the layout how the placeholders will be arranged. 
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Customizing slide layouts 

To change the layout of an existing slide: 

1. Select the slide you want to change. 

 

2. Click the Layout command in the Slides group on the Home tab. A menu will 

appear with your options. 
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3. Choose a layout from the menu. The slide will change in the presentation. 

 

 

To delete a placeholder 

You can easily customize your layout by deleting unwanted or extra placeholders from 

any slide. 

1. Position your mouse on the dotted border of the placeholder so it changes to 

a cross with arrows  

2. Click the border to select it. 

3. Press Backspace or Delete on your keyboard. The placeholder will be removed 

from the slide. 
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6.1.2.2 Adding text to the presentation  

 

To add a text box 

Text boxes allow you to add to your current layout, so you can place text wherever you 

want on your slide. 

1. From the Insert tab, click the Text Box command. 

 

2. Your cursor will turn into an upside-down cross . 
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3. Click, hold, and drag your mouse to draw a text box. A text box will appear. 

 

 

To use a blank slide 

For more control over your content, you may prefer a blank slide—a slide without 

placeholders—over one of the existing layouts. Blank slides can be customized by adding 

your own text boxes, pictures, charts, and more. 

● Select Blank from the menu of layout options. 

 

Working with slides 

To insert a new slide 

1. From the Home tab, click the bottom half of the New Slide command to open the 

menu of slide layout options. 
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2. Select the slide you want to insert. 

 

A new slide will be added your presentation. 

To instantly add a slide that uses the same layout as the one you have selected, click the 

top half of the New Slide command. 

6.1.3 Formatting a presentation 

One of the most powerful tools in Microsoft Office is the application of formatting feature. 

This feature basically lets you define the right format once and apply the same to a series 

of objects in the rest of the presentation or any other file. While working with large 

presentations or just working on slides for a long time, if you ever need to make a change 

in the style and want it applied across multiple content this is the tool to use. 

The following are the steps to apply formatting to your presentation − 

Step 1 − Select the content you want to copy the formatting from. 

Step 2 − Go to the Clipboard group under the Home ribbon. 

Step 3 − Click on the Format Painter icon. 

Step 4 − Select the content you want to format. 
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Here are some key aspects about the Format Painter − 

● If you click on the Format Painter icon just once, the formatting will be copied just 

once. 

● If you click on the Format Painter icon twice quickly, you can copy the formatting 

multiple times. 

 

 

 

● If you want to copy just the text formatting and not the paragraph features, ensure 

that you select just the sample text and not the entire paragraph. 

● If you want to copy paragraph and font formatting, you must select the entire 

paragraph. 
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6.1.3.1 Adding style 

These features can be accessed from the Home ribbon under the Font group. 

 

 

Given below are the various font decoration features and their functions in PowerPoint. 

S.No Icon & Description 

1 Makes the font face bold 

2 Makes the font face italics (slanted font) 

3 
Underlines the font face 

4 Adds shadow to the font face 

5 Strikes through the font face 

6 Adjusts the character spacing for the font. Predefined settings are very tight, tight, 

normal, loose and very loose. There is a user defined space setting available too. 



P a g e  | 322 

 

Besides these, there are some other font decoration features that can be accessed from 

the Font dialog. To open the Font dialog, right-click on the selected text and select Font. 

 

 

The table below describes the additional text decoration features in the Font dialog. 
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S. No Icon & Description 

1 Double Strikethrough - Adds two strike lines over the text 

2 Superscript - Raises the text above the normal text. For example, the use of "nd" in 2nd 

3 Subscript - Shrinks the below the normal text. For example, the '2' in H2O the chemical 

formula of water 

4 Small Caps - Changes the entire text to small caps 

5 All Caps - Changes the entire text to capital letters 

6 Equalize Character height - Adjusts the characters so that all are of the same height 

regardless of the caps setting 

 

6.1.3.2 Colour 

Step 1 − Select the text the color of which needs to be changed. 

Step 2 − Go to the Font group under the Home ribbon. 
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Step 3 − From the Font Color dropdown, select the color you want to use for your text. 

 
 

Step 4 − Click on your choice to change the font color for the selected portion of text. 

 

If you want to choose from a wider range of colors than what's shown in the dropdown 

you can click on "More Colors…" 
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Here you can pick from a standard color palette for a greater choice of predefined colors 

or create your own from the custom color palette. 

 



P a g e  | 326 

 

 

 

 

6.1.3.3 Gradient fills 

The simplest way is to click the shape to select it, and then click the Format tab that 

appears: 

▪ For shapes, text boxes, and WordArt, the Format tab appears under Drawing Tools. 

 

▪ For chart shapes, the Format tab appears under Chart Tools. 

 

▪ For SmartArt shapes, the Format tab appears under SmartArt Tools. 
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On the Format tab, click Shape Fill, click Gradient, and select the one you want. 

 

 

6.1.3.4 Arranging objects 

 

Step 1 − Select a set of shapes or objects together. To select the objects, press 

the Ctrl key and select each object individually. If the objects are together, you can also 

click and drag the cursor to select them; however with the click and drag everything that 

falls within the selected area will be selected. 
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Step 2 − Go to the Arrange Group under the Format ribbon. 
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Step 3 − Click on Group under the Group menu item - this will group the objects and 

shapes into a single object. 

 

Step 4 − Apply the common changes you want to make to these objects. 
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Step 5 − Even though the objects are grouped, you can still edit them individually if need 

be. 

 

Step 6 − If you want to edit the shapes or objects individually, go back to the Group menu 

item and select Ungroup. 
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Step 7 − After making changes, if you want to regroup the objects as per original 

grouping, you select one of the objects and use the Regroup option under 

the Group menu. 

 

6.1.3.5 Adding Header & Footer  

Step 1 − In the Insert ribbon, click on the Header & Footer menu item. 
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Step 2 − The Header and Footer dialog has two tabs — the Slide tab and the Notes and 

Handouts tab. 

Step 3 − You can add details to the slide footer from the Slide tab. 

 
 

 

S.No Slide Footer Options & Description 

1 Date and time 

Add date and time to the footer 

Specify the format of the date and time entered 

Set up the footer to update automatically or use a fixed number 

2 Slide Number 

Insert Slide number in the footer 

3 Footer 

Add designated text to the footer - a good example of this is the confidentiality clause or 

copyright clause 

4 Don't show on title slide 

Decide on whether the footer information should be displayed on the title slide or not 
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Step 4 − You can add the details to the handouts from the Notes and Handouts tab. 

 
 

 

Sl.No Notes and Handouts Options & Description 

1 Date and time 

Add date and time to the footer 

Specify the format of the date and time entered 

Set up the footer to update automatically or use a fixed number 

2 Header 

Add the header information for every page on the handout 

3 Page Number 

Insert page number in the footer 

4 Footer 

Add designated text to the footer - a good example of this is the confidentiality clause or 

copyright clause 
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When you check any of the header and footer checkboxes in either tabs, you can see the 

location where the detail is inserted in the preview section. 
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6.1.3.6 Slide background 

The steps to apply backgrounds in PowerPoint. 

Step 1 − In the Design ribbon, under the Background group, click the Background 

Styles command. 

 

Step 2 − Select one of the background styles that suits your requirements. 
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Step 3 − To edit the background for a specific slide, right-click on the desired background 

slide and select "Apply to Selected Slides". 
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Step 4 − Selected slide(s) now have the new background. 

 

The graphics in the slide background can distract you from the actual content, in such 

cases you can hide the graphics and retain a plain background till you finish working on 

the content. To do this, select the slide and check the "Hide Background Graphics" 

checkbox. 
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6.1.3.7 Slide layout 

 

Arrange slide content with different slide layouts to suit your taste and preference, or to 

improve the clarity and readability of the content. 

1. Select the slide that you want to change the layout for. 

2. Select Home > Layout. 

3. Select the layout that you want. 

The layouts contain placeholders for text, videos, pictures, charts, shapes, clip art, a 

background, and more. The layouts also contain the formatting for those objects, like 

theme colors, fonts, and effects. 

Note: Select Home > Reset if you made layout changes you don't like, and want to revert 

to the original layout. Using Reset doesn't delete any content you've added. 

Change the orientation of your slides 

 

A separate Help article describes how to switch between portrait and landscape 

orientations: 

  landscape 

     portrait 

 

6.1.4 Adding Graphics to the presentation 

PowerPoint supports multiple content types including images or pictures. With regards to 

pictures PowerPoint classifies them into two categories − 

● Picture − Images and photos that are available on your computer or hard drive 

● Clip Art − Online picture collection that you can search from the clip art sidebar 

 

Although their sources are different, both these types can be added and edited in similar 

fashion. Given below are the steps to add picture to a slide. 

6.1.4.1 Inserting pictures 

Step 1 − Go to the Images group in the Insert ribbon. 

Step 2 − Click on Picture to open the Insert Picture dialog and add a picture to the slide. 
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Step 3 − In this dialog, you have three sections: to the left corner, you have folders that 

can be browsed, the section in the center shows the subfolders and files in the selected 

folder and to the right, you can have a preview of the selected image. 

Step 4 − Select the image you want and click Open to add the picture to the slide. 

 

Step 5 − Once you have the clipart you want to use, double-click on the image to add it to 

the slide. 
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6.1.4.2 Inserting movies 

PowerPoint allows presentations to be saved as video files that can be posted on video 

sharing platform like YouTube or just played on any other media. 

Given below are the steps to save a presentation as a video file. 

Step 1 − Go to the Backstage view under the File tab. 

 

 
 

Step 2 − Click on Save As to open the Save As dialog. 

Step 3 − Select the file type as .wmv from the list of supported file types. 
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Step 4 − Add a proper name to the file and click Save. 

 

 

Step 5 − The video creation is not an instant process like other file types as PowerPoint 

needs to create the video file. You can track the progress of video creation at the bottom 

of your presentation window. 
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Step 6 − Once the creation is complete, the video file is created in the specified location. 

 

 

6.1.4.3 Inserting tables 

● Place the cursor on the slide where you want to insert the table 

● Click the Insert tab, it will display Tables group on the left 

● Click the Table button, it will display four options to insert the table: 

1) Highlight the Number of Rows and Columns 

You will see small boxes on top, select the boxes corresponding to number of rows and 

column that you want in your table. 

See the image: 
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2) Insert Table 

Click the Insert Table option and enter the number of rows and columns then click ok. 

See the image: 

 

 

3) Draw Table 

Click the Draw Table option and place the cursor on slide. Cursor changes into a pencil. 

Click and drag the pencil to draw a table border. 

See the image: 
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4) Excel Spreadsheet: 

Click the Excel Spreadsheet option. Worksheet will appear in the slide, drag it to get the 

desired number of rows and columns. 

See the image: 

 

 

6.1.4.4 Drawing pictures using draw  

Create a Drawing 

1. Click the Draw tab. 

2. Click the Draw with Touch button. 

 

The mouse cursor changes to a drawing tool, and you can draw a shape by clicking and 

drawing on the page. 

3. Draw a shape using the mouse or touchscreen. 
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Change Pen Type 

 

While drawing, you also have a number of pen effects to choose from in the Pens gallery. 

 

1. Select a pen from the gallery. 

2. Click the active pen in the gallery. 

3. Modify the pen's properties. 

 

 

You can also create new pens by clicking the Add Pen button, with the same thickness 

and color options you have when modifying a pen. 

Erase a Drawing 

 

If you've added a drawing that you don't want to keep, you can erase drawings that 

you've made. 

1. Click the Eraser button. 

2. Click a drawing. 
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The drawing is erased. If you're finished erasing drawings, click the Eraser button again 

to turn it off. 

1. Click the Eraser button again. 

 

 

The eraser is turned off, and you can go back to editing your presentation or making 

more drawings. 
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6.1.5 Adding Effects to the Presentation 

 

PowerPoint offers animation support which can be used effectively to add some motion 

in a monotonous presentation and make it more interesting. Animation can be applied to 

any object on the slide and the motions can the automated, timed or trigger. 

 

6.1.5.1 Setting animation & transition effect 

Animations 

 

The following steps will help you add and preview animations in the slide. 

Step 1 − Go to the Animation ribbon and click on the Animation Pane to display the 

animation sidebar. 
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Step 2 − Select one of the objects in the slide and click on the Add Animation menu  

option. 

 

 

 

 

 

 

 

 

 

 

 

Step 3 − Choose from one of the Animation options. 

● Entrance will cause the object to appear in the screen. 

● Emphasis will cause the object to emphasis without appearing or leaving the 

screen. 

● Exit will cause the object to disappear from the screen. 
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Step 4 - Once you add the animation for an object, it will show up in the Animation pane. 

 

Step 5 − By default, all the animations are initiated by a click, but you can change this. 

To change the trigger, right-click on the animation object on the pane and choose an 

alternate trigger. 

 



P a g e  | 350 

 

 

● Start On Click will cause the animation to start when you click the mouse. 

● Start With Previous will cause the animation to begin with the previous animation; 

if this is the first object, it will begin as soon as you reach the slide during the slide 

show. 

● Start After Previous will cause the animation to begin after the previous animation 

ends. 

Step 6 − From the timing section, you can also manipulate the animation timings. 

Step 7 − To preview the animation settings, just click Play on the animation pane. 

 

Transitions 

 

Apply a Transition 
 

1. Select the slide that you want to apply a transition to.  To select multiple slides, hold 

down Ctrl as you select each slide. 

2. Click the Transitions tab. 

3. Click the Slide Transitions More button. 

4. Select the transition you want to use. 

5. The transition is applied to just the selected slide. To apply the transition to all slides 

in the presentation, click the Apply to All button on the Transitions tab.  To test the 

transition after it‘s applied, click the Preview button. 

6. To remove a transition, select None in the Slide Transitions gallery. 
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Modify a Transition 

A transition effect can be customized, including adjusting its speed or duration and 

adding sound. 

1. Click the Effect Options button. 

2. Select an effect option. 
 

 



P a g e  | 352 

 

3. Select additional modification options in the Timing group: 

● Sound: Pick a sound to play in unison with the slide transition. 

● Duration: Specify the length of the transition. 

● Apply To All: Apply the current slide‘s transition, effects, and timing settings to the 

entire presentation. 

● On Mouse Click: Select this option to have the slide advance when the mouse is 

clicked. 

● After: Select this option to have the slide advance after the amount of time you 

specify. 

 

 
 

4. Click Preview to see how your transition looks with the modifications applied. 

 

6.1.6 Printing handouts 

Print your presentation 

1. Select File > Print. 

2. For Printer, select the printer you want to print to. 

3. For Settings, select the options you want: 

▪ Print All Slides: To print each slide on a single sheet or change to just print a range of 

slides.  

▪ Slides: From the drop-down, choose to print all slides, selected slides, or the current 

slide. Or, in the Slides box, type which slide numbers to print, separated by a comma. 
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▪ Print Layout: Choose to print just the slides, just the speaker notes, an outline, or 

handouts. The number of slides per page is also an option, an effective way to save 

paper.  

The Outline prints only the text in the slides, without images. The Notes of a 

presentation show the slide and the related speaker notes below it. If you choose to 

print Handouts, you can print several slides on one page using a variety of layouts, 

some with space for note-taking. 

▪ Color: Choose whether you want color, grayscale, or pure black and white.  

▪ Edit Header & Footer: Select to edit the header and footer before printing. 

4. For Copies, select how many copies you want to print. 

5. Select Print. 

6.1.6.1 Generating standalone presentation viewer 

● First open the Presentation, which you wish to convert into a standalone program. 

Click Save As -> and choose ‗PowerPoint Show (.PPS)‘ from the dropdown of 

format selection. 

● Then run the file and choose Package for CD, if you would like to set up Autorun.  

● When up for final presentation, export the .PPT as .PPS  to easily run the 

slideshow without accessing the toolbars and edit area. 

 

Using Software 

● There are literally hundreds of tools which offer Free PowerPoint to EXE 

conversion services. 

● One of the best tools is VaySoft. Just run the application and choose the Source 

PowerPoint Presentation file and the destination directory path for the converted 

file. 

● Tick ‗Generate Autorun for CD/DVD‘, if you wish to play it automatically when a CD 

or DVD loads up. 

● You can tweak around with Logo Setup and PowerPoint viewer options. 

● These tools make your presentation accessible to everyone without any 

PowerPoint viewer installed on your PC. 

 

Benefits of Standalone Presentations 

● You can directly launch the slideshow, without opening PowerPoint editor. 

● The receivers do not need PowerPoint installed for viewing the presentation on 

their system. 

● This makes portability a lot more flexible, because can share the presentation 

with anyone. 

● Compress the files and images into a single executable file. 

● However, one drawback is executable files are vulnerable to malicious virus and 

malware and a few users may be reluctant to download and run them. 
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6.2 Open Office Impress 

6.2.1 Introduction 

 

This easy-to-learn program, which features user-friendly functions and standard toolbars 

and menus, allows users to create a wide variety of slide layouts for visually attractive 

presentations. With Impress, users can create slides that contain many different 

elements, including: text, bulleted and numbered lists, tables, charts, clip art, and a wide 

array of graphic objects. It also comes complete with spell check, a thesaurus, pre-set 

text styles, attractive background styles, and a handy help menu. 

To create professional presentations in a short period of time. It features instructions, 

screenshots, and helpful hints that guide users through the Impress environment while 

designing presentations 

 

6.2.1.1 Creating Presentation 

 

This section shows how to set up a new presentation. 

Start AutoPilot presentation 

After launching Impress, AutoPilot Presentation window number 1 will appear (see Figure 

1). If it does not, then go to File > AutoPilot > Presentation. 

1) Under Type, select one of the following options: 

• Empty Presentation creates a presentation from scratch. 

• From Template uses a template design already created as the base of a new 

presentation. 

• Open Existing Presentation continues work on a previously created presentation. 

2) Click Next. 

 

 

 

 

 

 

 

 

 

Figure 1 

Window number 2 

AutoPilot Presentation window number 2 will appear (see Figure 2). 

1. Under Select a slide design, choose a design, or to leave it blank, select <Original>. 
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2. Under Select an output medium, select how the presentation will be used. Most 

often, the presentations are created for a screen. 

3. Click Next. 

 

Figure 2 

Choose the desired option from the effect menu. This option Effect creates transitions 

between all the slides in the presentation.  

1. To not have any transition effects, select No Effect. This option can be changed later, 

and each slide can have different transitions, if desired. For more information, see 

section 5–Transitions between slides. 

2. Select the desired speed for the transition between the different slides in the 

presentation from the speed menu. 

3. Click Create. A new presentation is created. 

 

Figure 3 

Modify Slide during Autopilot 

The Modify Slide window will appear (see Figure 4). The Select an AutoLayout section 

contains a wide variety of slides to incorporate in a presentation. Click the different slides 
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in this box to see the all of the slides. There are slides with a title, a title and text, a chart, 

a title and clip art, or other combinations of these options. Notice that the bottom of this 

frame reflects the type of slide selected. 

1) Type in a title for the slide in the area marked Name. 

2) Select a slide layout from the Select an AutoLayout frame. 

3) Click OK. 

 

 

Modify slides 

1) Select Format > Modify Layout. The Modify Slide window will appear (see Figure 7). 

2) Modify the layout by choosing a new layout from the Select an AutoLayout section. 

 

 

 

 

 

 

 

 

Delete slides 

1) Go to the slide to delete. 

2) Select Edit > Delete Slide. 

3) Click Yes. 
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Rename slides 

1) Select Format > Modify Layout. 

The Modify Slide window will appear. Under Name, enter the new name of the slide. 

Rearrange slides 

Rearranging the slides is most easily done in the Slides View. 

1) Select View > Workspace > Slides View. The slides will appear in miniature view from 

left to right, in their current order (see Figure 8). 

2) Change the order of the slides by dragging and dropping them to the new location. A 

black line will appear between the slides. This shows where they will go. 

 

6.2.1.2 Saving presentation files 

1. Choose File > Save As from the menu bar. 

2. Select the location where you want the PowerPoint file saved and type a name for 

the file. 

3. Under File type, choose Microsoft PowerPoint 97/2000/XP (.ppt). 

4. Click Save. The message shown below will appear. Click Yes to confirm that you want 

to save the file in Microsoft PowerPoint format. You can select the checkbox to not 

show the message again. 

 

 

6. 2.1.3 Master templates & re-usability 
 

Creating slide masters 

You can create a new slide master in a similar way to modifying the default slide master. 

To start, enable editing of slide masters by View > Master > Slide Master. 
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On the Master View toolbar, click the New Master icon (highlighted in the figure). 

 

 

Master View toolbar 

A second slide master appears in the Slides pane. Modify this slide master to suit your 

requirements. It is also recommended that you rename this new slide master. To do that, 

right-click on the slide in the Slides pane and select Rename master from the popup 

menu. 

When you are done, close the Master View toolbar to return to normal slide editing mode. 

 

Applying a slide master 

In the Tasks Pane, be sure the Master Pages section is showing. 

 

 

Available master pages (slides) 

To apply one of the slide masters to all slides in your presentation, click on it in the list. 

To apply a different slide master to one or more selected slides: 
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1. In the Slide Pane, select the slides you want to change. 

2. In the Tasks Pane, right-click on the slide master you want to apply to the 

selected slides, and click Apply to Selected Slides on the pop-up menu. 

 

6. 2.1.4 Slide transitions 

Adding transitions 

1. In the Sidebar, select the Slide Transition icon  to open the Slide Transition 

section 

 

 

2. In the Slides Pane select the slide or slides to apply the transition 

3. In the Sidebar select one of the available transitions. When you click in a transition 

you preview the effect in Impress workspace. 
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4. Modify the selected transition by changing the speed or adding a sound, in the 

Modify transition section. If you decide to play a sound during transitions, select a 

sound from the Sound list. 

5. If a sound is selected, the Loop until next sound option becomes active. Select this 

option to play the sound repeatedly until another sound starts. If there are no 

subsequent sounds in your slide show, the selected sound will play continuously for 

the remainder of the show. 

6. Select how to advance to the next slide: manually (On mouse click) 

or automatically (Automatically after). If you select an automatic advance, you can 

specify how long the slide remains visible before it automatically advances to the 

next slide. 

7. If you want the transition to apply to all slides, click Apply to All Slides. 

If the Automatic preview checkbox is marked, the effect of a selected transition is 

immediately displayed in the work area. You can replay the effect at any time by 

clicking Play. 

While using many different transitions may be fun to do, it may not give your slide show a 

professional appearance. 

Removing transitions 

To remove a slide transition: 

1. Select the slides from where you want to remove the transitions. 

2. Select None transition in the Slide Transition pane. 

 

 

6.2.1.5 Making presentation CDs 

Save your package to a CD 

1. Insert a blank recordable CD (CD-R), a blank rewritable CD (CD-RW), or a CD-RW (that 

contains existing content that can be overwritten) in the disk drive. 

2. In PowerPoint, click File, click Export, click Package Presentation for CD, and then 

click Package for CD. 

3. In the Package for CD dialog box, type a name for your CD in the Name the CD box. 

4. To add one or more presentations to package together, click Add, select the 

presentation, and then click Add. Repeat this step for each presentation that you 

want to add. 
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Tip: If you add more than one presentation, they'll play in the order in which they are 

listed in the Files to be copied list. Use the arrow buttons on the left side of the 

dialog box to re-order the list of presentations. 

5. To include supplementary files such as TrueType fonts or linked files, click Options. 

 

6. Under Include these files, select the applicable check boxes: 

To inspect your presentation for hidden data and personal information, select 

the Inspect presentation for inappropriate or private information check box. 

 

7. Click OK to close the Options dialog box. 

8. In the Package for CD dialog box, click Copy to CD. 

 

6. 2.1.6 Printing Handouts 
 

Handouts 

In the Handout view you can check, how the documents for the listeners look like. If you 

prefer another sharing out of the slides, you can change the Layout in the Task pane on 

the right side. This selection is used after a mouse click for all pages of the handout. 
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Printing 

If you want to print your presentation directly, you can click the Printer button (printer 

symbol) in the Standard bar. Special adjustments can be done in the menu File > Print. 

Here you can define if all pages should be printed, or only individual pages. 

When you click the Options button a dialog box will appear, where you can define, that 

notes or handouts should be printed too. 

6. 2.1.7 Operating with MS power Point files / slides 
 

Use File > Save As to save your presentation as one of the file types listed below.   

The default file format in PowerPoint version 2007 or newer is .pptx 

File type Extension Use to save 

PowerPoint 

Presentation 
.pptx 

A presentation that you can open on a PC in PowerPoint 2007 and 

newer versions, or that you can open on a Mac in PowerPoint 2008 

and newer versions.  

You can also open the presentation on any mobile device that has 

PowerPoint installed. 

PDF 

Document 

Format 

.pdf 

A PostScript-based electronic file format developed by Adobe 

Systems that preserves document formatting and enables file 

sharing. 

PowerPoint 

97-2003 

Presentation 

.ppt 
A presentation that you can open in PowerPoint 97 to Office 

PowerPoint 2003. 

 

***** 
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UNIT – 7 

INTERNET & INTRODUCTION TO VARIOUS 

DEVICES AND TOOLS 
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7.1 Computer Networks 

A computer network is a set of computers sharing resources located on or provided by 

network nodes. The computers use common communication protocols over digital 

interconnections to communicate with each other. These interconnections are made up 

of telecommunication network technologies, based on physically wired, optical, and 

wireless radio-frequency methods that may be arranged in a variety of network 

topologies. 

7.1.1 Data Communication 

Data Communications  

Components of a data communication  

The five components are :  

1. Message - It is the information to be communicated. Popular forms of information 

include text, pictures, audio, video etc.  

2. Sender - It is the device which sends the data messages. It can be a computer, 

workstation, telephone handset etc.  

3. Receiver - It is the device which receives the data messages. It can be a computer, 

workstation, telephone handset etc.  

4. Transmission Medium - It is the physical path by which a message travels from sender 

to receiver. Some examples include twisted-pair wire, coaxial cable, radio waves etc.  

5. Protocol - It is a set of rules that governs the data communications. It represents an 

agreement between the communicating devices. Without a protocol, two devices may be 

connected but cannot communicate. 

 

 

7.1.2 Types of Computer Networks 

1. Local Area Network (LAN) 

2. Metropolitan Area Network (MAN) 

3. Wide area network (WAN) 

4. campus area network (CAN) 

5. Home Area Networks (HAN) 

7.1.3 Local Area Networks & Wide Area Networks  

Local Area Network (LAN) is generally a privately owned network within a single office, 

building or campus, covering a distance of a few kilometres. The main reason for 

designing a LAN is to share resources such as disks, printers, programs and data. 

Depending on the needs the LAN can be limited two PC‘s and a printer.   LAN size is 
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limited to a few kilometres. They are designed to allow resources to be shared between 

personal computers or workstations.  

 

The resources include both hardware like printer or software like application program or 

data.  

Here one computer may be provided with higher capacity hard disk which can act as the 

server and remaining as clients or workstations.  

Topology mostly adopted in use are bus, ring,star. 

 

A Wide area network (WAN) is a telecommunication network that is used for connecting 

computers and covers a wide geographical area. WANs often contain a few smaller 

networks (LANs, MANs, etc.).A WAN span across city, state, country or even continent 

boundaries. 

 

7.2 Internet and Web Browsers 

It is a worldwide system which has the following characteristics:  

● Internet is a world-wide / global system of interconnected computer networks.  

● Internet uses the standard Internet Protocol (TCP/IP)  

● Every computer in internet is identified by a unique IP address.  

● IP Address is a unique set of numbers (such as 110.22.33.114) which identifies a 

computer‘s location.  
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● A special computer DNS (Domain Name Server) is used to give name to the IP 

Address so that user can locate a computer by a name.  

 

For example, a DNS server will resolve a name http://www.google.com to a particular IP 

address to uniquely identify the computer on which this website is hosted.  

Internet is accessible to every user all over the world by using various devices both by 

wired and wireless.  

 

 

Web Browser 

The web browser is an application software to explore www (World Wide Web). It provides 

an interface between the server and the client and requests to the server for web 

documents and services. It works as a compiler to render HTML which is used to design a 

webpage. Whenever we search anything on the internet, the browser loads a web page 

written in HTML, including text, links, images, and other items such as style sheets and 

JavaScript functions. Google Chrome, Microsoft Edge, Mozilla Firefox, Safari are 

examples of web browsers.  

A web browser helps us find information anywhere on the internet. It is installed on the 

client computer and requests information from the webserver such a type of working 

model is called a client-server model. 
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7.2.1 Definition & History of Internet 

Internet & World Wide Web The internet is a globally connected network system that 

transmit data via various types of media. The internet is a network of global exchanges – 

including private, public, business, academic and government networks – connected by 

guided, wireless and fiber-optic technologies.  

The terms internet and World Wide Web are often used interchangeably, but they are not 

exactly the same thing; the internet refers to the global communication system, including 

hardware and infrastructure, while the web is one of the services communicated over the 

internet. Billions of internet users rely on multiple application and networking 

technologies, including:  

Internet Protocol (IP): The internet‘s primary component and communications backbone. 

Because the internet is comprised of hardware and software layers, the IP 

communication standard is used to address schemes and identify unique connected 

devices. Prominent IP versions used for communications include Internet Protocol 

version 4 (IPv4) and Internet Protocol version 6 (IPv6).  

Communications: The internet is the most cost-effective communications method in the 

world, in which the following services are instantly available:  

● Email  

● Web-enabled audio/video conferencing services  

● Online movies and gaming  

● Data transfer/file-sharing 

● Instant messaging  

● Social networking  

● Online shopping  

● Financial services   

History of Internet The first workable prototype of the Internet came in the late 1960s 

with the creation of ARPANET, or the Advanced Research Projects Agency Network. 

Originally funded by the U.S. Department of Defense, ARPANET used packet switching to 

allow multiple computers to communicate on a single network.  

 The technology continued to grow in the 1970s after scientists Robert Kahn and Vinton 

Cerf developed Transmission Control Protocol and Internet Protocol, or TCP/IP, a 

communications model that set standards for how data could be transmitted between 

multiple networks. ARPANET adopted TCP/IP on January 1, 1983, and from there 

researchers began to assemble the ―network of networks‖ that became the modern 

Internet. 

The online world then took on a more recognizable form in 1990, when computer 

scientist Tim Berners-Lee invented the World Wide Web. While it‘s often confused with 

the Internet itself, the web is actually just the most common means of accessing data 

online in the form of websites and hyperlinks. The web helped popularize the Internet 
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among the public, and served as a crucial step in developing the vast trove of 

information that most of us now access on a daily basis.  

World Wide Web  

 The World Wide Web (WWW), commonly known as the Web, is an information system 

where documents and other web resources are identified by Uniform Resource Locators 

(URLs, such as https://www.example.com/), which may be interlinked by hypertext, and 

are accessible over the Internet.  

The resources of the WWW may be accessed by users by a software application called a 

web browser. English scientist Tim Berners-Lee invented the World Wide Web in 1989. 

He wrote the first web browser in 1990 while employed at The European Organization for 

Nuclear Research (CERN) near Geneva, Switzerland. The browser was released outside 

CERN in 1991, first to other research institutions starting in January 1991 and then to 

the general public in August 1991.  

The World Wide Web has been central to the development of the Information Age and is 

the primary tool billions of people use to interact on the Internet. Web resources may be 

any type of downloaded media, but web pages are hypertext media that have been 

formatted in Hypertext Markup Language (HTML). Such formatting allows for embedded 

hyperlinks that contain URLs and permit users to navigate to other web resources. In 

addition to text, web pages may contain images, video, audio, and software components 

that are rendered in the user's web browser as coherent pages of multimedia content. 

The terms Internet and World Wide Web are often used without much distinction. 

However, the two terms do not mean the same thing. The Internet is a global system of 

interconnected computer networks. In contrast, the World Wide Web is a global collection 

of documents and other resources, linked by hyperlinks and URIs. 

 

7.2.2 Uses of Internet 

1. Electronic mail. At least 85% of the inhabitants of cyberspace send and receive e-

mail. Some 20 million e-mail messages cross the Internet every week. 

2. Research. 

3. Downloading files. 

4. Discussion groups. These include public groups, such as those on Usenet, and the 

private mailing lists that ListServ manages. 

5. Interactive games. Who hasn‘t tried to hunt down at least one game? 

6. Education and self-improvement. On-line courses and workshops have found yet 

another outlet. 
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7. Friendship and dating. You may be surprised at the number of electronic 

―personals‖ that you can find on the World Wide Web. 

8. Electronic newspapers and magazines. This category includes late-breaking news, 

weather, and sports. We‘re likely to see this category leap to the top five in the 

next several years. 

9. Job-hunting. Classified ads are in abundance, but most are for technical positions. 

10. Shopping. It‘s difficult to believe that this category even ranks. It appears that 

―cybermalls‖ are more for curious than serious shoppers. 

 

7.2.3 Definition of Web-Addressing - URL 

A website address, also known as a URL (uniform resource locator), is an Internet or 

intranet name that points to to a location where a file, directory or website page is 

hosted. Website addresses can represent the home page of a web site, a script, image, 

photo, movie or other file made available on a server for viewing, processing or 

download. They can also be embedded into the code of web pages in the form of 

hyperlinks to direct the user to other locations on the Internet. 

 

7.2.4 Different types of Internet Connections 

Understanding the difference between Internet Connections 

When determining which type of Internet speed and Internet connection type is right for 

you or your family, it's important to understand the distinction between each connection. 

In today's age, there are numerous ways to connect laptops, desktops, mobile phones, 

gaming consoles, e-readers and tablets to the Internet. Some of the most widely used 

Internet connections are described below. 

1. Dial-up Connection 

Dial-up connections require users to link their phone line to a computer in order to 

access the Internet. This particular type of connection—also referred to as analog—does 

not permit users to make or receive phone calls through their home phone service while 

using the Internet. Now more outdated, a dial-up connection used to be among the most 

common Internet connection type. 

2. Broadband 

This high-speed Internet connection is provided through either cable or telephone 

companies. One of the fastest options available, broadband Internet uses multiple data 

channels to send large quantities of information. The term broadband is shorthand for 

broad bandwidth. Broadband Internet connections such as DSL and cable are 

https://www.xfinity.com/hub/internet/internet-speed
https://www.xfinity.com/hub/internet/dsl-vs-cable
https://www.xfinity.com/learn/home-phone-services
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considered high-bandwidth connections. Although many DSL connections can be 

considered broadband, not all broadband connections are DSL. 

ISDN 

ISDN (Integrated Services Digital Network) allows users to send data, voice and video 

content over digital telephone lines or standard telephone wires. The installation of an 

ISDN adapter is required at both ends of the transmission—on the part of the user as well 

as the Internet access provider. 

There are quite a few other Internet connection options available, including T-1 lines, T-3 

lines, OC (Optical Carrier) and other DSL technologies. 

As you decide what Internet connection is the best fit for your needs, you may wish to 

narrow down your selection based on your preferred download and upload speeds, or 

based on deals and pricing options. Reliably fast speeds and comprehensive coverage 

make it easier than ever to stream your favorite TV shows and movies, share photos, 

chat with friends and play games online. 

DSL 

DSL, which stands for Digital Subscriber Line, uses existing 2-wire copper telephone line 

connected to one's home so service is delivered at the same time as landline telephone 

service. Customers can still place calls while surfing the Internet. 

Cable 

Cable Internet connection is a form of broadband access. Through use of a cable 

modem, users can access the Internet over cable TV lines. Cable modems can provide 

extremely fast access to the Internet, making a cable connection a viable option for 

many. 

3. Wireless 

Wi-Fi Hotspots 

Wifi Hotspots are sites that offer Internet access over a wireless local area network 

(WLAN) by way of a router that then connects to an Internet service provider. Hotspots 

utilize WiFi technology, which allows electronic devices to connect to the Internet or 

exchange data wirelessly through radio waves. Hotspots can be phone-based or free-

standing, commercial or free to the public. 

WiMax 

WiMax is a standardized wireless version of Ethernet intended primarily as an alternative 

to wire technologies (such as Cable Modems, DSL and T1/E1 links) to provide broadband 

access to customer premises. WiMAX would operate similar to WiFi, but at higher speeds 

over greater distances and for a greater number of users. WiMAX has the ability to 

https://www.xfinity.com/learn/internet-service/deals
https://www.xfinity.com/learn/internet-service/wifi


P a g e  | 371 

 

provide service even in areas that are difficult for wired infrastructure to reach and the 

ability to overcome the physical limitations of traditional wired infrastructure. 

Satellite 

In certain areas where broadband connection is not yet offered, a satellite Internet option 

may be available. Similar to wireless access, satellite connection utilizes a modem. 

Mobile 

Many cell phone and smartphone providers offer voice plans with Internet access. Mobile 

Internet connections provide good speeds and allow you to access the Internet. 

Naming convention 

● 802.11n technology will  be referred to as Wi-Fi 4 

● 802.11ac technology will be referred to as Wi-Fi 5 

● 802.11ax technology will be referred to as Wi-Fi 6 

7.2.5 Browsers and its types, Internet Browsing 
 

Web Browsers are software installed on your PC. To access the Web, you need a web 

browser, such as Netscape Navigator, Microsoft Internet Explorer or Mozilla Firefox. 

Currently you must be using any sort of Web browser while you are navigating through 

our site tutorialspoint.com. On the Web, when you navigate through pages of information, 

this is commonly known as web browsing or web surfing. 

There are four leading web browsers − Explorer, Firefox, Netscape, and Safari, but there 

are many others browsers available. You might be interested in knowing Complete 

Browser Statistics. Now we will see these browsers in bit more detail. 

While developing a site, we should try to make it compatible to as many browsers as 

possible. Especially sites should be compatible to major browsers like Explorer, Firefox, 

Chrome, Netscape, Opera, and Safari. 

Internet Explorer 

Internet Explorer (IE) is a product from software giant Microsoft. This is the most 

commonly used browser in the universe. This was introduced in 1995 along with 

Windows 95 launch and it has passed Netscape popularity in 1998. 

Google Chrome 

This web browser is developed by Google and its beta version was first released on 

September 2, 2008 for Microsoft Windows. Today, chrome is known to be one of the 

most popular web browser with its global share of more than 50%. 

https://www.xfinity.com/hub/internet/internet-on-the-go
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Mozilla Firefox 

Firefox is a new browser derived from Mozilla. It was released in 2004 and has grown to 

be the second most popular browser on the Internet. 

Safari 

Safari is a web browser developed by Apple Inc. and included in Mac OS X. It was first 

released as a public beta in January 2003. Safari has very good support for latest 

technologies like XHTML, CSS2 etc. 

Opera 

Opera is smaller and faster than most other browsers, yet it is full- featured. Fast, user-

friendly, with keyboard interface, multiple windows, zoom functions, and more. Java and 

non Java-enabled versions available.Ideal for newcomers to the Internet, school children, 

handicap and as a front-end for CD-Rom and kiosks. 

Konqueror 

Konqueror is an Open Source web browser with HTML 4.01 compliance, supporting Java 

applets, JavaScript, CSS 1, CSS 2.1, as well as Netscape plugins. This works as a file 

manager as well as it supports basic file management on local UNIX filesystems, from 

simple cut/copy and paste operations to advanced remote and local network file 

browsing. 

Lynx 

Lynx is a fully-featured World Wide Web browser for users on Unix, VMS, and other 

platforms running cursor-addressable, character-cell terminals or emulators. 

 

7.2.6 Search Engines 
 

Search Engines are now part of our daily life, whether it be carrying out research for 

Xmas presents or where is the nearest coffee shop open before 7am or looking for best 

Steak House in town. People are now becoming more and more dependent on search 

engines to get the answer for their everyday queries. 

At Inspire we monitor our search traffic using a variety of analytics. Most of our queries 

returned are related to what we do and some are simply bizarre. Those we‘re interested 
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in relate to the services of what we do e.g improving search ranking, web design, web 

development, and many more.  

Much as we utilise ―all routes to market‖ we are still heavily dependent on the search 

engines for our bread & butter traffic. 

1. Google  

Google Search Engine is the best search engine in the world and it is also one of most 

popular products from Google. Almost 70 percent of the Search Engine market has been 

acquired by Google. The tech giant is always evolving and looking to improve the search 

engine algorithm to provide best results to the end-user. Although Google appears to be 

the biggest search engine, as of 2015 YouTube is now more popular than Google (on 

desktop computers). 

 

2. Bing   

Bing is Microsoft‘s answer to Google and it was launched in 2009. Bing is the default 

search engine in Microsoft‘s web browser. At Bing, they are always striving to make it a 

better search engine but it‘s got a long way to go to give Google competition. Microsoft‘s 

search engine provides different services including image, web and video search along 

with maps. Bing introduced Places (Google‘s equivalent is Google My Business), this is a 

great platform for business to submit their details to optimise their search results. 

 

3. Yahoo  

Yahoo & Bing compete more with each other than with Google. A recent report on 

netmarketshare.com tells us that Yahoo have a market share of 7.68 percent. Although a 

leader as a free email provider, this is declining significantly though with their recent 

acknowledgement that User Details & Passwords where hacked last year. 

 

4. AOL   

Aol.com is also among the top search engines. These are the guys that used to send out 

CD‘s which you‘d load onto your PC to install their browser and modem software. Once 

the pre-eminent player they now have a market share of 0.59 percent. Verizon 

Communication bought AOL for $4.4 billion. It was started back in 1983 as Control Video 

Corporation. It was named America Online in 1991 and in 2009 as AOL Inc. AOL is a 

global mass media company which is based in New York. The company also provides 

advertising services as AOL Advertising, AOL mail and AOL Platform. 

7.2.7 Portals 

A portal is a web-based platform that collects information from different sources into a 

single user interface and presents users with the most relevant information for their 

context. Over time, simple web portals have evolved into portal platforms that support 

digital customer experience initiatives. 

 

http://www.google.com/
http://bing.com/
http://yahoo.co.uk/
http://aol.co.uk/
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Web Portals Are About Personalized Access 

The problem portals tried to solve in the early days of the internet was content discovery. 

In the face of the vast amount of information available online, the easiest way for the 

average user to discover information was through a human-curated content hub, known 

as a portal. Portals could display selected content in order to provide a custom 

experience for users.  

 

Examples of portals, particularly those that use a login experience, abound in most 

industries: 

● Patient Portals 

● Government Portals 

● Intranets/Extranets/Workplace Portals 

● Knowledge Management Portals 

● Student Portals 

● Vendor Portals 

The basic, uniting concept for each type of portal is personalized access, based on an 

assigned or assumed user role. For example, workplaces typically have multiple 

applications that their employees need to access, such as an application for recording 

time sheets, another for scheduling time off and a third for sending internal 

communications. Employees are frustrated when they have too many touchpoints that 

they need to jump between as part of their daily routine. A new employee portal brings 

together these common services and applications into one place for your team to access, 

and can further customize the page based on department or role.  

This personalization can also extend to anonymous users. Clothing retail sites, for 

instance, can begin personalizing which products are displayed based on stored 

information from past visits, even if the user hasn‘t created an account.  

 

7.2.8 Social Networking Sites 
 

A social networking site is an online platform that allows users to create a public profile 

and interact with other users. Social networking sites usually allow a new user to provide 

a list of people with whom they share a connection, and then allow the people on the list 

to confirm or deny the connection. After connections are established, the new user can 

search the networks of connections to make more connections. 

A social networking site is also known as a social networking website or social website. 

There are numerous social networking websites, the following sites are the most popular: 

Facebook: Facebook users create profiles, share information, send messages and post 

status updates on their "walls." Ranked the most active social networking platform by 
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DataReportal, Facebook has more than 2.9 billion active users. In 2021, the company 

was renamed Meta to reflect its business beyond just social media. 

 

 

YouTube: This popular video-sharing website enables users to share, upload, and post 

videos and vlogs. According to Global Media Insight, YouTube has more than 2 billion 

monthly active users. 

WhatsApp: This free instant messaging app lets users send text messages, make video 

and voice calls, and share documents. According to WhatsApp, it has more than 2 billion 

users worldwide. 

Instagram: This free social media platform enables users to share long- and short-form 

videos and photos. It is primarily designed for iOS and Android smartphone users, but a 

desktop version is also available. However, sharing and uploading of content is only 

available through the Instagram app. Also owned by Meta, Instagram has over 2 billion 

monthly active users as of December 2021, according to CNBC. 

Twitter: Launched in 2006, this social media platform enables users to share their 

thoughts and opinions with a broad audience by posting messages known as "tweets" 

that contain up to 280 characters. According to DataReportal, as of January 2022, 

Twitter has more than 436 million users. 

Pinterest: The Pinterest bookmarking site enables users to save and organize links to 

favorite online resources and destinations through "tagging." According to Pinterest Inc., 

the platform has 431 million global monthly active users as of December 2021 -- a 6% 

decrease over the previous year. 
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7.2.9 Blogs 

A blog (a shortened version of ―weblog‖) is an online journal or informational website 

displaying information in reverse chronological order, with the latest posts appearing 

first, at the top. It is a platform where a writer or a group of writers share their views on 

an individual subject. 

Blog structure 

The appearance of blogs has changed over time, and these days blogs include a wide 

variety of items and widgets. However, most blogs still include some standard features 

and structures. 

Here are common features that a typical blog will include: 

● Header with the menu or navigation bar. 

● Main content area with highlighted or latest blog posts. 

● Sidebar with social profiles, favorite content, or call-to-action. 

● Footer with relevant links like a disclaimer, privacy policy, contact page, etc. 

 

Basic blog structure 
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The above example is the basic structure of the average blog. Each item has its own 

importance and helps visitors to navigate through your blog. 

Blogger 

A blogger is someone who runs and controls a blog. He or she shares his or her opinion 

and knowledge on different topics for a target audience. 

 

7.2.10 Viewing a Web page 
 

Everything you view online has been put on a "server" – a computer that is serving the 

information to you when you request it by typing in a web address or clicking a link in a 

search engine. 

Web pages and documents stored on servers are typically accessed via a Web Browser. 

There are various browsers available – mainstream examples are Internet Explorer, 

Firefox, Chrome and Safari. A web browser is just a piece of software you have on your 

computer that knows how to read and display web pages to you. 

You access a website by typing it's address into the address bar on the browser (shown 

below with a red box around it).  

 

 

7.2.11 Creating an email-ID 
 

1. Go to the Gmail website. 

2. At the bottom of the sign in screen, click the link. 

3. On the account creation screen, fill out all the fields (A) and then click Next (B) 

4. On the next screen, fill out your birth date and gender (A) and any other information 

you are comfortable with, then click Next (B). 

5. Read Google's Privacy and Terms, then click the  button. 

6. Click the button until you've moved through the features menu. 

7. Click the button, allowing you to access your new account. 

https://www.gmail.com/
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Reading Email 

Every email program offers you an interface to access email messages. Like in Gmail, 

emails are stored under different tabs such as primary, social, and promotion. When you 

click one of tab, it displays a list of emails under that tab. 

In order to read an email, you just have to click on that email. Once you click a particular 

email, it gets opened. 

The opened email may have some file attached with it. The attachments are shown at 

the bottom of the opened email with an option called download attachment. 

Replying Email 

After reading an email, you may have to reply that email. To reply an email, 

click Reply option shown at the bottom of the opened email. 

Once you click on Reply, it will automatically copy the sender‘s address in to the To field. 

Below the To field, there is a text box where you can type the message. 

Once you are done with entering message, click Send button. It‘s that easy. Your email is 

sent. 

Saving Email 

While composing an email in Gmail / Yahoo it is automatically saved as a draft, 

preventing accidental data loss in the event of an interrupted connection.  
 

There are a couple of ways to save a message while composing in Gmail fast: 

● Stop typing and editing for three seconds, and Gmail saves a draft. The composition 

window does not close using this method. 

● Press the Esc key to save immediately. This saves email to the Drafts label and 

closes the composition window. The screen returns to inbox. 
 

  
Locating Draft 

When you are ready to continue working on the email, you'll find it in the Drafts folder in 

the left column of Gmail where all the labels are located. Click Drafts and click the email 
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to open it. As you work, Gmail continues to save until you are ready to click the Send 

button. 

 

Printing Email 

Open your mail and go to the mail you want to print. 

Step 1: Open the specific mail or expand it if it's part of a long thread of conversations. 

Step 2: Go to the top-right and click the Printer icon. You can also right-click on top of the 

mail and choose Print from the context menu. Alternatively, use the Ctrl + P shortcut. 

 

Step 3: The Print dialog is now displayed. Pick the printer you want to print to. 

Remember, you can print to your electronic printer, a cloud printer, PDF, or just "print" it 

to OneNote. 
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Forwarding Email 

It is also possible to send a copy of the message that you have received along with your 

own comments if you want. This can be done using forward button available in mail client 

software. 

The difference between replying and forwarding an email is that when you reply a 

message to a person who has send the mail but while forwarding you can send it to 

anyone. 

When you receive a forwarded message, the message is marked with a > character in 

front of each line and Subject: field is prefixed with Fw. 

 

Deleting Email 

If you don‘t want to keep email into your inbox, you can delete it by simply selecting the 

message from the message list and clicking delete or pressing the appropriate 

command. 

Some mail clients offers the deleted mails to be stored in a folder called deleted items or 

trash from where you can recover a deleted email. 

 

Composing and Sending Email 

Before sending an email, we need to compose a message. When we are composing an 

email message, we specify the following things: 

● Sender‘s address in To field 

● Cc (if required) 

● Bcc (if required) 

● Subject of email message 

● Text 

● Signature 

You should specify the correct email address; otherwise it will send an error back to the 

sender. 

Once you have specified all the above parameters, It‘s time to send the email. The mailer 

program provides a Send button to send email, when you click Send, it is sent to the mail 

server and a message mail sent successfully is shown at the above. 

 

Viewing and running file attachments 

Attaching file in mail 

Ability to attach file(s) along with the message is one of the most useful features of 

email. The attachment may be a word document, PowerPoint presentation, audio/video 

files, or images. 
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● In order to attach file(s) to an email, click the attach button. As a result, a dialog 

box appears asking for specifying the name and location of the file you want to 

attach. 

● Once you have selected the appropriate file, it is attached to the mail. 

 

Viewing and downloading Attachment 

● Login to your account.  It will display the Inbox. 

● If the mail has any attachment, it will be displayed under the message as shown 

below. 
 

 

● Click on the mail to download attachment.  To download file, click the button shown 

below.  Select a folder location and then click save. 
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Addressing with cc and bcc 

 

 

CC and BCC are two fields that sit next to or below the ―To‖ field at the top of any new 

message you compose in your inbox. CC stands for ―Carbon Copy‖ and BCC stands for 

―Blind Carbon Copy‖. All are used to add the email addresses of the people you wish to 

send your message to. However, they differ significantly in their usage. 

 

To CC BCC 

Primary contact/s Secondary contact/s Tertiary contact/s 

Used for emailing individual or 

multiple contacts 

Used for emailing individual or 

multiple contacts 

Used for emailing individual or 

multiple contact 

Email addresses viewable by 

all 
Email addresses viewable by all 

Email addresses viewable only 

by the sender 

7.3 Introduction to various devices & Applications (Electronic Gadgets) 

Electronic Gadgets (Other than the computers) 

● Mobile phones 

● Tablet computers 

● E-readers 

● Storage devices, such as flash drives 
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7.3.1 Tablet, Smart Phone 

Tablet vs Smartphone 

Smart phones and tablets are the hottest gadgets nowadays. Even though tablets and 

smart phones look pretty much the same, there are still major differences between them. 

The main difference between tablets and smart phones is obviously the size. Tablets are 

much bigger than smart phones, and the screen size is typically the basis of 

measurement. Tablets range from models with 7 inch screens, with models around 10 

inches being the most popular, and there also models that have even larger screen sizes. 

Smart phones are much smaller with most models sporting 4 inch screens. It is 

important for smart phones to be small since majority of people carry them in their 

pockets, especially men. 

There is also a difference when it comes to the applications that you are able to run. 

Tablets and smart phones typically share the same operating; Android tablets and smart 

phones, as well as the iPad and the iPhone. But there are applications that only run in 

tablets and not in smart phones. This is not because of limitations in the processor but 

usually because of the impracticality of small screens with the app. 

When it comes to network connectivity, smart phones trump tablets. Virtually all smart 

phones have WiFi and 3G connectivity, the latter is basically a given since connecting to 

a cellular network is a must for smart phones. Tablets have WiFi at the very least for 

connectivity, but only high-end and pricier models feature 3G connectivity. 

Despite having a wide array of uses, the primary function of smart phones is still for 

communication. Tablets on the other hand are not intended as phone replacements. 

Although some tablets have the ability to send SMS or do calls, many do not. You can 

immediately rule out tablets that do not have 3G as the hardware is necessary for this 

functionality. And even if your tablet allows you to make calls, you would probably have to 

purchase a Bluetooth headset as it is rather awkward to hold a large tablet to your face. 

 

7.3.1.1 Concept of Mobile Phone and Tablet and their uses 

A mobile device is a general term for any type of handheld computer. These devices are 

designed to be extremely portable, and they can often fit in your hand. Some mobile 

devices—like tablets, e-readers, and smartphones—are powerful enough to do many of 

the same things you can do with a desktop or laptop computer. 

Tablet computers 

Like laptops, tablet computers are designed to be portable. However, they provide a 

different computing experience. The most obvious difference is that tablet computers 

don't have keyboards or touchpads. Instead, the entire screen is touch-sensitive, allowing 

you to type on a virtual keyboard and use your finger as a mouse pointer. 

Tablet computers can't necessarily do everything traditional computers can do. For many 

people, a traditional computer like a desktop or laptop is still needed in order to use 

http://www.differencebetween.net/category/technology/hardware-technology/
http://www.differencebetween.net/category/object/gadgets-object/tablets/


P a g e  | 384 

 

some programs. However, the convenience of a tablet computer means it may be ideal 

as a second computer. 

 

E-readers 

E-book readers—also called e-readers—are similar to tablet computers, except they are 

mainly designed for reading e-books (digital, downloadable books). Notable examples 

include the Amazon Kindle, Barnes & Noble Nook, and Kobo. Most e-readers use an e-

ink display, which is easier to read than a traditional computer display. You can even 

read in bright sunlight, just like if you were reading a regular book. 

 

You don't need an e-reader to read e-books. They can also be read 

on tablets, smartphones, laptops, and desktops. 

 

Smart phones 

A smartphone is a more powerful version of a traditional cell phone. In addition to the 

same basic features—phone calls, voicemail, text messaging—smartphones can connect 

to the Internet over Wi-Fi or a cellular network (which requires purchasing a monthly data 

plan). This means you can use a smartphone for the same things you would normally do 

on a computer, such as checking your email, browsing the Web, or shopping online. 

Most smartphones use a touch-sensitive screen, meaning there isn't a physical keyboard 

on the device. Instead, you'll type on a virtual keyboard and use your fingers to interact 

with the display. Other standard features include a high-quality digital camera and the 

ability to play digital music and video files. For many people, a smartphone can actually 

replace electronics like an old laptop, digital music player, and digital camera in the 

same device. 
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7.3.2 Applications of Google forms, Google sheets, Google Slides 
 

Applications of Google Forms 
 

1. Google forms are used to create surveys to meet curriculum objectives 

2. Can be used to ask Various Types of Questions like 

● Text 

● Paragraph Text 

● Multiple Choice 

● Checkboxes 

● Choose from a list 

● Scale 

● Grid 

● Date 

● Time 

3. Possible to Apply Validation Options to Control Data Entry 

4. Google Forms helps to Create Professional Looking Forms using Themes 

5. Google Forms helps us to collect data using multiple methods.  

● A form can be included in the body of an email allowing a respondent to submit 

their responses from their Inbox.  

● A link can be generated allowing respondents to answer the questions using a 

web-based form.  

● Code can be generated and then embedded into a blog or web page as another 

option for data collection. 

 

Applications of Google Sheets 
 

1. Editing 

One of the key features of Google Sheets is that it allows collaborative editing of 

spreadsheets in real-time. Rather than emailing one document to multiple people, a 

single document can be opened and edited by multiple users simultaneously. Users can 

see every change made by other collaborators, and all changes are automatically saved 

to Google servers.  Google Sheets also includes a sidebar chat feature that allows 

collaborators to discuss edits in real-time.  
 

2. Explore 

The Explore feature in Google Sheets was first introduced in September 2016, and it 

uses machine learning to bring additional functionalities. This feature provides a lot of 

information based on the data added to the spreadsheet, and it can auto-update itself 

depending on the selected data.  With the Explore feature, users can ask questions, build 

charts, visualize data, create pivot tables, and format the spreadsheet with different 

colors.  
 

3. Offline editing 

Google Sheets supports offline editing, and users can edit the spreadsheet offline either 

on desktop or mobile apps.  
 

4. Supported file formats 
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Google Sheets supports multiple spreadsheet file formats and file types. Users can open, 

edit, save or export spreadsheets and document files into Google Sheets. Some of the 

formats that can be viewed and converted to Google Sheets include: .xlsx, .xls, .xlsm, .xlt, 

.xltx, .xltxm, .ods, .csv, .tsv 
 

5. Integration with other Google products 

Google Sheets can be integrated with other Google products such as Google Form, 

Google Finance, Google Translate, and Google Drawings. For example, if you want to 

create a poll or questionnaire, you can input the questions in Google Forms, and then 

import the Google Forms into Google Sheets. 

 

Applications of Google Slides 

1. Using  Google Slides we can create Lectures and Presentations 

2. It is used to create Pre-Class Slides for the Flipped Classroom 

3. Possible to create Animated Diagrams and Demonstrations 

4. We can conduct Polls and Assessment Check-Ins between the lecture 

5. It is possible to design Posters and Display Work in a Digital Gallery or Poster Session 

6. Used to Create Illustrations by Adding Slides to Google Sites, a Blog, or Canvas 

7. It is having features like Sticky Note Board and Interactive Notebooks 

8. Provides features to Lock the Background of a Slide 

 

7.3.3 Scanning Image using Scanner and edit it using tools available  

Click Start, type: devices and printer then hit Enter. Right-click your scanner or printer, 

then click Start Scan. 

 

 

Users have several options on the screen which let you preview the document, choose a 

color format (color or black and white), adjust brightness, set the appropriate resolution, 

and even choose the format you want to save it in: JPEG, PDF, or PNG. If you are satisfied 

with the results after reviewing the document, proceed to click Scan. 

https://clt.champlain.edu/kb/creative-uses-google-slides/#%E2%80%9Dlectures-and-presentations%E2%80%9D
https://clt.champlain.edu/kb/creative-uses-google-slides/#%E2%80%9Dflip-classroom%E2%80%9D
https://clt.champlain.edu/kb/creative-uses-google-slides/#%E2%80%9Danimated-diagrams%E2%80%9D
https://clt.champlain.edu/kb/creative-uses-google-slides/#%E2%80%9Dadd-polls%E2%80%9D
https://clt.champlain.edu/kb/creative-uses-google-slides/#%E2%80%9Ddesigning-posters%E2%80%9D
https://clt.champlain.edu/kb/creative-uses-google-slides/#%E2%80%9Ddigital-gallery%E2%80%9D
https://clt.champlain.edu/kb/creative-uses-google-slides/#htoc-create-illustrations
https://clt.champlain.edu/kb/creative-uses-google-slides/#%E2%80%9Dadd-slides-sites-blogs%E2%80%9D
https://clt.champlain.edu/kb/creative-uses-google-slides/#%E2%80%9Dsticky-note-board%E2%80%9D
https://clt.champlain.edu/kb/creative-uses-google-slides/#%E2%80%9Dinteractive-notebooks%E2%80%9D
https://clt.champlain.edu/kb/creative-uses-google-slides/#%E2%80%9Dlock-background%E2%80%9D
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Make your selections, Click Preview to ensure everything looks good then click Scan. 

 

After giving your scanned document a Name, add a few tags to make it easier to search 

for later. Click Import. 

 

 

Your scanned document can normally be found in Pictures within the scanned files 

folder. 
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Edit using tools available by default in Windows Operating System 

The User Interface of Scanner 

The interface is quite similar to the old scanning utility. You can preview your document, 

crop it before scanning the final document, adjust resolution, select appropriate file 

formats and choose your save location. 
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When ready, click Scan then review the scanned document. 

 

Edit using tools available by default in Linux Operating System 

Simple Scan 
 

Simple Scan is a lightweight Scanner utility with a handful of editing features. It allows 

you to scan documents at the click of a button, rotate and/or crop your scan, and save it 

as JPG, PNG, or PDF.  By default, it uses 300dpi for photos and 150dpi for text – settings 

you can edit in its preferences menu.  Simple Scan is the default scanner app on many 

Linux distros including the GNOME desktop. 

 

 
***** 
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